Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
roytam1

Win98SE: Firefox SSL broken?

Recommended Posts

I formatted hard disk and reinstall Win98 SE but I still get this when starting Firefox:

xZURFUc.png

does it need IE6?

Share this post


Link to post
Share on other sites

Reply to myself: no it doesn't need IE6. Deleting profile folder works.

Share this post


Link to post
Share on other sites
30 minutes ago, LoneCrusader said:

Which version of Firefox? Official or forked?

So do you mean you fixed it by deleting the profile folder?

If not, these might be relevant.

ADS Client for Windows 9x

Windows 98 128-Bit SSL SECUR32.DLL 4.10.2228

I'm trying to create a build that is working in win98 without kex, and I first tried official build.

and yes I mean that, deleting profile folder and let it recreate new profile.

Share this post


Link to post
Share on other sites

Firefox 2.0.0.20 always worked for me under 98SE with no weird issues like this, and I didn't have to install anything else either. :unsure:


Firefox 2.0.0.20 also runs under 95 OSR2 with a couple of small tweaks (delete "nsSearchService.js" and nsSafebrowsingApplication.js" prior to running the build; {IIRC this is all that is required, it's been a while :lol:}), so 2.0.0.20 is a good testbed to see what should be working.

Share this post


Link to post
Share on other sites

Hey, thanks for the fix! I've been experiencing the same message on *some* (but not all) fresh installs.

But a question: When you say "profile folder", could you specify the exact path? I've found a few different locations, both in the installation folder and the Windows folder that have the name "profile" or "profiles":
- Firefox\defaults\profile
- C:\Windows\Application Data\Mozilla\Firefox\profiles
- C:\Windows\Local Settings\Application Data\Mozilla\Firefox\profiles

Each of them contain various files.

Thanks.

- Doug B.

Share this post


Link to post
Share on other sites
30 minutes ago, DougB said:

Hey, thanks for the fix! I've been experiencing the same message on *some* (but not all) fresh installs.

But a question: When you say "profile folder", could you specify the exact path? I've found a few different locations, both in the installation folder and the Windows folder that have the name "profile" or "profiles":
- Firefox\defaults\profile
- C:\Windows\Application Data\Mozilla\Firefox\profiles
- C:\Windows\Local Settings\Application Data\Mozilla\Firefox\profiles

Each of them contain various files.

Thanks.

- Doug B.

both :)

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×