Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Radish

Suddenly Windows Wakes up from Sleep After 30 Seconds - How to Fix?

Recommended Posts

Been using my computer for years now and frequently put it into sleep mode. Never had any problems with this in the past. Then, suddenly, yesterday, this stopped working properly. Now if I put the computer to sleep it only sleeps for about 20-30 seconds then it wakes up again. d***!

I use sleep a lot. How do I fix this?

Edited by Radish

Share this post


Link to post
Share on other sites

Try to isolate the waking factor. May be it is malfunctioning mouse or keyboard? Or unwanted network activity? You may check them by disconnecting these devices one by one and try put your system to sleep. Also, tell more about your hardware.

  • Like 1

Share this post


Link to post
Share on other sites
37 minutes ago, Yellow Horror said:

Try to isolate the waking factor... unwanted network activity?

Doh! :blushing:

Thanks for the memory jogger. Yesterday I changed my router mode to "modem only". I just tested by going back to full "modem and wireless mode" (which is what I've always had it on since I got the router years ago) and the computer was able to sleep again.

However, now I'm wondering what is it about "modem only mode" that is making it impossible for my computer to sleep? The router is a Virgin Media Super Hub 2 Router. I don't know anything  about routers and networking so if anyone can tell me what is going on with this I'd be very grateful. And if someone could tell me how to get this router into "modem only mode" and still get my computer to sleep I'd be even more grateful still.

Edited by Radish

Share this post


Link to post
Share on other sites
2 hours ago, Radish said:

The router is a Virgin Media Super Hub 2 Router.

I don't know anything about this particular router. But it seems that in "modem only" mode it exposes your PC for unwanted network activity from the Internet. I may try to help you with the settings, if you give me link to user's manual for the router.

The workaround for you is to find and disable "wake on LAN" feature in your PC BIOS setup. I think, you really don't need it to be enabled.

  • Like 1

Share this post


Link to post
Share on other sites

Thank you so much, Yellow, for your very helpful tips and comments. Hugely appreciated. :)

I went into the BIOS and looked for a "Wake on LAN" setting, no such setting to be found. Then I searched the web for any help on this and came across this webpage: What Is Wake-on-LAN, and How Do I Enable It? Once I read that back into the BIOS and look for anything in the form of “Power on by PCIE/PCI”. No such setting exists in my computer's BIOS.

Then, again from that webpage, I looked at these settings in Windows 7:

K2TSreq5_o.png

So that solved my immediate problem with the computer waking out of sleep. However, I have a question regarding this when you say:

On 6/21/2018 at 4:26 PM, Yellow Horror said:

But it seems that in "modem only" mode it exposes your PC for unwanted network activity from the Internet.

Could you clarify that a little for me (I'm quite ignorant on these matters)? Are you saying that there are random attempted internet connections trying to get into my computer in "modem only mode"? Or are you suggesting that someone must be deliberately trying to hack into my computer? I mean I'm not clear on what you mean when you say, "exposes your PC for unwanted network activity from the internet". What does that mean? What could the "unwanted network activity" be?

Also with respect to this, the reason why I'm putting my Virgin Media (VM) Super Hub 2 router into modem only mode is that I intend to cancel my VM fibre connection (too expensive for me now) and replace it with an ADSL (down an phone line) internet connection (cheaper but slower). In preparation for that I got an TP-Link Archer VR2800 modem router. So I was putting my VM modem router into modem only mode so that I could connect the Archer to it and test that the Archer was working okay. I spent most of yesterday night and most of today trying to connect them together and get them to work and in the end I actually managed to get it to work. Yippee! But here is the curious thing for me. Once I had them connected, and having my network adapter enabled for "Allow this device to wake the computer" but disabled for "Only allow a magic packet to wake the computer", I found that my computer wasn't waking unexpectedly from sleep. I don't understand how this can be, given that my VM router is still set to modem only mode -- and hence was still effectively providing the internet connection -- but now it wasn't resulting in the computer waking from sleep. Would you know of any reason why this should be?

P.S. With respect to a manual for the VM Modem Router I could only find a "Setup" manual which is of no use at all as it doesn't provide any detail on the router settings, just how to get the thing working and no more. Not that it matters much to me now, next month and I won't be using it at all.

Edited by Radish

Share this post


Link to post
Share on other sites
12 hours ago, Radish said:

So that solved my immediate problem with the computer waking out of sleep.

Yes, this is valid workaround also.

12 hours ago, Radish said:

Once I had them connected, and having my network adapter enabled for "Allow this device to wake the computer" but disabled for "Only allow a magic packet to wake the computer", I found that my computer wasn't waking unexpectedly from sleep.

Was your PS network cable connected to Archer or to Super Hub at the time?

12 hours ago, Radish said:

Are you saying that there are random attempted internet connections trying to get into my computer in "modem only mode"? Or are you suggesting that someone must be deliberately trying to hack into my computer?

Either is probable.

I found Super Hub 2 user's manual, but there is no "modem only" mode description in it. Web search give me some clues, that the "modem only" mode disables not just WiFi function, but routing functions also, leaving only one Ethernet port on the Super Hub to down-link connection. Is this information correct?

If so, i am sure that "modem only" mode means "bridge mode" in which any device down-linked to Super Hub is reachable directly from the Internet. Placing the Archer (in "router" mode) in-between the bridge (Super Hub) and your PC, you again isolate the PC from unwanted network activity coming from the Internet.

I strongly suggest you to not use "modem only" mode with your PC directly connected to Super Hub, because in this configuration everyone in the Internet can discover your PC and try to hack it. Of course, Windows 7 (if properly updated and configured) have its own defensive layer against unwanted connections. But it isn't even close to most hardware routers security.

Edited by Yellow Horror
  • Like 1

Share this post


Link to post
Share on other sites
14 hours ago, Yellow Horror said:
18 hours ago, Radish said:

Once I had them connected, and having my network adapter enabled for "Allow this device to wake the computer" but disabled for "Only allow a magic packet to wake the computer", I found that my computer wasn't waking unexpectedly from sleep.

Was your PS network cable connected to Archer or to Super Hub at the time?

Hi, Yellow. I take that you meant "PC" and not "PS" (I'm not sure what "PS" stands for).  The Super Hub was in modem only mode  (and, obviously, connected to the VM cable wall socket where the physical internet fibre optic connection cable comes into my house) then I had an Ethernet cable from the Super Hub to the Archer and then another Ethernet cable from the Archer to the computer. So, basically, both routers were in operation, connected together, and providing the internet connection. (The Archer is what I think is called and ADSL2+ modem router and is, as far as I understand it, physically incapable of being directly connected to a fibre optic cable internet connection and provide an internet connection via that means. If I'm wrong about that I'd be grateful if you would let me know.)

Given the struggles I was having in trying to connect the two routers together and get an internet connection I emailed TP-Link and asked for a couple of hints on how to do this. They responded that to get them working together the Super Hub must be on modem mode and the Archer must be on WI-FI router mode (i.e. not also operating as a modem). There were a couple of other hints on how to do essential configuration that had to be made in the Archer's settings to get the two routers to work together with a VM internet connection.

Above said, I was mulling over this last night: why the computer could go into sleep and stay that way with the two routers connected together? Then it occurred to me that it is most likely that the Super Hub was still "under attack" but that the (connected to the Super Hub) Archer was rejecting the "random" internet network traffic being sent to it from the Super Hub (assuming that the Super Hub was passing that traffic to the Archer). Does that sound about right to you? Or could there be other reasons?

14 hours ago, Yellow Horror said:

I found Super Hub 2 user's manual, but there is no "modem only" mode description in it. Web search give me some clues, that the "modem only" mode disables not just WiFi function, but routing functions also, leaving only one Ethernet port on the Super Hub to down-link connection. Is this information correct?

Yes, that information is correct. In modem only mode there is only one Ethernet port functional on the Super Hub. That is the port that is lowest down (closest to the base) of the Super Hub when the Super Hub is standing upright (the other Ethernet ports are disabled). In the Super Hub browser interface that allows configuring of the Super Hub in modem only mode it says, "When active, Modem Mode disables the wireless and routing functions of your Super Hub so you can use your own wireless router." So when connected the Super Hub in modem mode to the Archer you have to (a) connect the only active Ethernet port on the Super Hub to the Archer's "LAN4/WAN" port, then (b) you connect the Archer to the computer via any other available Ethernet port on the Archer. But here is the catch I discovered purely by accident to doing this. I had struggled for a day and half to try to get this to work and it just wouldn't work so I decided to check (again! for the four-hundredth time!) that I had the two routers connected via the correct Ethernet ports. I checked the Super Hub it was fine. Then I unplugged both the Ethernet cables at the back of the Archer and plugged it together again to make sure I had them in the correct ports (I did) and suddenly, for no reason that was immediately obvious to me, the internet connection started working (whereas it had never worked before). So what was the difference this time round? The difference was in the order in which I connected the Ethernet cables to the Archer. Seems that you need to first connect the computer to any of the Archer's LAN(n) ports and only after that has been done do you connect the cable from the Super Hub to the Archer's LAN4/WAN port. (You do this with both routers powered on at the time.) Thinking about that, after the internet connection was suddenly working, I thought that this was odd that it had to be done in that order, but I thought, as that seemed to be the case, this was probably a problem with some part Windows 7 rather than the two routers. If you have any comments to make on this I would be grateful for them. I don't understand why this should be so.

14 hours ago, Yellow Horror said:

If so, i am sure that "modem only" mode means "bridge mode" in which any device down-linked to Super Hub is reachable directly from the Internet. Placing the Archer (in "router" mode) in-between the bridge (Super Hub) and your PC, you again isolate the PC from unwanted network activity coming from the Internet.

Yes! Now I understand what you are writing, Yellow. Yes that sounds like exactly what is happening. I'll now have to do some research on what "bridge mode" means in a little more detail.

14 hours ago, Yellow Horror said:

I strongly suggest you to not use "modem only" mode with your PC directly connected to Super Hub, because in this configuration everyone in the Internet can discover your PC and try to hack it. Of course, Windows 7 (if properly updated and configured) have its own defensive layer against unwanted connections. But it isn't even close to most hardware routers security.

Yes, I think I'm beginning to understand this a bit better now. Thanks for the comment. As to Windows 7 I only use default fresh install of it (though I tweak that a lot, of course), have never updated it and never will -- I don't want Windows 10, or any of its associated components, rammed down my throat by Microsoft. If ever I change my computer it'll be a bog standard install of Windows 8.1 (and no updates) or Linux, never ever would I accept a computer that was Windows 10.

Thanks again for your responses, Yellow. Much appreciated, I've learnt quite a bit through this. And discovered, by accident, how to successfully connect a Super Hub to an Archer and get it to actually work! :)

Edited by Radish

Share this post


Link to post
Share on other sites
14 minutes ago, Radish said:

So what was the difference this time round? The difference was in the order in which I connected the Ethernet cables to the Archer. Seems that you need to first connect the computer to any of the Archer's LAN(n) ports and only after that has been done do you connect the cable from the Super Hub to the Archer's LAN4/WAN port. (You do this with both routers powered on at the time.) Thinking about that, after the internet connection was suddenly working, I thought that this was odd that it had to be done in that order, but I thought, as that seemed to be the case, this was probably a problem with some part Windows 7 rather than the two routers. If you have any comments to make on this I would be grateful for them.

It is hard to say something for sure without reproducing and thoroughly investigating your network configuration in the "bad" state, but i think the trouble was somehow linked to DHCP services and IP address leasing. Try to power off/on the Archer while all the cables remain connected. If the trouble won't reappear, i think, there is nothing to worry about.

21 minutes ago, Radish said:

As to Windows 7 I only use default fresh install of it (though I tweak that a lot, of course), have never updated it and never will

Then i suggest you (again) to not use "modem only" mode with your PC connected directly to Super Hub. And also to check your PC with some of antivirus/anti-malware scanners to be sure that the probable hackers' attack against the PC while it was exposed to the Internet remain unsuccessful.

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, Yellow Horror said:

Try to power off/on the Archer while all the cables remain connected.

Done. No problems.

1 hour ago, Yellow Horror said:

check your PC with some of antivirus/anti-malware scanners

Scanned. No problems. And, yes, I'll now never have the Super Hub in modem mode directly connect to my computer. I'll just leave it connected to the Archer, which I want to keep using anyway as the Wi-Fi performance is better than the Super Hub.

Thanks again.

Share this post


Link to post
Share on other sites

IF disconnecting the network interfaces don't work, it had to be a malware infection. Let's just say it might be. Spyware trojan dysfunctions the system settings and your basic settings changes and personalization don't work. Up to my knowledge, K7 Total Security  detects spyware trojan. You can also try scanning with a good antivirus like Norton or AVG.

Edited by leo321
  • Like 1

Share this post


Link to post
Share on other sites
On Σάββατο, 23 Ιουνίου 2018 at 4:51 PM, Radish said:

If ever I change my computer it'll be a bog standard install of Windows 8.1 (and no updates)

In this case you should install Update 1 (it has no telemetry and it corrects a bunch of Windows 8.1 bugs).

Edited by HarryTri
  • Like 1

Share this post


Link to post
Share on other sites
19 hours ago, leo321 said:

IF disconnecting the network interfaces don't work, it had to be a malware infection.

Leo, my computer is clean, no problems. I just followed Yellow Horror's advice and things all checked out fine. Computer sleeps okay now and no unexpected wake-ups of any kind. But thanks for the thought.

17 hours ago, HarryTri said:

In this case you should install Update 1 (it has no telemetry and it corrects a bunch of Windows 8.1 bugs).

Thanks for mentioning that Harry, keeping me straight on things. The installer ISO for Win 8.1 that I have has Update 1 integrated. So create an install DVD from the ISO and the installer already gets me to Update 1 level. That is what I meant by a "bog standard" install of Win 8.1 -- for me that would automatically be to Update 1 level. To be honest I didn't know that Update 1 fixed "a bunch of bugs" -- so you are correct I was ignorant of that. The ISO I have was an official Microsoft release, checked fine against Microsoft MSDN's own hashes for the ISO at the time I downloaded it, so no problems there.

All above said my current computer will likely last me a long time -- and I'm starting to get on in years so it might outlive me. Have Win7 Pro. x64 SP1 installed, no updates, and runs with no problems at all, has done so for a couple of years, solidly stable.  If push comes to shove and I ever do have to change OS I might just give Win8.1 a pass, (had it installed for a while, didn't like it, went back to Win7) and go for Linux Mint, which I ran for a couple of years. Pretty good it was too. Only thing that pushed me back to Windows was the need to use MS Office for work and the lack of a Linux DVD burner that could in any way reliably burn multi-session DVD's. So was dual-booting (which I didn't like doing, pest) between two OSes just to deal with those two factors. If it wasn't for those factors I'd still be on Mint. As it stands now I very, very rarely want to burn multi-session DVD's, so that factor isn't as important to me as it was, and the necessity for MS Office will evaporate for me within the next two years, yippee!

Share this post


Link to post
Share on other sites

Just as a test, change the mouse for another one. A brand-new el cheapo will do. Then keep the new one on for a whole day and see whether the issue disappears...

  • Like 1

Share this post


Link to post
Share on other sites
31 minutes ago, dencorso said:

Just as a test, change the mouse for another one.

Hi, dencorso,

This isn't necessary the information that Yellow Horror give was definitely the cause of what was happening - that and that I had a Windows setting made that allowed internet activity to wake the computer once it had gone to sleep (as detailed in posts above). Basically, I had one router, a Virgin Media Super Hub 2, connected to the computer in modem only mode. Seems that when this is done then, as Yellow Horror correctly identified, the router only acts as a bridge and hence has no firewalling functionality (in that mode) and hence my computer was exposed to all internet activity aimed at it and that was what was waking the computer from sleep. If I then connected another router between the Super Hub and the computer the waking from sleep problem disappeared -- the second router was now providing firewalling functionality. Hence, the problem was using only the Super Hub in modem only mode which was exposing my computer to all internet activity aimed at my machine and that was what was waking it up.

Thanks for the thought though.

Edited by Radish
  • Like 1

Share this post


Link to post
Share on other sites

I don't know if this helps or even relates since I'm seeing Windows 8.1 referenced in a Windows 7 forum...

I had this same problem a couple of months ago, which I eventually traced to a change Microsoft put out in their patches (May updates I think).  It turns out that they added a different kind of sleep option ("hybrid sleep" I believe) and then enabled it.   My system didn't support that particular kind of sleep, so it'd just bounce back on if I tried to make it sleep.   On top of that, they locked out the settings so only "Administrator" could change them.  I can't find the settings referencing it now since my memory is foggy - and finding the setting was a pure PITA in the first place.  Edit: I went into the "Administrator" account and looked for the setting and couldn't find it anymore.  Evidently it was a recognized bug in a detection routine or something that they fixed in a later patch. 

Interestingly, they locked out the Windows Update setting in a similar way (stuck on "Never check for updates"), even if I enable "Administrator" and attempt to change it.  And when I went into "Administrator", I still couldn't change this.

winupdate01.jpg.e5f1b77fd3bf878f9e4fd2d9058359ca.jpg

 

Hopefully that'll be a good tip, if this is still a problem.

Edited by Glenn9999

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×