Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


666_peter_666

Aero Glass for Win8.1+ v1.5.7 and "Your DWM is incompatible"

Recommended Posts

Hello,

I bought a licence for Aero Glass for WIn10 10.0.16299, everything works fine, but at Windows boot still appear a well known small window with "Your DWM is incompatible".

I think, this is a question for Big Muscle, but does anyone know how to get rid off this annoying window? The "Again" button in this window does not work.

In fact, it looks like that: image.png.eb78f15409aab79a1526c5fde3945ac4.png

Thank you for help,

Peter

Edited by 666_peter_666
added screenshot

Share this post


Link to post
Share on other sites

I've had that happen before.  Usually, eventually after a windows version update, the symbols become available and download upon bootup.   Then it goes away.  

  • Like 1

Share this post


Link to post
Share on other sites

I have read somewhere, that donated copy of this Aero Glass will find and download the symbols themselves. But my copy does not.  I would do it on my own, if I found somewhere detailed manual how to do it.

Share this post


Link to post
Share on other sites

I think that I already wrote it some time ago, but the Microsoft implementation of the symbol downloading (symsrv.dll) has the bug if the download fails once for whatever reason (mostly internet connection failure), it will fail forever even the reason has already gone away. Thus I recommend to delete "Symbols" folder and try again... especially if there is download.error file somewhere.

Also, the real reason of the failure can be found in debug.log if the verbose logging is enabled.

  • Like 2

Share this post


Link to post
Share on other sites

Bigmuscle, please be more specific. Where the "Symbols" folder can be found?  And what then? Delete it and download some symbols from some MS page to the new folder "Symbols"? Which symbols to download?

Or when the folder "Symbols" will be deleted, AeroGlass will download symbols automatically?

I attach list of debug.log of today. Please, look at it and write me, what I should do to solve the problem? I am not a programmer, I am only user.

Thank you,

Peter

debug.txt

Share this post


Link to post
Share on other sites

Obviously symbols are located in Aeroglass' folder. In your case, that would be Program Files (x86). I suggest you reinstall AG in C:\Aeroglass.

Share this post


Link to post
Share on other sites

If someone installs the Aero Glass into Program Files, it is only his problem that it is not able to download and store the symbols. It has been said milliontimes that it mustn't be installed there and even the guide mentions "Important thing is that you must place all files in writable location (i.e. not in Program Files),, because DWM process does not run under user's credential. If you don't do this, Aero Glass will not be able to download symbols".

Also the note about debug.log "if the verbose logging is enabled" was not probably too bold and underlined.

  • Like 2
  • Upvote 1

Share this post


Link to post
Share on other sites

Same here. Win 10 64-bit Build 10.0.16299.192. Aeroglass is installed in C:\Aeroglass. I am getting hook DWM error on every boot. Couldn't figure out how to actually install proper Symbols.

Edited by Yautja Hunter

Share this post


Link to post
Share on other sites

Just did a quick test on my end, installing Aero Glass in Program Files does not interfere with its functionality, symbols just end up in C:\ProgramData\dbg folder instead. If one has to have it installed in Program Files and wants symbols to appear in AeroGlass folder, "Authenticated Users" group must be granted at least read/write access to the folder (folder's properties, Security tab).

My guess is that people here have some other problem, but since enabling verbose logging is too difficult, despite the fact that registry setting for it is documented on Aero Glass's website and a tool being available that makes enabling it as easy as flipping a single checkbox, we can't really know what's going on.

Still, @bigmusclecould bundle dbghelp.dll and symsrv.dll files from the latest Debugging Tools for Windows. The versions provided are about 2.5 years old.

Edited by UCyborg

Share this post


Link to post
Share on other sites

So, I uninstalled AG from Program Files folder, install it to C:\Aeroglass, but I still do not see any subfolder "Symbols" under Aeroglass folder. Also I tried to install AG to another folder, with no luck. There is no "Symbols" folder.

But I remember, when I very first time install a trial copy of AG (v 1.5.7 unregistered), there was no error window, only window for a donation there popuped. Error window appeared just after registration.

My OS:  image.png.97460e174839890be37af4249cafd07a.png

Edited by 666_peter_666

Share this post


Link to post
Share on other sites
9 hours ago, Yautja Hunter said:

Same here. Win 10 64-bit Build 10.0.16299.192. Aeroglass is installed in C:\Aeroglass. I am getting hook DWM error on every boot. Couldn't figure out how to actually install proper Symbols.

This was also driving me crazy until I figured out (by looking at the debug file from the latest experimental version 1290) that AeroGlass was unable to download:
http://msdl.microsoft.com/download/symbols/dwmcore.pdb/4DFDA14B2ACD35B23AC37976303DB51A1/dwmcore.pdb

Finally, by simply manually pasting the above link into my browser, I was able to download the above required symbol file. I then had to manually create a subfolder with the name "4DFDA14B2ACD35B23AC37976303DB51A1"
in the '..symbols\dwmcore.pdb' folder, and then copied the 'dwmcore.pdb' file into this new subfolder.

Everything worked great from that moment forward!  Hope this helps anyone!
-JT

  • Like 4

Share this post


Link to post
Share on other sites
21 hours ago, UCyborg said:

My guess is that people here have some other problem, but since enabling verbose logging is too difficult, despite the fact that registry setting for it is documented on Aero Glass's website and a tool being available that makes enabling it as easy as flipping a single checkbox, we can't really know what's going on.

I did enable verbose logging in registry, but it doesn't seem to work. Also, what's the tool for that?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×