Jump to content

Weird internet problem in Windows 95


punio
 Share

Recommended Posts

I'm having this really weird internet problem in Windows 95. This never happened before when I installed Windows 95 previously, but it is now. I tried everything, including uninstalling the Windows Desktop Update and installing Firefox 1.5.0.9, but none of it's working.

Basically, every web page I visit, it says 'Detecting proxy settings...' for a bit, then gives me a 'The page cannot be displayed' error. The TCP/IP protocol has been installed, TLS 1.0 has been turned on, and I have 128-bit encryption installed, but it still won't work. I'm using a VMware Virtual Machine with an AMD PCNET Family ethernet adapter (which has been binded to TCP/IP), which is connected via NAT (my physical connection is fine), and I have Internet Explorer 5.5 SP2 installed with Java 1.3.1_20. Does anyone have any idea what's happening?

1.PNG

2.PNG

3.PNG

4.PNG

Link to comment
Share on other sites


Before we blame the operating system (win95) or blame it's configuration.  We should do a few things.

Make sure VMware bridge protocol is binded to your host machine LAN adapter.

1.  On the host machine/hypervisor run start run CMD type in the command prompt ipconfig /all  Take note of your default gateway address, your DNS adress, and you iprange and subnet.

2.  Edit the virtual machine adapter and change it from NAT to bridged.  This should be in VMware settings or whatever for the VM you made up.

3 Boot up 95 and open network from the control panel.  Find Item listed TCP/IP click properties.  Specify and IP adress. if your host machine IP is like 192.168.1.2 as example.  Make the adress 192.168.1.50 in the same IP range.  Enter in the same subnet mask as the host machine.  usually its like 255.255.255.0  example.  Click DNS configuration tab.  and enable DNS.  type DNS as the host.  Now add your DNS settings.  that you got from IPconfig earlyer.  

4.  click OK.  It may want you to insert the 95 CD or point it to the windows system folder whatever just dont overwrite newer files.

5.  Reboot the computer. and try to ping google or use the internet.

6.  Stop using internet explorer.  Use Retrozilla  link below.  Your issues have nothing to do with IE but IE is terrible none the less.

7. if this worked than the problem is with your NAT configuration.  If this didn't work than your problem is windows 95 config.

8. I 100% bet this is not a problem of 95 but a problem of how you configured your system.

Edited by Destro
Link to comment
Share on other sites

As of right now, Google.com (not google.co.uk) works on Internet Explorer 5.5, but not on Internet Explorer 6. Bing crashes IE5.5 and unless you use a different browser, you won't be able to use the search engine. You can still do a basic search for websites under Google, but most of the websites under that browser will not work correctly, if not at all.

Here's a screenshot:

google.thumb.png.8f42d7b2fab171541a079b21a9a9d30c.png

I recommend that you use a working browser if you're running Windows 95 such as the latest version of Retrozilla. :)

Link to comment
Share on other sites

If you are not using a proxy server, uncheck the box to automatically detect a proxy server in Internet Options.

Verify you have a valid IP address. If you have a valid IP address, verify that DNS works. You can do this by running these two commands:

ping google.com
ping 172.217.11.46

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...