Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


bizzybody

Making a disk image in Windows 10

Recommended Posts

I need to make a full image of a 64 megabyte IDE Disk On Module and have it work with DOSbox or some other DOS or PC emulator that can run DOS. I also need to be able to write the image back to the DOM so it can boot the thin client it's normally installed in.

All I need to do to the DOM or an image of it is run FORMAT /S with the DOS that will be run from it. Then I can copy everything else to the DOM from within Windows, plug it back into the thin client and finish setting up everything from there.

I tried an uncompressed, full sector image with Macrium Reflect. DOSbox won't use that, can't get CHS info from the image.

If WYSE hadn't been so 'clever' with their BIOS I could simply make a bootable USB from Windows and boot the thin client from it and install DOS. But noooo, they had to put in a roadblock. It can be worked around, this guy did it with a linux kernel patch. Should be possible to write a little DOS program to do the same hack, but I'm not a programmer.

http://www.parkytowers.me.uk/thin/wyse/s10/Linux.shtml

Share this post


Link to post
Share on other sites

And what is the issue?

Making the image?

Try using any among dsfok, Clonedisk, DMDE.

http://members.ozemail.com.au/~nulifetv/freezip/freeware/index.html

https://labalec.fr/erwan/?page_id=42

https://dmde.com/

or *any* dd port.

Or re-deploy it to the physical device?

(this may give you some of the usual issues with access in *any* Vista and later OS, you will probably need to put it offline).

 

Forget about DosBox, use Qemu instead as a VM.


Reasons:

1) it uses "standard", "legacy" virtual hardware
2) can uses RAW images natively

 

About the guy, you referred to, he is a nice guy :) that collects good ol' terminal clients, in the specific case he did no kernel patch for booting, he had to make one (on an earlier version of the kernel) to have Linux run (which is another thing).

The issue (and it is not the first terminal client that behaves the same) might be that a given bootloader/bootmanager (in this or that version) may not work with them, due to some "queer" BIOS behaviour, either from the USB or from the internal (IDE) CF card only to give you an example (and not necessarily your specific case) I have one of these that:

1) boots from some versions of grub4dos ONLY
2) boots NOT from "legacy" GRUB
3) boots NOT from Syslinux (at least the versions I tried)
4) boots just fine with Win2K/XP NTLDR
5) boots just fine with plain DOS
6) boots just fine with PLoP BUT with it uses a "queer" geometry 

 

As long as you don't have an exceedingly large USB stick, it is still worth the effort to do a few experiments to boot from it.

Personally I would try a USB stick with a "normal" MBR and DOS, with grub.exe so that you can use its internal dd to create or deploy the image.

Please note how the grub4dos dd is "as slow as molasses", but since you have to make or deploy only 64 Mb that should not be an issue.

jaclaz

 

Share this post


Link to post
Share on other sites

OK, used Clonedisk to make an image. Glory be, a Windows utility that actually uses a GUI. Point, click, done. The way Xerox intended...

Got QEMU for Windows x64 downloaded and installed. Will work on this some more tomorrow.

Two reasons for fiddling with DOS on these old WYSE Sx0 thin clients. Main one is to have a tiny box for running the old DOS control software for a PLM2000 benchtop CNC milling machine. That will need the USB to work, I have the Panasonic universal USB drivers for DOS. All it needs to run the mill is one RS232C port, which the WYSE Sx0 series has. USB will only be for loading G-Code files. USB keyboard support is in BIOS, other than the serial port these are Legacy Free.

Secondary is setting one up as a tiny retrogame machine. The ethernet should work since it's a common Realtek chip for which there are DOS drivers. The sound is the iffy bit. Only VIA released AC97 DOS drivers. If their drivers and the chip WYSE used both were made strictly to the AC97 standard, the drivers may work with it. If that works, hello wee little DOOM machine. :) With up to 512meg DDR1 RAM and DOM's available from 64 meg to 8 gig, and the System On Chip faster than most 90's PCs, it should do well - if the sound will work. I don't think the SOC does MMX but what DOS software uses that? They're powerful enough to run normal Win 9x through XP but the swap file would soon destroy the DOM's chips. Would have to fit in some more durable type of storage.

Going to be some fun digging 25~30+ years ago DOS knowledge out of my head to setup the startup stuff. I used to have the perfect setup memorized.

I hope after all this the thin client has a sane memory map that will allow room for loading as much as possible high, and for XMS or EMS emulation to provide space for large G-Code files. I tried an old laptop but laptop memory maps post 1994 are a fragmented mess with nowhere large enough for an EMS window. Simply cannot setup any DOS on them for doing stuff like running games that use a DOS extender.

Share this post


Link to post
Share on other sites

Clonedisk x64's RAW image worked. Since there doesn't appear to be any up to date QEMU front ends for Windows, I used the old QEMU Manager 7.0 that comes with an older version of QEMU. I was able to install DOS to the RAW image then use Clonedisk to write it back to the Apacer DOM.

Now I just need to configure the autoexect.bat and config.sys files, plug it into the S30 and see if it'll work.

Share this post


Link to post
Share on other sites

And it doesn't work. It blocks MS-DOS from booting from IDE. I have an old FreeDOS image someone made for these thin clients, it boots, but everything is in French.

Share this post


Link to post
Share on other sites
6 hours ago, bizzybody said:

And it doesn't work. It blocks MS-DOS from booting from IDE. I have an old FreeDOS image someone made for these thin clients, it boots, but everything is in French.

No, it doesn't "block" MS-DOS, come on :) .

Describe what happens.

Very likely there is (as said these thin clients are pesky, and as well these tiny DOMs may behave "queerly") an issue with the geometry of the device, usually (but not always) FreeDOS is more tolerant, whilst DOS (also the exact version might be relevant) is more strict.

If you have a booting FreeDOS image, add to it:

grub.exe <- get it from here: http://dl.grub4dos.chenall.net/grub4dos-0.4.5c-2016-01-18.7z

and:

IO.SYS
MSDOS.SYS
COMMAND.COM 

from the DOS you are using.

Boot to FreeDos, and from it run grub.exe.

At the prompt, find out the geometry of the device (as seen when booted) with:

geometry (hd0)

then try booting DOS:

find --set-root /io.sys

chainloader /io.sys

boot

and report what happens.

jaclaz

 

 

 

 

Edited by jaclaz

Share this post


Link to post
Share on other sites

I just tried installing FreeDOS 1.2 Lite from a 512 meg USB drive onto a WYSE S30. Result? Failure.

It boots and launches the setup. First is says there's no fixed disk, then is says drive D: is not partitioned. So I have it partition and reboot.

Repeats this exactly the same. The BIOS *does* prevent some critical access to the IDE when booted from USB or when attempting to boot an OS from the IDE, except when using an OS and BIOS updater from USB or an OS from the IDE that came from WYSE.

The workaround at the bottom of this page will have to be implemented in FreeDOS in order to install it from USB. http://www.parkytowers.me.uk/thin/wyse/s10/Linux.shtml

Edit:

I found an "MS-DOS 7.1" boot floppy image and *this one* had no problems booting the S30 with a USB floppy drive, wiping the DOM and creating a fresh partition with FDISK, then rebooting and using format c: /s

NOW it's booted to a DOS prompt from the DOM.

So I'll try FreeDOS again......

Nope. Same as before. Screen full of No Fixed disks present, followed by a prompt to repartition D:, but it cannot touch it.

Edited by bizzybody
more info

Share this post


Link to post
Share on other sites

*all* or *most* DOSes tend to be very restrictive about which device they will boot from, essentially they must be on first, active, primary, partition of first hard disk, that has drive letter C: assigned (also drive 128 or drive 0x80).

This is where grub4dos (and its capability of exchanging/remapping disks) would become useful.

If you boot from USB a "hard disk like device" (i.e. a partitioned device) that will be first disk and th einternal one will become 2nd disk (and DOS won't ever "install" to a non-drive128 or non-C: volume).

A floppy (or emulated floppy such as an image or an El-Torito emulation floppy from CD) will work because it will get letter A:.

BTW, the FreeDos installer is notoriously an unneeded piece of crap that creates historically lots of issues.

Till now, nothing indicates that the particular patch (or a similar one) is needed,

I still believe that re-mapping the disks with grub4dos will work a threat (of course provided that grub4dos "sees" the IDE disk when booted from USB).

jaclaz 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...