Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Dreamweaver01

Thank You Big Muscle For New Aero Glass Build 1.5.7

Recommended Posts

On 12/25/2017 at 11:32 AM, evgnb said:

I have.

 

bug157.png

 

Yes! - I have similar window/control refreshing issues related to the blur effect.  I'm running the latest FCU with an Intel i7-7700K using only the onboard graphics.  Several programs are now intermittently leaving residual artifacts on the desktop after the app windows close. Also, several of my installed programs (Like MindManager 2018) will not display the ribbon properly while Aero Glass 1.5.7 is running. These blur-related/refresh glitches are almost a show-stopper. Would really appreciate you looking into this @bigmuscle

Share this post


Link to post
Share on other sites

On 12/28/2017 at 10:24 AM, UCyborg said:

Finally caught some glitches related to blurring feature (BlurDeviation) on the screenshots! They're shown on the program Windows Style Builder. I was getting the exact same glitches with the older debug version of Aero Glass when running Windows 10 natively with the newer NVIDIA card, but didn't suspect Aero Glass as the culprit at the time. The problem I'm seeing with the blurring enabled is that it simply causes parts of the screen to not refresh immediately...

  • Hovering over the tab with mouse causes it to refresh and display correctly:
  • Disable blurring and the glitches disappear.

Ditto!  As I said in my earlier post, Several programs are now intermittently leaving residual artifacts on the desktop after their app windows close/redraw/refresh.  For example: 1) TrueLaunchBar caption windows now often remain on the screen until I mouse over them again;  2)  MindManager 2018 will not properly display it's collapsed ribbon properly while Aero Glass 1.5.7 is running; 3) SyncBack Pro now intermittently leaves ghosted windows on the desktop after they are closed!  Unfortunately, I'm unable to take screenshots of these issues because taking a screenshot causes the desktop+windows to be refreshed, which wipes out the residual artifacts.

I've inspected the log file and nothing unusual is being generated.  No mini-dumps are being created either.

Disable blurring and these glitches disappear.

Please help @bigmuscle.  Let me know if I can give you any additional info!  Perhaps creating a screen video recording would allow me to demonstrate the glitches.  -JT

Share this post


Link to post
Share on other sites
6 hours ago, Alanrh said:

Is that look difficult to achieve and maintain?

the theme is doing all the job, you just need AeroGlass and Black Glass Enhanced

Download the theme

ow, and, about maintain, it's stays like it's on screenshot, when i close, move etc it's stays like i want, i can modify blur radius, transparency etc

Edited by drakulaboy
edit

Share this post


Link to post
Share on other sites
3 hours ago, JTB3 said:

SyncBack Pro now intermittently leaves ghosted windows on the desktop after they are closed!

that's strange, i just tested this app, added the app in the list and i opened and closed a few times, all fine, i'm using the last version of AeroGlass 

Share this post


Link to post
Share on other sites
58 minutes ago, drakulaboy said:

that's strange, i just tested this app, added the app in the list and i opened and closed a few times, all fine, i'm using the last version of AeroGlass 

 

 

With SBPro, It's been intermittent on my machine - mostly when the 'modify profile' windows is closed - not the main window.  Right now I can't easily reproduce.  With the True Launch Bar, it is easy to reproduce the glitches - and also with MindManager 2018...

Share this post


Link to post
Share on other sites
16 hours ago, JTB3 said:

Yes! - I have similar window/control refreshing issues related to the blur effect.  I'm running the latest FCU with an Intel i7-7700K using only the onboard graphics.  Several programs are now intermittently leaving residual artifacts on the desktop after the app windows close. Also, several of my installed programs (Like MindManager 2018) will not display the ribbon properly while Aero Glass 1.5.7 is running. These blur-related/refresh glitches are almost a show-stopper. Would really appreciate you looking into this @bigmuscle

Mine did this a time or two and it was my video card driver after the update it never did it again. Not sure if this would be your problems as well just thought I would let ya know. 

Share this post


Link to post
Share on other sites
On 30. 12. 2017 at 4:53 AM, JTB3 said:

Several programs are now intermittently leaving residual artifacts on the desktop after the app windows close.

I've seen this more than half-year ago while I still had 10 as my main OS (Anniversary Update), though not as frequent.  Interestingly, @NoelC said he's running 1.4.5 on his 8.1 machine because 1.4.6 caused glitches. On my old Radeon on the other hand, anything below 1.4.6 (I tried 1.4.5, 1.4.1 and 1.3.1) causes massive screen artifacts, windows leaving residual artifacts, parts of screen getting corrupted etc. Again, they can be avoided by turning off blur. The two obvious glitches that still show up from time to time can be seen in the alt-tab switcher (I use the one from Windows Vista which gives glassy appearance) and around the start button.

On 30. 12. 2017 at 9:45 PM, gitit20 said:

Mine did this a time or two and it was my video card driver after the update it never did it again. Not sure if this would be your problems as well just thought I would let ya know.

Not always the option, updates can cause other issues, though the results indeed differ between different drivers. I tried Aero Glass on another laptop still running CU with Intel HD 4000 with whatever drivers were newest in late 2015 and it works OK there.

Share this post


Link to post
Share on other sites

Hm, good point.  I haven't tried 1.4.6 again on my Win 8.1 setup since having upgraded from ATI Radeon HD 7850 to nVidia Quadro P2000.

Part of me says "if it works, don't fix it"...  Should I experiment or leave well enough alone?  Decisions, decisions...

-Noel

Share this post


Link to post
Share on other sites
4 hours ago, NoelC said:

Part of me says "if it works, don't fix it"...  Should I experiment or leave well enough alone?  Decisions, decisions...

Aero Glass is easy to manage so you don't have anything to lose I guess. At least you'll know how it behaves.

Hey, guess what happened when I upgraded the laptop I mentioned to FCU? The glitches appeared! So, the only difference was transition from CU to FCU and I see the same problems of which screenshots I've posted from VMware virtual machine on my desktop. Afterwards, I updated software on it, including drivers for Intel HD 4000 which didn't change anything.

There's something else, take a good look at the AG's watermark on my screenshots. It's like it has the shadow behind it. It wasn't present in CU with AG 1.5.7 on that laptop. Plus, after the upgrade, the watermark itself started showing up those refresh issues, especially when toggling View->Show desktop icons from desktop context menu. Those of you that have donation.key, maybe rename/move it temporarily and see how the watermark behaves.

Share this post


Link to post
Share on other sites
5 hours ago, UCyborg said:

There's something else, take a good look at the AG's watermark on my screenshots. It's like it has the shadow behind it. It wasn't present in CU with AG 1.5.7 on that laptop. Plus, after the upgrade, the watermark itself started showing up those refresh issues, especially when toggling View->Show desktop icons from desktop context menu.

I got this shadows after I used the Task View button. I use to have 5 "running" desktops and I got a shadow added from etch one to the watermark... But this is gone since the watermark isn't showing in 1.5.7 throe donation ;0)

Share this post


Link to post
Share on other sites

Yeah, it's mostly about correctness. While watermark by itself isn't important, why it glitches is.

Share this post


Link to post
Share on other sites

Those of you that are having programs that are intermittently leaving residual artifacts on the desktop after the app windows closes, try this.
Untic as shown below.

Performance Options.jpg

  • Like 1

Share this post


Link to post
Share on other sites

Hi Big Muscle i am So excited of Your Project and I want to ask you just if i make an properly donation is it possible to make me an version for build 17063 just because of some features that i want to experiment and without ApplicationFrameHost only normal aero glass if its some debugging no problem just an version experimental who work in this build Thank you so much. also i have registration in your site but i cant change the password also i can generate many keys. for all machines that i have.

Share this post


Link to post
Share on other sites
On 12/30/2017 at 12:45 PM, gitit20 said:

Mine did this a time or two and it was my video card driver after the update it never did it again. Not sure if this would be your problems as well just thought I would let ya know. 

Thanks @gitit20 for suggesting to upgrade the video driver.  Unfortunately for me, it did not help at all.
I've now updated my built-in Intel HD 630 graphics driver to the latest - to no avail... -JT

Share this post


Link to post
Share on other sites
On 1/2/2018 at 9:36 PM, Dreamweaver01 said:

Those of you that are having programs that are intermittently leaving residual artifacts on the desktop after the app windows closes, try this.
Untic as shown below.

Performance Options.jpg

2

Thx for the suggestion, but this is the 'tail wagging the dog'.  It only solves a few of the 'many' glitches issues.
Can you help us resolve these serious residual artifacts @bigmuscle ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×