Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


roytam1

My build of New Moon (temp. name) a.k.a. Pale Moon fork targetting XP

Recommended Posts

I've been running the New Moon 28 Sneak Peek for a few days now.  I upgraded to the last build from a day or so ago, but the New Tab Page changed a tad (it added a Search bar like Australis builds did and increased the size of thumbnails).  I went back to the previous v28 build and that's running great.

Apparently, the v27 builds now work again with Facebook, but I find that v28 works so well, that I'm going to stay put.

:)

 

Share this post


Link to post
Share on other sites

Basilisk 55 does not update the add-ons, 52 versions of the add-on are updated.

Thank you very much for your work!

not naming.png

not naming2.png

Share this post


Link to post
Share on other sites
1 hour ago, ED_Sln said:

Basilisk 55 does not update the add-ons, 52 versions of the add-on are updated.

because of versioning, AMO server refused to provide updates to (they think) "old" firefox alpha versions.

Share this post


Link to post
Share on other sites
1 hour ago, roytam1 said:

because of versioning, AMO server refused to provide updates to (they think) "old" firefox alpha versions. 

Is this impossible to fix? For example, replace the useragent?

Share this post


Link to post
Share on other sites
58 minutes ago, ED_Sln said:

Is this impossible to fix? For example, replace the useragent?

I think it is no worth to do so since they're going to nuke legacy XUL externsions in AMO in near future.

  • Like 1

Share this post


Link to post
Share on other sites

https://forum.palemoon.org/viewtopic.php?f=1&p=144176&sid=f6a1360dba9d5576938705ce161a2d88#p144176

 

Quote

A second announcement I'd like to make today is that development is progressing rapidly and smoothly, and it looks like we will be able to release v28.0.0 in (late) August somewhere, barring any unforeseen blockers.

 

 

Edited by Sampei.Nihira
  • Like 1

Share this post


Link to post
Share on other sites

So that means a beta 28 now for New Moon?  Maybe?  LOL

I was going to say that v28 has improved Pale Moon A LOT

Edited by Jody Thornton

Share this post


Link to post
Share on other sites
42 minutes ago, Jody Thornton said:

So that means a beta 28 now for New Moon?  Maybe?  LOL

I was going to say that v28 has improved Pale Moon A LOT

I'll just remove the disclaimer, but they will still share same post in future.

  • Like 2

Share this post


Link to post
Share on other sites
On 6/21/2018 at 6:47 PM, roytam1 said:

for bk55 build, I'm now trying to catch up esr52 sec fixes and incorporating them to it, now up to timestamp "2017-12-18 19:39 -0500" at mozilla-esr52

On 6/23/2018 at 7:12 AM, roytam1 said:

New build of post-deprecated basilisk/moebius for XP!
* Notice: This repo will not be built on regular schedule, and changes are experimental as usual.
** Current moebius patch level should be on par with 52.8, but some security patches can not be applied/ported due to source milestone differences between versions. 

Hi Roy :)

 Your efforts to breathe new life into the Moebius repo, deprecated by its maintainers since Mar 18th 2018,
are highly appreciated and praiseworthy :wub: ; I understand it is a very tedious and time-consuming task to port-over
security fixes from Mozilla...

Although always a consideration, I'm not that paranoid about browser security as I am about browser features and continued functionality (acknowledging, as you state, Bk55/Moebius being "experimental" software :rolleyes:).

I was one of the people to highly praise Basilisk(55)/Moebius during the time it was actively maintained by Moonchild, of course through your Vista compatible forks/builds, especially in comparison to the early releases of Basilisk(52) /UXP-T2, which then presented many issues; Bk55, on Vista at least, was/is more "fluid", had/has a better rendering engine and richer webextension APIs and its native theme has better integration with Vista's Aero.

But then MC dumped Moebius, because it was no longer serving their original needs, and focused developing on Bk52/UXP; so I ultimately had myself to revert to your Serpent 52.9.0 builds (and accept its various shortcomings on Vista), if I was to use an actively maintained browser where existing bugs had some chance of a fix by MC...

But I have kept a (portable) installation of Basilisk (now Serpent) 55 for tests; further down in this post I'm going to talk about my "adventures" with using your latest Serpent 55.0.0 offerings...

 

(Web)Notifications bug:

This was first reported by our Polish friend @kitaro1 in a now lost post; it was quite annoying especially because it used to affect this MSFN forum, too! The browser wouldn't save between sessions (browser restarts) notification exceptions (sites allowed to display webnotifications) and every time one logged in, one had to (re-)allow notifications for msfn.org (and, of course, other sites with the notification feature). FWIW, this bug was not present in the last official build of Bk55, Basilisk-55.0.2018.03.21-git-20180321-g6afc1c7.en-US.win32[buildID=20180321093734].

I had carried out regression tests (but sadly I never posted those) and determined that the bug was first introduced by you in Basilisk-55.0.0-git-20180308-g3da3c97-xpmod.en-US.win32[buildID=20180306151332] by updating NSPR to 4.18 and NSS, first to 3.35 and then to 3.36; in the profile, cert8.db changed to cert9.db and key3.db to key4.db.

That bug was finally rectified with Basilisk-55.0.0-roytam1-git-20180616-gde24cec.en-US.win32[buildID=20180616141358], with the update of NSS to 3.36.4; cert9.db and key4.db reverted to cert8.db and key3.db again...

 But that fix came with a small price: I am not using a third party password manager, after the update from buildID=20180413153516 to buildID=20180306151332 I just found out all my stored login accounts (for ca. 15 sites) in about:preferences#security could not be read/recovered and I had to manually re-input them :angry:; so, for those wishing to update from Basilisk-55.0.0-roytam1-git-20180413-gee7cd5f.en-US.win32[buildID=20180413153516] to a more recent build of Bk55, take care to first export/back up your saved login credentials!

 

Extensions installed from AMO won't pick-up available updates/won't auto-update (according to your settings)

This specific issue was recently reported in this thread by new member @ED_Sln

On 6/25/2018 at 1:59 PM, ED_Sln said:

Basilisk 55 does not update the add-ons, 52 versions of the add-on are updated.

I believe the real reason behind this bug is the one mentioned here:

https://forum.palemoon.org/viewtopic.php?f=61&t=19273

Mozilla on AMO have switched to providing extension update manifests exclusively in JSON format, killing the XML format used in Basilik55; the MC team mitigated this change in the UXP repo (hence Serpent 52.9.0); owing to a similar root cause, current Bk55 (as offered by Roy) can't update other extensions not installed from AMO, but whose update manifests also come in the form of .json; one such example I am aware of is the GitHub hosted beta/RC versions of gorhill's uBlock Origin :

https://github.com/gorhill/uBlock/releases

whose update manifest URI is:

https://raw.githubusercontent.com/gorhill/uBlock/master/dist/firefox/updates.json

E.g. on Serpent 52.9.0, 1.16.11rc1 will update to 1.16.11rc2, but NOT on Basilisk 55.0.0 (has to be installed manually from Github).

To fix this bug on Bk55, you'll have to back port code from the UXP repo!

 

EME and Widevine CDM support on Vista OS

This was already brought up by me here previously, sadly those posts have permanently vanished due to site's server crash/database corruption :realmad:

TL;DR: Yes, your Bk55 builds are compiled with the --enable-eme=widevine flag and while widevine on Windows XP is a lost cause (again, there was discussion/explanation in this thread that is now lost), on Vista the plugin does appear as loaded and enabled (v1.4.8.903) inside AOM (about:addons); FWIW, extensive tests by yours truly have shown that Serpent55+WV works as expected in WinOSes >=7, but not on Vista :angry:

Explanation: Actually, neither MC team nor you are to blame for this! Widevine is a closed source plugin; from my many tests and online searching I have concluded that WV on a Mozilla type browser only searches for h264/aac decoders among the system codecs and implies a working WMF implementation in the browser; BK55 doesn't support Vista's WMF+WV, because that support was already removed by Mozilla in the source (53.0a1?) MC originally forked; MC didn't plan on their test bed browser working on Vista, so never bothered to reinstate Vista's broken WMF support (not the story with Basilisk52: in that case, Vista WMF+WV support was present in the forked source, MC team selectively removed it :realmad: and you (Roy) reinstated it :yes:; hence, Serpent 52.9.0 + WV works OK in Vista! :thumbup).

Visiting https://bitmovin.com/demos/drm with Basilisk-55.0.0-roytam1-git-20180623-g0249f58.en-US.win32[buildID=20180623000710] on Vista I get:

EAvgg9e.jpg

avc1 (h264) decoding support is achieved via your patched ffvpx lib, not by WMF; thus widevine (and other EME) are not supported! Similar results are produced when one visits https://demo.castlabs.com/ :(

@roytam1 you'd have to install a Vista VM (fully updated with all Service Packs and Platform Update Supplements!) to reproduce; if your kind heart wishes to fix this, you'd have to bring back WMF on Vista; you can start by looking at

https://bugzilla.mozilla.org/show_bug.cgi?id=1324183

https://bugzilla.mozilla.org/show_bug.cgi?id=1329547

and possibly others... :(

 

Non-working userstyles :(

I have an eye condition and I can't stand bright colours for long, plus I tend to be on-line more during the night (yes, bad for my sleep patterns :P); as such, on all of my browsers I install Stylish (or similar) and a group of "dark" userstyles to have a darker web experience!

When I updated my previous Bk55 installation (Basilisk-55.0.0-roytam1-git-20180616-gde24cec.en-US.win32[buildID=20180616141358]) to the latest compile (Basilisk-55.0.0-roytam1-git-20180623-g0249f58.en-US.win32[buildID=20180623000710]), I was unpleasantly surprised to find that more than half of my installed userstyles quit working (while the rest remained functional!); my Stylish version is 2.1.1, the last (hybrid-)XUL version that still has access to the browser GUI (as I also use a number of userstyles to accommodate the GUI to my liking!).

A brief list of userstyles that stopped working after the latest update is

Addons Mozilla Firefox 2017 Dark Theme
bing nightly
Bitbucket Org Dark
Dark style for (ftp|archive).mozilla.org
Darker Facebook
Darker IMDb
DarkSearch for Google
DuckDuckGo DeepDark
GitHub Dark
Userstyles DeepDark
Website: cleaner - Mozillazine.org Forums
YouTube DeepDark Material
YouTube  DeepDark Classic
Findbar on Top Right (modifies Browser GUI)

Some of them can be found on-line, others I have picked-up from various sources I now have no recollection of; it is noteworthy that while all but one are "dark" styles affecting the look of webpages, I have at least one that modifies the browser GUI itself (Findbar on Top Right) which is now broken... :realmad: For the record, I have one "dark" userstyle, "Wikipedia - Dark, blue, simple", that is not broken and still works! :dubbio:To make matters worse, it looks as though the style hosting site https://userstyles.org is broken; when I visit, e.g.

https://userstyles.org/styles/118959/darksearch-for-google

and have that style installed, there's no indication on the site the style is indeed installed (or am I confusing this with greasyfork.org? ); in any case, don't hit that deceptive button "Install with Stylish"; you'll end up with the latest webextension version of Stylish that will mess things up for you... :sneaky::angry:

The relevant changelog is

https://github.com/roytam1/basilisk55/compare/de24cec...0249f58

I hope something responsible for the userstyle breakage stands out for you... This new bug is a deal-breaker for me and I have switched back to Serpent 55.0.0 (2018-06-16)

I hope you'll appreciate the detailed bug-report, my gratitude for your hard work remains unscathed regardless :)

Best wishes to Hong Kong :hello:

Edited by VistaLover
Resized attached screenshot
  • Like 1
  • Upvote 1

Share this post


Link to post
Share on other sites

Hey VistaLover,

I noticed some of the same things except the ones that stopped working for me were google-calendar-dark-style by Devo and gmail-dark-1 by TheArkive.  I temporarily worked around it by changing my GMail theme but it is not a true dark theme because when reading emails they show in white background hence why I changed in the first place.  Instead of Stylish I was using Website Theme Manager 0.1.1.  Like you using the 6-16 version it still worked.  However I noticed Gmail is faster without the styles so I might go on the hunt for something better.  Either way thank you Roy for all your hard work.  It is appreciated. 

Leland

:D

  • Like 1

Share this post


Link to post
Share on other sites
14 hours ago, VistaLover said:

Non-working userstyles :(

I have an eye condition and I can't stand bright colours for long, plus I tend to be on-line more during the night (yes, bad for my sleep patterns :P); as such, on all of my browsers I install Stylish (or similar) and a group of "dark" userstyles to have a darker web experience!

try enabling layout.css.moz-document.content.enabled and restart.

14 hours ago, VistaLover said:

I had carried out regression tests (but sadly I never posted those) and determined that the bug was first introduced by you in Basilisk-55.0.0-git-20180308-g3da3c97-xpmod.en-US.win32[buildID=20180306151332] by updating NSPR to 4.18 and NSS, first to 3.35 and then to 3.36; in the profile, cert8.db changed to cert9.db and key3.db to key4.db.

That bug was finally rectified with Basilisk-55.0.0-roytam1-git-20180616-gde24cec.en-US.win32[buildID=20180616141358], with the update of NSS to 3.36.4; cert9.db and key4.db reverted to cert8.db and key3.db again...

because it is not intended to use SQLite-format cert9.db and key4.db, which have bad experience when starting a profile over network drive, and it is caused by updating NSS. And finally it is reverted back to old DBM-format cert8.db and key3.db.

for MSE and JSON-based update manifest, I hope I can have time having a look on it.

for Auto Update issue, tag #409@UXP: https://github.com/MoonchildProductions/UXP/issues/409

Edited by roytam1
  • Like 1

Share this post


Link to post
Share on other sites
22 hours ago, roytam1 said:

try enabling layout.css.moz-document.content.enabled and restart.

because it is not intended to use SQLite-format cert9.db and key4.db, which have bad experience when starting a profile over network drive, and it is caused by updating NSS. And finally it is reverted back to old DBM-format cert8.db and key3.db.

for MSE and JSON-based update manifest, I hope I can have time having a look on it.

for Auto Update issue, tag #409@UXP: https://github.com/MoonchildProductions/UXP/issues/409

Thanks Roy that fixed the issues with dark user styles for me.  Gmail is back to where it was.  Hopefully this fixes it for VistaLover also.

Leland

Share this post


Link to post
Share on other sites
On 6/27/2018 at 6:03 AM, roytam1 said:

try enabling layout.css.moz-document.content.enabled and restart.

Hello again Roy :)

I did update back to the latest build, Basilisk (Serpent) 55.0.0 (2018-06-23) (32-bit) (buildID=20180623000710) and toggled the mentioned pref: SUCCESS :thumbup All previously non-functional userstyles now work as expected! Cheers for finding the culprit! :worship: And I saw you've already pushed the necessary change to your forked Bk55 repo:

https://github.com/roytam1/basilisk55/commit/81899e5

But (sadly, there's always a but... :( ) :

On 6/26/2018 at 9:01 PM, VistaLover said:

it looks as though the style hosting site https://userstyles.org is broken; when I visit, e.g.

https://userstyles.org/styles/118959/darksearch-for-google

and have that style installed, there's no indication on the site the style is indeed installed

... this issue is still there, in an annoying fashion :}.

Userstyles.org have made it all the more difficult to install a userstyle they host, if 1) you're not running one of the major browser brands, notably latest versions of Chrome/Quantum, and 2) you're not running the latest webextension version of Stylish. They do not provide an interface to install a specific style on its page, as I said the "Install with Stylish" button is just a lure to force Stylish WE 3.1.1 down your throat :realmad: . With New Moon and Serpent browsers (Stylish 2.1.1), I have found clearing the browser cache and reloading the page several times will finally get you the "install style" pop-up prompt... ;)

But the detection of an installed style is a very handy feature that doesn't work in Bk55; if I visit

https://userstyles.org/styles/94667/selected-tab-blue-font-color-for-ft-deepdark

with latest Bk55 (buildID=20180623000710) with that userstyle installed, I get:

67hm8uT.jpg

In the case of latest Basilisk (Serpent) 52.9.0 (2018-06-23) (32-bit) (buildID=20180623010357), with the same userstyle installed and active, detection succeeds:

M5fw8jo.jpg

Possibly some javascript code which only works in Bk52/UXP but not in Bk55/Moebius :} Can you please come up with a solution for this? FWIW, it would appear that the detection of an installed userstyle also fails in both NM 27 [27.9.1a1 (2018-06-15) (32-bit)] and NM 28 [28.0.0a4 (2018-06-23) (32-bit), so this bug isn't unique to Bk55!

On 6/27/2018 at 6:03 AM, roytam1 said:

for MSE

I think you meant a working WMF+EME (Widevine) Vista implementation - thanks for not throwing in the towel beforehand :)

On 6/27/2018 at 6:03 AM, roytam1 said:

and JSON-based update manifest, I hope I can have time having a look on it.

For Auto Update issue, tag #409@UXP:

https://github.com/MoonchildProductions/UXP/issues/409

I see this has already been taken care of in

https://github.com/roytam1/basilisk55/commit/7042385

We'll have to wait for your next builds over the weekend to test ;)

As ever, lots of  :wub:

Regards

Share this post


Link to post
Share on other sites
17 minutes ago, VistaLover said:

Hello again Roy :)

I did update back to the latest build, Basilisk (Serpent) 55.0.0 (2018-06-23) (32-bit) (buildID=20180623000710) and toggled the mentioned pref: SUCCESS :thumbup All previously non-functional userstyles now work as expected! Cheers for finding the culprit! :worship: And I saw you've already pushed the necessary change to your forked Bk55 repo:

https://github.com/roytam1/basilisk55/commit/81899e5

But (sadly, there's always a but... :( ) :

... this issue is still there, in an annoying fashion :}.

Userstyles.org have made it all the more difficult to install a userstyle they host, if 1) you're not running one of the major browser brands, notably latest versions of Chrome/Quantum, and 2) you're not running the latest webextension version of Stylish. They do not provide an interface to install a specific style on its page, as I said the "Install with Stylish" button is just a lure to force Stylish WE 3.1.1 down your throat :realmad: . With New Moon and Serpent browsers (Stylish 2.1.1), I have found clearing the browser cache and reloading the page several times will finally get you the "install style" pop-up prompt... ;)

But the detection of an installed style is a very handy feature that doesn't work in Bk55; if I visit

https://userstyles.org/styles/94667/selected-tab-blue-font-color-for-ft-deepdark

with latest Bk55 (buildID=20180623000710) with that userstyle installed, I get:

67hm8uT.jpg

In the case of latest Basilisk (Serpent) 52.9.0 (2018-06-23) (32-bit) (buildID=20180623010357), with the same userstyle installed and active, detection succeeds:

M5fw8jo.jpg

Possibly some javascript code which only works in Bk52/UXP but not in Bk55/Moebius :} Can you please come up with a solution for this? FWIW, it would appear that the detection of an installed userstyle also fails in both NM 27 [27.9.1a1 (2018-06-15) (32-bit)] and NM 28 [28.0.0a4 (2018-06-23) (32-bit), so this bug isn't unique to Bk55!

I think you meant a working WMF+EME (Widevine) Vista implementation - thanks for not throwing in the towel beforehand :)

I see this has already been taken care of in

https://github.com/roytam1/basilisk55/commit/7042385

We'll have to wait for your next builds over the weekend to test ;)

As ever, lots of  :wub:

Regards

Hey VistaLover,

 

I have had to use User Agent Switcher in order to set the user agent for Firefox 52 in order to install updated extensions and themes lately.  I suspect you may have to do the same to get certain functions working.

Leland

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...