Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


roytam1

My build of New Moon (temp. name) a.k.a. Pale Moon fork targetting XP

Recommended Posts

17 hours ago, Mathwiz said:

OK, so that's Quantum-based with the "Photon" interface, right? My first thought was, "that couldn't run on XP;" but:

On Windows 7, it certainly looks like Photon (and a bit too much like M$ Edge). I can't test it on XP until Monday; in the meantime, can anyone confirm? https://www.comodo.com/home/browsers-toolbars/icedragon-browser.php

(Warning: a dialog box will pop up offering to install "Comodo cloud Antivirus" and change your home page and default search engine to Yahoo on all supported browsers. You must click the teeny "Decline" button if you don't want to do that. Seems a bit PUPpy to me....)

A Quantum browser would have drawbacks; the chief ones being no legacy extensions and no NPAPI plug-ins (except Flash). Still, a Quantum browser on XP would be quite a feat.

Browsercrashes during/after installation: Winxp SSE
They cannot be used on SSE-PC.
Basilisk crash after installation
Slimjet dito/the same
Chrome installation crash
Lunascape dito
Icedragon dito
Lightshot no SSE
Mypal SSE2 ok
Opera SSE2 ok
Seamonkey SSE2 ok
Cometbird must rechecked most probably no winxp-SSE

Share this post


Link to post
Share on other sites

On 10/20/2019 at 6:07 AM, roytam1 said:

this pref is enabled by default. did you change it in about:config?

very strange when i checked if available it denied and browser crashed/hadnt been restarted since almost whole day...-
after restart i see dom.storage.enable . as user- defined was false. set it to true. whats next?
NB: there is an about:config plugin: Open about:config 1.2
https://addons.palemoon.org/addon/open-about-config/

On 10/18/2019 at 9:52 AM, roytam1 said:

already read, tried, but nothing helped. also asked selling agent of mainboard and they told be I have to grab the board to their office for further diagnosis

check also realtek-forum.
i would spend you 100 usd for a new identical MOBO hoping the others can also do. Then you could send them for control.Always good to have replacement MOBOs. saved me multiple times.
 

I only hope the capacitor-plague is extincted forever. Thats why my next Highend-MOBO will be military-certified. Also had to use an audio-stick since connector worn out. old problem. the industry is thinking about that.

On 10/18/2019 at 9:52 AM, roytam1 said:

already read, tried, but nothing helped. also asked selling agent of mainboard and they told be I have to grab the board to their office for further diagnosis

I also had audiodriver-problems. no sound. when switching between the versions one must set the right one in windows audio-control-panel. it will not be reset/adjusted automatically. at least true for my pcs/winxp.

------------------------

Update: If not yet done. Bios-update. shut down pc totally. do a cmos-clear and Replace  old battery/wait 30 min. then the necessary steps in cmos-setup. If it doesnt help I would  go to MOBO x-forum. Asus right?
2. Bios-refresh Make cmos/bios-backup first and then needed steps. read precisely the instructions.

Edited by 3dreal

Share this post


Link to post
Share on other sites
4 hours ago, WinFX said:

Hello, you can eliminate calls to "EncodePointer", "DecodePointer" and "GetLogicalProcessorInformation" since Windows XP RTM / SP1 does not have these dependencies in kernel32, but Windows XP SP2 does. At least do it with New Moon 27 since Windows XP SP1 in Pentium II works better than SP2 / SP3.

And another question how do I make YouTube play videos on New Moon 27?

I have a sticky here somewhere backwards. But its not yet updated/maybe a bit confusive. and in my own i have german remarks.
But maybe this is enough to make YT running again. Downloading is another thing.
UPDATE means must be adjusted after new PM-version installed/running. i cannot run the installer. see old message.
From my detailed Sticky 2

6.a)
media.av1.enabled   true  UPDATE
b)
media.mediasource.webm.enabled  true  ONLY CHANGE(from false) AFTER A RESET /UPDATE(NEW)
https://news.ycombinator.com/item?id=9329306

Q: VP9 Support? (for PM27) NOT IN FIREFOX SEE 6.
 a) VP9 works if async MSE option is unchecked  UPDATE
Extras/Tools, Einstellungen/Preferences, Inhalt/Content   

b)  and "Enable MSE for WebM Video" checked in options.
Youtube only used VP9 with MSE but even then not all content is available as VP9, some is only available as H.264/MSE.

You can check https://www.youtube.com/html5 to see what your browser supports.



maybe the lav-files and ffmpeg-workaround is also needed. pls let us know if YT is working now.

Edited by 3dreal

Share this post


Link to post
Share on other sites
9 hours ago, 3dreal said:

i would spend you 100 usd for a new identical MOBO hoping the others can also do. Then you could send them for control.Always good to have replacement MOBOs. saved me multiple times.

If I want to get another MB I'd pick MSI X470 GAMING PLUS instead.

Share this post


Link to post
Share on other sites
On 10/20/2019 at 9:21 AM, Kwasiarz said:

I've tried installing it on Vista, and while it indeed installed, after launching, Windows complained that it's not a valid Win32 application:

icedragon.thumb.png.7a0aececb8af33e1e308f41274d715ae.png

I guess the same will happen under XP.

I downloaded the win32 version (https://download.comodo.com/icedragon/update/icedragonsetup.exe), installed it as portable app, ran it and got the same complaint that it is not a valid win32 application. So it cannot run on XP despite the claim.

Edited by luweitest

Share this post


Link to post
Share on other sites
3 hours ago, luweitest said:

So it cannot run on XP despite the claim.

I think they just "forget" to update their website after they changed their base.

  • Upvote 3

Share this post


Link to post
Share on other sites

Well, they said it would work:

On 10/19/2019 at 5:54 PM, kitaro1 said:

Another firefox comodo icedragon fork on FF 65 has quick startup and fast gmail support. Neither serpent, any newmon and mypal have a quick start. Icedragon you will polish, add a lot of extensions and amaze with speed. It's much faster than firefox 70.0, than chrome.

Why authors of slow browsers do not use instant icedragon solutions? @roytam1

On 10/19/2019 at 7:14 PM, Mathwiz said:

Comodo IceDragon will run on 32/64 bit Windows 7, Windows Vista and Windows XP.

... but it won't run, at least not OOTB:

On 10/19/2019 at 8:21 PM, Kwasiarz said:

I've tried installing it on Vista, and while it indeed installed, after launching, Windows complained that it's not a valid Win32 application

I installed it on XP anyway, just to run Dependency Walker. And (no surprise), there are unresolved dependencies in KERNEL32.DLL:

AcquireSRWLockExclusive
AcquireSRWLockShared

... and in ADVAPI32.DLL:

RegGetValueW

So, it looks like a dry hole, folks. Despite claims, it does not run on XP. @kitaro1 must be running it on Win 7 or later. But on Win 7, I'd pick Waterfox over IceDragon, at least if I had a 64-bit CPU (which I do).

I suppose there's still (slim) hope for Vista. @Kwasiarz, can you check your installation with Dependency Walker? If there are unresolved dependencies, there's no point in trying to patch the min. Windows version to let it run on Vista. But I think the first two above are in Vista, so it's worth checking.

Oh, and @3dreal, no one ever claimed this would run on SSE-only CPUs. It would still have been surprising had it run on XP or Vista with an SSE2 CPU!

Edited by Mathwiz

Share this post


Link to post
Share on other sites
46 minutes ago, Mathwiz said:

I suppose there's still (slim) hope for Vista. @Kwasiarz, can you check your installation with Dependency Walker?@3dreal

Sure, but to be honest I don't know what to exactly look at:

iddw.thumb.png.d3c81c964832f5fc9675c9aca2a3bf9c.png

Edited by Kwasiarz

Share this post


Link to post
Share on other sites

It looks better than on XP, at least. There are missing imports, but they are in "delayed-load" .dll's. Hard to tell if they'll stop it from running, but they won't stop it from at least loading (if the minimum Windows version can be patched to 6.0, that is). So I guess there's still hope for Vista.

 

Share this post


Link to post
Share on other sites
On 10/19/2019 at 8:21 PM, Kwasiarz said:

I've tried installing [IceDragon 65] on Vista, and while it indeed installed, after launching, Windows complained that it's not a valid Win32 application:

I'm quite certain you are wasting your time. As stated in Last versions of software for Windows Vista and Windows Server 2008, the last version of Comodo IceDragon to support Vista was 52.0.0.4, which was of course forked from Firefox 52 and was only available in 32 bit. Here's a Comodo thread from January 2018 in which staff member Shane states, "We confirm Comodo Ice Dragon 57+ won't support XP and Vista."

Regarding Windows XP, there's another old Comodo thread in which OP states that he couldn't install version 57 or even 52, so 49 may have been the last XP-compatible version.

  • Like 1

Share this post


Link to post
Share on other sites

So Roytam was probably right:

7 hours ago, roytam1 said:

I think they just "forgot" to update their website after they changed their base.

I haven't wasted *that* much time on this trivial pursuit, if it makes you feel better. Only took 20 minutes to download, install, run Dependency Walker, and uninstall again.

Share this post


Link to post
Share on other sites

> I'm quite certain you are wasting your time. As stated in...

We are already quite aware of its OOTB limitations. The question now is: can it do anything after a bit of tweaking?
RegGetValueW can be hexed to RegGetValueA.
AcquireSRWLockExclusive and AcquireSRWLockShared can be hexed to SetLastError.

Share this post


Link to post
Share on other sites

Unfortunately those are just the ones that jumped out at me. Digging deeper there are several more in MOZGLUE.DLL:

GetThreadId
GetTickCount64
InitOnceExecuteOnce
InitializeConditionVariable
InitializeCriticalSectionEx
InitializeSRWLock
ReleaseSRWLockExclusive
ReleaseSRWLockShared
SleepConditionVariableSRW
WakeAllConditionVariable
WakeConditionVariable

... and in ICEDRAGON.EXE itself:

DeleteProcThreadAttributeList
GetThreadId
GetUserDefaultLocaleName
InitOnceExecuteOnce
InitializeCriticalSectionEx
InitializeProcThreadAttributeList
ReleaseSRWLockExclusive
UpdateProcThreadAttribute

And Dependency Walker tells me RegGetValueA isn't in ADVAPI32.DLL either.

So it looks like a rather bigger task than at first.

Share this post


Link to post
Share on other sites

@dencorso

As this thread is about to hit 200 pages, do you think it should be continued in a new thread now (keeping the original intact of course, but locked)?
It is getting rather unwieldy, and on many other forums I use the mods lock threads and start continuation threads when they are deemed to be too long.
:)

Share this post


Link to post
Share on other sites

I'm sorry. I set the topic to 300 pages - the latest topic page is always displayed. ;)

d32d41d3fac2717c.png

  • Like 1

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...