Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
Aeridyne

CD drive not recognized in 98SE on Dell Inspiron 5150

Recommended Posts

Have a nice Dell 5150 that I had put Windows 7 on and had running pretty decent, realized that the chipset on it is an 850PM, so I thought hey what the heck, lets see if I can get 98SE on there and running good.

General hardware:
P4 3.06Ghz
Intel 850PM chipset
Sigmatel 9750 audio
Nvidia 5200FX (32mb)
Broadcom 440x ethernet
Broadcom BCM94306MP Wireless card
512mb ddr1 333mhz
40gb Fujitsu HD
Quanta SBW-242 optical DVD/CD-rw drive

Here's the problem, I put an image onto the drive (image of Dell D600 with 855 chipset) and upon first boot it detected lots of hardware, lots of loading & reboots later it gets to desktop and appears to function fine, however there are some problems, the biggest one being that it does not detect the optical drive. I tried installing Intel 6.3.0.1007 chipset package (final 98 intel chipset package) and it loaded drivers for some things like usb controllers & such but did not fix the issue of not seeing the optical drive. (Which works just fine to boot from BIOS or in any other OS, etc. Also I tried a clean install but it couldn't finish because at some point it can't see the optical drive and continue the install after it reboots, wants files from the cd to continue but can't see the drive to use. I did this on a separate hard drive and then popped back in the original that I imaged when it did not work.)

Under DM, I have under hard disk controllers;
Intel 82801DBM Ultra ATA Storage Controller - 24CA - looks fine no exclamation.
Primary IDE Controller (dual fifo) - this has yellow exclamation, says device is either not working properly, not present or does not have all drivers installed. Does not say it has any resource conflicts.
Secondary IDE Controller (dual fifo) - looks fine, no exclamation.

It seems that this issue crops up on laptops / notebooks as I was trying to research a fix, others seem to have had variations of this problem as well, but found no real fixes for it.

Share this post


Link to post
Share on other sites

JFYI, you can do anyway a clean 98 install by installing from hard disk (actually this is the way most experienced people usually install it as it much faster than from CD and has the advantage of having the files available in case):

http://www.duxcw.com/digest/Howto/software/windows/upgrade/inst98.htm

see if you can use the CD in real mode:

https://web.archive.org/web/20060210090803/http://support.microsoft.com/default.aspx?scid=kb;en-us;189526

https://web.archive.org/web/20060209003934/http://support.microsoft.com:80/kb/190303/EN-US/

Then as always you will need to try some different drivers, but how is the CD-ROM connected? (I seem to remember issues on that Intel Controller connected to primary/secondary and master/slave settings :dubbio:)

jaclaz


 


 


 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...