Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


sdfox7

Spoofing Firefox 53 (and newer versions) on Windows 2000 and XP

Recommended Posts

Just spoffed MyPal to think its firefox 63 running on XP.Now im "Upto date" :D

IMG.JPG

Share this post


Link to post
Share on other sites

Posted (edited)

In Italy since 1st January 2019 the obligation of electronic invoicing between private individuals has been introduced.

I found out that the link chosen to work did not support my XP:

 

https://app.agyo.io/portal/index.html#/

 

In the image below the warning that says that the Operating System is no longer supported:

CRDLMQL7_o.jpg

 

Problem solved with spoofing:

uQ9Sa0Y7_o.jpg

HpMgcHWN_o.jpg

 

 

Edited by Sampei.Nihira
  • Like 2
  • Upvote 1

Share this post


Link to post
Share on other sites
10 hours ago, Sampei.Nihira said:

Problem solved with spoofing:

... And if you spoof a Firefox browser, they still insist you download and install :no:  the ultimate spyware, Google Chrome :angry::realmad::

SzFcGHA.jpg

Share this post


Link to post
Share on other sites

You are right.

I do not want to insert the Chrome User Agent even for spoof.:lol:

Edited by Sampei.Nihira

Share this post


Link to post
Share on other sites

Hello, I have not done the spoofing thing for firefox yet, but i want to ask...

I use "slack" in firefox to talk to people with, because the actual slack program itself is only for windows 7 and above, but works fine in firefox. But today i just got this notification linking to this page saying it's not going to work anymore starting on March 15. :(

https://get.slack.help/hc/en-us/articles/115002037526

Im currently on firefox 47 -- and it says on that page it needs version 60 after March :| Is this spoofing trick going to work for it by any chance ?? I'll find out on March 15, but i wanted to ask in advance early.

Edited by rockmaster113

Share this post


Link to post
Share on other sites

I guess there's no way to know for sure until 3/15, but even if spoofing doesn't work for FF 47, there's probably an XP browser it will work with.

Whether FF 47 will still work (with a spoof) probably depends on what Web technologies Slack relies on.

Share this post


Link to post
Share on other sites

Dang, i really hope it'll work. I don't have any other place to talk to them at. :( (theres a gaming project there)

Edited by rockmaster113

Share this post


Link to post
Share on other sites

Remember that spoofing only will cause the site to make available code specific to the browser you are identifying as. It all depends on how the site is written. Identifying as another browser or application does not magically give your browser the ability to do the things the other software is capable of. If they are adding some code that doesn't work in older versions of Firefox, even if they don't put in a version checker, the page may not work properly because your version can't execute the code.

As noted, it is impossible to tell what the results will be until that site updates their site, only then would you know if changing your user agent will make the page work or not.

  • Like 1
  • Upvote 1

Share this post


Link to post
Share on other sites

If @rockmaster113 is lucky, Slack is just blocking older browsers so that they have fewer configurations to test, and fewer variables to contend with when they take support calls. I'm hopeful that a spoof will let Slack work, if not with FF 47, then at least with FF 52 or one of @roytam1's Basilisk builds, which were forked from FF 52 & 53 with few changes. It may look different when rendered by Gecko or Goanna vs. Quantum or Chromium but hopefully it'll still be usable.

Anyway, we'll find out in March.

Share this post


Link to post
Share on other sites

I have tried this and to and extent it works fine, till i went on Amazon music it seems to detect my browser is out of date

I have modified

general.useragent.override : Mozilla/5.0 (Windows NT 6.1; rv:65.0) Gecko/20100101 Firefox/65.0

general.useragent.overrideprefrence : Mozilla/5.0 (Windows NT 6.1; WOW64;rv:65.0) Gecko/20100101 Firefox/65.0

going to Whatismybrowser it says all is upto date

what could be wrong

I'm on XP SP3 is it picking up the esr FF version

111.JPG

Share this post


Link to post
Share on other sites

I'd probably be a bit less aggressive in my spoofing. The ESR release of FF should be supported for several more months, so try:

Mozilla/5.0 (Windows NT 6.1; rv:60.0) Gecko/20100101 Firefox/60.0

That way, you won't have to update it every month or two. (You can change 60.0 to 60.5, the latest ESR version, if you wish.) Whatismybrowser.com may not like it, but it should work pretty much everywhere else.

But, don't be totally surprised if it still doesn't work with Amazon. There are other ways besides the user agent string that Web sites can use to ferret out your browser version. In the case of Amazon Music, I bet there's third-party DRM code Amazon's looking for, and it may not even be possible to get that code working on FF 52.9.1 or earlier, or any of @roytam1's forks either for the simple reason that it's likely not XP-compatible. DRM is the one area where pretty much every XP-compatible browser disappoints nowadays.

But if anyone can do it, I'd bet on @VistaLover ;)

Share this post


Link to post
Share on other sites

DrWho3000 wrote:


I have tried this and to and extent it works fine, till i went on Amazon music it seems to detect my browser is out of date
I have modified
general.useragent.override : Mozilla/5.0 (Windows NT 6.1; rv:65.0) Gecko/20100101 Firefox/65.0


Not sure if that applies in your case, just in general:
most people are not aware that the "general" pref is overriden by site-specific ones.
And especially not that a whole bunch of hardcoded domain spoofs come predefined already out-of-box
For example roytams KG76.1 contains a spoof for amazon.com, sending FF45.

The whole list can be found on about:config, filtering "useragent"
For real general spoofing disable this one temporarily:
general.useragent.site_specific_overrides (=>false)

And also check the other "general.useragent" prefs, if existent, for sub-elements.

Ah right and almost forgot trap-4:
if useragents work like other site-specific stuff in geckos (for images, videos etc. in permissions.sqlite), then those domain-spoofs don't work top-down (only domain in urlbar matters) but bottom-up (source domain of single elements matter).
That means even when surfing on amazon.co.uk, the spoof for amazon.com still affects those page elements that all country-amazons are loading from ".com"
Or whatever other domains they are loading stuff from, for scripts or general resources etc., usually todays major sites use a whole variety, e.g. nearly all including stuff from googlexxx Edited by siria

Share this post


Link to post
Share on other sites

@DrWho3000

You may wish to try SeaMonkey. Although I never usually have issues with XP browsers while using Amazon.com, there may be exceptions depending on what you are doing.

Back in September, Amazon Prime video refused to work for me in Chrome, complained that my OS was out of date. However, I used SeaMonkey and it worked just fine. even though I didn't spoof the browser user agent!

See the full explanation in my thread here: (FIXED) How to watch Amazon Prime Video on Windows XP

Share this post


Link to post
Share on other sites

i had tried Safari and Opera didn't get on with them and tried playing with a old Netscap Navigator deffo no go

I wonder how long can we go on spoofing FF to belive its latest fromm esr 52.9 before it stops working

an this spoofing be done with last chrome for XP

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×