Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


pointertovoid

Latest Version of Software Running on XP

Recommended Posts

Just an update: Audacity 2.2.1 has been released.

https://www.audacityteam.org/download/

To clarify, Windows XP is supported as long as Service Pack 3 is installed and there is a SSE2 or later processor. Otherwise, 2.0.6 is the last supported version on Windows XP.

More info: http://www.audacityteam.org/download/legacy-windows/ and http://www.audacityteam.org/download/legacy-windows/#sysreq

  • Upvote 1

Share this post


Link to post
Share on other sites

Java JRE 8 Update 161 was released today, January 16, 2018. I just got the automatic update notification on my Windows XP SP3 system:

jre8x161.jpg

  • Upvote 1

Share this post


Link to post
Share on other sites

@dencorso

Although I got the notification, the installer does not actually run! 

When double-clicking, nothing happens. Either there is an compatibility issue with the installer, or as of update 161 Java 8 is no longer compatible with Windows XP. 

If you already uninstalled the previous version (Java JRE 8 Update 152) and need to restore it, it's on my FTP here:

http://sdfox7.com/xp/sp3/EOL/jre-8u152-windows-i586.exe

jre8x152.jpg

 

Edited by sdfox7
Java JRE 8 Update 152 appears to be the final working installer.

Share this post


Link to post
Share on other sites

Hopefully @blackwingcat will again create modified installers for Java 8. I hope the problem is just the installer, like in the past.

Share this post


Link to post
Share on other sites
On 19/12/2016 at 8:03 PM, vwestlife said:

The overall list will be 95% the same as the one for Windows Vista.

There are only a small number of significant applications which still support Vista but don't support XP, such as Microsoft Security Essentials and Pale Moon.

OTOH, there are actually some applications which support XP but don't officially support Vista, such as Adobe Reader XI:

https://helpx.adobe.com/reader/kb/system-requirements-adobe-reader.html

It supports Windows Server 2008 which is based of Vista, so it is tenichally supported by Vista.

 

 

Share this post


Link to post
Share on other sites
On 1/17/2018 at 8:37 AM, sdfox7 said:

@dencorso

Although I got the notification, the installer does not actually run! 

When double-clicking, nothing happens. Either there is an compatibility issue with the installer, or as of update 161 Java 8 is no longer compatible with Windows XP. 

If you already uninstalled the previous version (Java JRE 8 Update 152) and need to restore it, it's on my FTP here:

http://sdfox7.com/xp/sp3/EOL/jre-8u152-windows-i586.exe

jre8x152.jpg

 

Try the offline installer at https://java.com/en/download/manual.jsp

UPDATE: Tried that and it's not working. After some quick debugging it seems that there is an access violation exception related to C runtime implementation.

ANTIDEBUGGING related stuff. The resource section includes an MSI file, which cannot install for some reason. Using Orca tto see more info.

Edited by harkaz
  • Upvote 1

Share this post


Link to post
Share on other sites

Figured it was worth a shot to try patching the Java installer with XomPie. While it changed many things, no dice.

Share this post


Link to post
Share on other sites

MSI Error 1603:

MSI (c) (30:60) [03:46:21:203]: Note: 1: 1708
MSI (c) (30:60) [03:46:21:203]: Product: Java 8 Update 161 -- Installation failed.

MSI (c) (30:60) [03:46:21:203]: Windows Installer installed the product. Product Name: Java 8 Update 161. Product Version: 8.0.1610.12. Product Language: 1033. Installation success or error status: 1603.

MSI (c) (30:60) [03:46:21:234]: Grabbed execution mutex.
MSI (c) (30:60) [03:46:21:234]: Cleaning up uninstalled install packages, if any exist
MSI (c) (30:60) [03:46:21:250]: MainEngineThread is returning 1603

Share this post


Link to post
Share on other sites

@dencorso @harkaz @i430VX

I submitted a bug submit to Oracle today. I'll be interested to see what their response is.

While Oracle does not "officially" support XP on Java 8, I'm hoping that they'll be motivated to fix it. It seems to me that this is likely a minor compatibility issue, since all previous versions of the JRE 8 run and install correctly.

I doubt they would want people running outdated versions of their software because of an error they made with the software. If they don't care, then that is at least an ethical issue they need to make a decision about.

Here is the report I submitted, with the field headers redacted:

http://sdfox7.com/xp/files/java.pdf

  • Upvote 2

Share this post


Link to post
Share on other sites
On 1/28/2018 at 12:02 AM, sdfox7 said:

Skype (now owned by Microsoft) is officially still supported on Windows XP SP3 with Internet Explorer 8. Apparently Microsoft still has a soft spot for XP. :wub:

https://www.skype.com/en/get-skype/ then click on System Requirements

https://support.skype.com/en/faq/fa10328/what-are-the-system-requirements-for-skype

I can confirm that it works perfectly-- I've used it for a couple of years now. I've had intermittent issues with the installer, though. Usually the full installer is needed.

Edited by i430VX

Share this post


Link to post
Share on other sites
10 hours ago, Sampei.Nihira said:

Out 7-zip 18.01 stable.

Thanks for the info. I downloaded it and it runs nicely on 98SE with my Wrappers.

  • Upvote 1

Share this post


Link to post
Share on other sites
On 28.1.2018 at 6:02 AM, sdfox7 said:

Skype (now owned by Microsoft) is officially still supported on Windows XP SP3 with Internet Explorer 8. Apparently Microsoft still has a soft spot for XP.

Unfortunately, there is no newer version for Windows XP (latest version 7.36.0.150). Currently, however, version 7.40.32.104 is offered which no longer works under Windows XP. The last working where I have is the version 7.37.32.103 (here the high voice frequency shares are not cut off).

:)

Edited by heinoganda

Share this post


Link to post
Share on other sites

I know I briefly mentioned this already over a year ago, but since this thread has been getting more activity lately I thought I should bring this up again. 

If you'd like a comprehensive list of final versions of software for Windows XP (as well as a list of software that continues to support it), you should check out my list for Windows Vista here. Since many software developers dropped support for XP and Vista simultaneously, much of the information on my list (as far as final software versions go) can also be applied to Windows XP, with a few exceptions here and there. 

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×