Jump to content

MS-DOS 6.22 + Shared NAT = No internet!


ppgrainbow
 Share

Recommended Posts

Hello, everyone! :hello:

I have a problem here. I'm running MS-DOS 6.22 under Virtual PC 2007 with the Intel DC21140 packet driver and for some reason, the internet doesn't work when I set the first adapter to use Shared networking (NAT).

For example, when I run the Arachne browser, I end up getting a Arachne Network Error (Unable to initalize TCP/IP) when attempting to access the Google homepage.

Here's what the screenshot looks like:No connection.png

This next screenshot has the settings of what network adapter that I'm using:

Network settings.png

If I select "Lnksys WMP54G v4.1 Wireless-G PCI Adapter" and use the "192.168.254.X" IP address, I can connect to the internet under MS-DOS and Windows 3.1 just fine.

But if I select Shared Networking (NAT) and use 129.168.131.x as the IP address, the internet doesn't connect at all.

The Shared Networking feature works fine in Windows for Workgroups 3.11 and later.

Is there anyway how to get the internet access working under MS-DOS 6.22 and Windows 3.1 using the Shared Networking (NAT) adapter under Virtual PC?

Should I post the CONFIG.SYS, AUTOEXEC.BAT and/or WATTCP.CFG configurations to see what could be wrong here as well?

Link to comment
Share on other sites


Maybe unrelated, but are you running the VM as Administrator or as "normal" user?

See:
https://blogs.msdn.microsoft.com/virtual_pc_guy/2007/04/27/virtual-pc-shared-networking-and-the-problems-with-ping/

Still possibly unrelated, have you installed the service to the (wireless) network card?

https://claytonj.wordpress.com/2007/02/02/connect-virtual-pc-to-internet/

 

jaclaz


 

Edited by jaclaz
Link to comment
Share on other sites

3 hours ago, jaclaz said:

Maybe unrelated, but are you running the VM as Administrator or as "normal" user?

See:
https://blogs.msdn.microsoft.com/virtual_pc_guy/2007/04/27/virtual-pc-shared-networking-and-the-problems-with-ping/

Still possibly unrelated, have you installed the service to the (wireless) network card?

https://claytonj.wordpress.com/2007/02/02/connect-virtual-pc-to-internet/

 

jaclaz


 

I am running Virtual PC 2007 as Administrator and have the Virtual Machine Network Services installed.

Still, MS-DOS will not connect to the internet with the Arachne browser or other network-connected programmes that use the Intel DC21140 packet driver.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...