Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
Tsundere

Desperate to install/use Windows 7. Help

Recommended Posts

I made a yt video hope it helps

Edited by aviv00

Share this post


Link to post
Share on other sites

11 hours ago, aviv00 said:

I made a yt video hope it helps

Thanks man, I just have a few questions. Why did you use VMWare when you already applied win7 to E: partition? What if I get bsod (probably due to missing drivers? Why do you suggest this particular method? Isn't it quite similar to applying image on an external fixed disk?

Share this post


Link to post
Share on other sites

try first and see what the problem

Share this post


Link to post
Share on other sites

There is no working driver at default windows 7 install.wim for the eMMC storage controller. A BSOD is very likely.

Currently there is no known working driver at all.

Share this post


Link to post
Share on other sites
6 minutes ago, cdob said:

There is no working driver at default windows 7 install.wim for the eMMC storage controller. A BSOD is very likely.

Currently there is no known working driver at all.

Hey man

So not even the intel driver (iaiosd)? 

Edited by Tsundere

Share this post


Link to post
Share on other sites
6 hours ago, Tsundere said:

So not even the intel driver (iaiosd)? 

The situation is unclear.
Is Disk 0 the eMMC disk?
Then iaiosd can find the disk, but diskpart.exe is confused, a list detail should work and a list par should find existing partittions. Strange.
A clean could work and clean the disk, Win 8.1 is gone. Not a good idea currently. Windows 7 installation is questionable still.

Or Disk 0 is a ghost disk.

Jumping to USB boot next? This may help do solve the eMMC controller driver riddle.

There is a "Windows 7 USB 3.0 Creator Utility". Let's try this one, there are different drivers included.
https://downloadcenter.intel.com/download/25476/Windows-7-USB-3-0-Creator-Utility
Read Win7-USB3.0-Creator-Readme-v3.pdf page 1,
1. Create a USB flash drive installer
2. Run the Utility

Boot boot.wim from this created USB flash drive.
Does diskpart.exe list the USB flash drive?

Share this post


Link to post
Share on other sites
14 hours ago, cdob said:

Is Disk 0 the eMMC disk?

I think so. The size matches up at least and there is only the lexar 8gb connected to the laptop. Btw, that previous attempt I posted was usb boot, not apply-image method. I think all apply-image methods I've tried result in bsod after 'starting windows' animation.

14 hours ago, cdob said:

1. Create a USB flash drive installer
2. Run the Utility

Boot boot.wim from this created USB flash drive.
Does diskpart.exe list the USB flash drive?

I will try this tonight

Share this post


Link to post
Share on other sites

Run the "Windows 7 USB 3.0 Creator Utility" and open boot.wim at 7-zip next.
Does exist \Windows\system32\drivers\iusb3xhc.sys and iusb3hub.sys?

If not then, integrate the "Windows 7 USB 3.0 Creator Utility" drivers manually.

dism.exe /Mount-WIM /WimFile:"U:\sources\install.wim" /index:3 /MountDir:"C:\ISO\MOUNT"

	dism.exe /image:"C:\ISO\MOUNT" /Add-Driver /driver:"F:\Win7_USB3.0_Creator_v3\USB_Drivers\x64" /ForceUnsigned /recurse

	dism.exe /image:"C:\ISO\MOUNT" /Get-Drivers /Format:Table

	dism.exe /Unmount-wim /mountdir:"C:\ISO\MOUNT" /commit


Two drivers are added: x64\iusb3hub.inf and x64\iusb3xhc.inf

dism.exe /Mount-WIM /WimFile:"U:\sources\boot.wim" /index:2 /MountDir:"C:\ISO\MOUNT"
dism.exe /image:"C:\ISO\MOUNT" /Add-Driver /driver:"F:\Win7_USB3.0_Creator_v3\USB_Drivers\x64" /ForceUnsigned /recurse
dism.exe /image:"C:\ISO\MOUNT" /Get-Drivers /Format:Table
dism.exe /Unmount-wim /mountdir:"C:\ISO\MOUNT" /commit[/CODE]

Do you have more testing USB sticks? There are native MMC and SD drivers at Windows 7.
However these drivers are older than eMMC, eMMC is not supported. May work or fail, it's a long shot.

Edited by cdob

Share this post


Link to post
Share on other sites

Another game: native MMC and SD Windows 7 drivers
There are native drivers at install.wim, but not at boot.wim.
Transfer the files from install.wim to boot.wim first.
And adjust registry settings, the previous fix_USB3_SD.cmd contains code already.

As for testing small steps, start with a new boot.wim.
Do not add USB3 drivers at first step. Add USB3 drivers later, if eMMC works by chance.
 

Example, adjust used path yourself:

USB stick with:
 U:\sources\boot.wim,  U:\sources\install.wim
 
Mount pathes
 C:\mount\boot and C:\mount\install 

dism.exe /Mount-WIM /WimFile:"U:\sources\install.wim" /index:2 /MountDir:"C:\mount\install"
dism.exe /Mount-WIM /WimFile:"U:\sources\boot.wim" /index:2 /MountDir:"C:\mount\boot"

dir C:\mount\install\Windows\system32\DriverStore\sdbus* /s
dism.exe /image:"C:\mount\boot" /Add-Driver /driver:"C:\mount\install\Windows\system32\DriverStore\FileRepository\sdbus.inf_amd64_neutral_735aa3b5ee832f62" /ForceUnsigned

dir C:\mount\install\Windows\system32\DriverStore\sff*.inf /s
dir C:\mount\install\Windows\system32\DriverStore\FileRepository\sffdisk.inf_amd64_neutral_d2425e60845d17d3
dism.exe /image:"C:\mount\boot" /Add-Driver /driver:"C:\mount\install\Windows\system32\DriverStore\FileRepository\sffdisk.inf_amd64_neutral_d2425e60845d17d3" /ForceUnsigned

dism.exe /image:"C:\mount\boot" /Get-Drivers /Format:Table

fix_USB3_SD.cmd C:\mount\boot\Windows /SD_native_driver

dism.exe /Unmount-wim /mountdir:"C:\mount\boot" /commit
dism.exe /Unmount-wim /mountdir:"C:\mount\install" /discard

Boot boot.wim. Does diskpart find the eMMC, are partitions available?

Share this post


Link to post
Share on other sites
On ‎9‎/‎07‎/‎2016 at 2:57 AM, cdob said:

Read Win7-USB3.0-Creator-Readme-v3.pdf page 1,
1. Create a USB flash drive installer
2. Run the Utility

Boot boot.wim from this created USB flash drive.
Does diskpart.exe list the USB flash drive?

It seems like I don't have enough local disk space to run the installer =(. It gives no option for mount-path. I will try again on different computer tomorrow. Could I just manually add the drivers instead from that same folder?

I only have lexar 8gb and 32gb usb sticks currently, but can buy more if needed.

7 hours ago, cdob said:


Do not add USB3 drivers at first step. Add USB3 drivers later, if eMMC works by chance.

I think we've tried this previously (see page 1) and the result was:"No fixed disks to show"+"missing driver error".

I will try these things within a day

Share this post


Link to post
Share on other sites
3 hours ago, Tsundere said:

Could I just manually add the drivers instead from that same folder?

Follow the manual approach, just use the USB drivers from "Windows 7 USB 3.0 Creator Utility".
With luck, these drivers works at Windows 7 booted from USB hard disk.

I only have lexar 8gb and 32gb usb sticks currently, but can buy more if needed.

Overwrite the lexar stick, no need for more so far.

I think we've tried this previously (see page 1) and the result was:"No fixed disks to show"+"missing driver error".

Sorry for the confusion. Yes, this is expected, igonre this so far, do not contine setup, press shift F10 instead.
Remember small steps, this is the case: verify native SD drivers, searching a driver for the eMMC controller.
If native SD drivers works, then it's time to create the next step.

Share this post


Link to post
Share on other sites

I seem to be getting errors with command prompt, I will need to re-install windows 8 I think, please bear with me

Share this post


Link to post
Share on other sites
14 hours ago, Tsundere said:

I seem to be getting errors with command prompt, I will need to re-install windows 8 I think, please bear with me

Which errors? Please be explicit, report the EXACT errors and when they happen.

Before needing to reinstall a whole OS they must be VERY SERIOUS errors.

jaclaz
 

Share this post


Link to post
Share on other sites
On ‎10‎/‎07‎/‎2016 at 5:58 PM, cdob said:

dism.exe /Mount-WIM /WimFile:"U:\sources\install.wim" /index:2 /MountDir:"C:\mount\install"
dism.exe /Mount-WIM /WimFile:"U:\sources\boot.wim" /index:2 /MountDir:"C:\mount\boot"

dir C:\mount\install\Windows\system32\DriverStore\sdbus* /s
dism.exe /image:"C:\mount\boot" /Add-Driver /driver:"C:\mount\install\Windows\system32\DriverStore\FileRepository\sdbus.inf_amd64_neutral_735aa3b5ee832f62" /ForceUnsigned

dir C:\mount\install\Windows\system32\DriverStore\sff*.inf /s
dir C:\mount\install\Windows\system32\DriverStore\FileRepository\sffdisk.inf_amd64_neutral_d2425e60845d17d3
dism.exe /image:"C:\mount\boot" /Add-Driver /driver:"C:\mount\install\Windows\system32\DriverStore\FileRepository\sffdisk.inf_amd64_neutral_d2425e60845d17d3" /ForceUnsigned

dism.exe /image:"C:\mount\boot" /Get-Drivers /Format:Table

fix_USB3_SD.cmd C:\mount\boot\Windows /SD_native_driver

dism.exe /Unmount-wim /mountdir:"C:\mount\boot" /commit
dism.exe /Unmount-wim /mountdir:"C:\mount\install" /discard

Boot boot.wim. Does diskpart find the eMMC, are partitions available?

Attached is a log of my attempt and the error I got, and also my intended plan. E: drive is wd passport because I haven't enough space to mount on C:.

On ‎9‎/‎07‎/‎2016 at 7:52 PM, cdob said:

Run the "Windows 7 USB 3.0 Creator Utility" and open boot.wim at 7-zip next.
Does exist \Windows\system32\drivers\iusb3xhc.sys and iusb3hub.sys?

If not then, integrate the "Windows 7 USB 3.0 Creator Utility" drivers manually.


dism.exe /Mount-WIM /WimFile:"U:\sources\install.wim" /index:3 /MountDir:"C:\ISO\MOUNT"

	dism.exe /image:"C:\ISO\MOUNT" /Add-Driver /driver:"F:\Win7_USB3.0_Creator_v3\USB_Drivers\x64" /ForceUnsigned /recurse

	dism.exe /image:"C:\ISO\MOUNT" /Get-Drivers /Format:Table

	dism.exe /Unmount-wim /mountdir:"C:\ISO\MOUNT" /commit


Two drivers are added: x64\iusb3hub.inf and x64\iusb3xhc.inf


dism.exe /Mount-WIM /WimFile:"U:\sources\boot.wim" /index:2 /MountDir:"C:\ISO\MOUNT"

	dism.exe /image:"C:\ISO\MOUNT" /Add-Driver /driver:"F:\Win7_USB3.0_Creator_v3\USB_Drivers\x64" /ForceUnsigned /recurse

	dism.exe /image:"C:\ISO\MOUNT" /Get-Drivers /Format:Table

	dism.exe /Unmount-wim /mountdir:"C:\ISO\MOUNT" /commit[/CODE]


Also, I have been using x86 win7 iso all this time because from what I understand, x64 version makes it more complicated. So just to clarify: I should add x86 drivers?

Thanks

planofapproach.txt

log.txt

Edited by Tsundere

Share this post


Link to post
Share on other sites
16 minutes ago, Tsundere said:

Attached is a log of my attempt and the error I got, and also my intended plan. E: drive is wd passport because I haven't enough space to mount on C:.

Also, I have been using x86 win7 iso all this time because from what I understand, x64 version makes it more complicated. So just to clarify: I should add x86 drivers?

Use dirvers relating your ISO. Use x86 drivers, if you use a x86 OS.

The log shows adding driver from FileResopitory. No, there are no drivers, add the subfolder name. Compare instructions again.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...