Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


mixit

Enable MP4 (H.264 + AAC) HTML5 video in Firefox on Windows XP without Flash

Recommended Posts

Life is too short to watch long YouTube videos ;) ... but I guess that means someone still needs to try this and let us know if it makes a difference!

  • Like 1

Share this post


Link to post
Share on other sites

Let us all know how it works for you! And if you like to watch long Youtube videos, install Primetime CDM, disable ffvpx and let us know if Primetime happens to fix the 23 min. bug. Edit: Just discovered Primetime doesn't work with NM 28, so @obstinateXP will have to stick with native support (ffvpx) for modern videos.

Edited by Mathwiz

Share this post


Link to post
Share on other sites
On 9/18/2018 at 4:55 PM, WarwolfPrime said:

Firefox 28 on Windows XP

Haven't been here in awhile.  Have I missed something?  Why are we not using 52.9.0 ESR?

Share this post


Link to post
Share on other sites

A lot of folks still are, and it continues to work well. But some of us are concerned about the lack of further development and are exploring alternatives based on the same platform (FF 52), like MyPal, New Moon, and Basilisk (Serpent). The good news is Primetime works with those browsers too edit: Basilisk, so at least we have one modern browser build that still works with Primetime.

Edited by Mathwiz

Share this post


Link to post
Share on other sites
On 9/27/2018 at 4:41 PM, Mathwiz said:

Let us all know how it works for you! And if you like to watch long Youtube videos, install Primetime CDM, disable ffvpx and let us know if Primetime happens to fix the 23 min. bug.

Primetime CDM does not work with New Moon. The contents of gmp-eme-adobe folder are deleted. I don't know why.

Share this post


Link to post
Share on other sites

Confirmed, sort of; at least with the latest build of New Moon (28.2.0.a1 dated 2018-09-28). I had to add all the required preferences manually; after that, my gmp-adobe-eme\17 folder didn't get deleted, but Primetime still wouldn't show up in about:addons or about:plugins. Looks like the PM team did more to disable EME than just removing those preferences. Don't know if Primetime will work with MyPal but I sort of doubt it at this point.

Primetime does work with Basilisk, and I suspect it will also work with @roytam1's FF 45 build for pre-SSE2 machines. And of course it works with FF 52.9.

Share this post


Link to post
Share on other sites

Hi guys, Please Help me.

I'm not able to watch H.264 videos using Firefox 48 on Win XP SP3 (x86). CPU: AMD Sempron 2400+ 1.67 Ghz which does not support SSE2.My video card on the other hand is: ATI Radeon HD 4670 RV730 (AGP) which supports HEVC/H.264 codec. Is there any way I can work things out..any. Even if there's a different browser or smthng I can use.

Edited by dido_fan

Share this post


Link to post
Share on other sites
5 hours ago, Mcinwwl said:

Firefox 45 ESR by roytam1?:

https://rtfreesoft.blogspot.com/

it doesn't do hardware acceleration. grab the video and play it with MPC-BE Video decoder 1.4.6 with DXVA enabled to see if it will play smoothly or not.

Edited by roytam1

Share this post


Link to post
Share on other sites

@dido_fan:

Did you carefully carry out the configuration of your Mozzilla as detailed at the beginning of this thread? It works fine for me with the same Windoze and approximately the same machine.

Share this post


Link to post
Share on other sites

I've used the instructions in the start of this thread, and it worked for me, but now I have problems with some videos (like this https://www.youtube.com/watch?v=BUJiGnjGIoI) again, and https://www.youtube.com/html5 shows both H.264 and MSE & H.264 unsupported. I've rechecked the settings, the content of GMP-EME-ADOBE\17 in my profile, and my add-ons show Primetime CDM and Open264 Videocodec are always activated.

SOLVED! It was media.mp4.enabled set to false ;)
 

Edited by yun
Solved

Share this post


Link to post
Share on other sites

the instagram videos now doesn't work, shows black screen, we need a new patch or solution

1ik13s.jpg

Share this post


Link to post
Share on other sites

At present the only known fix for the Instagram issue is to switch to @roytam1's New Moon or Serpent browser. Note that of those, only Serpent supports Adobe's Primetime CDM plug-in.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×