Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


mixit

Enable MP4 (H.264 + AAC) HTML5 video in Firefox on Windows XP without Flash

Recommended Posts

19 hours ago, yun said:

FF 52.1.1, Windows XP SP3.

Check to see whether each and every needed directive is present in the about:config page.
It has happened many times to many of us that some directive or other disappears upon updading, even from a minor build to the next.

Share this post


Link to post
Share on other sites

24 minutes ago, dencorso said:

Check to see whether each and every needed directive is presente in the about:config page.
It has happened many times to many of us that some directive or other disappears upon updading, even from a minor build to the next.

I started from this. And BTW I didn't update anything since the time when all worked,

Share this post


Link to post
Share on other sites

I see... it's byte rust! :ph34r:
It seems you've got a bad case of it... :(

Share this post


Link to post
Share on other sites
16 hours ago, yun said:

An example of not working ones

I seem to fix some problems with unplayable YT videos in a counter-intuitive way: just disable playing mp4 at all by switching «media.mp4.enabled» config line to false. That second video works fine on my PC by using VP8/vorbis codecs instead. Of course, this also disables playing other mp4-sources.

Share this post


Link to post
Share on other sites
52 minutes ago, Tacit said:

I seem to fix some problems with unplayable YT videos in a counter-intuitive way: just disable playing mp4 at all by switching «media.mp4.enabled» config line to false. That second video works fine on my PC by using VP8/vorbis codecs instead. Of course, this also disables playing other mp4-sources.

Cool! It worked! I would have never come to such an idea myself ;)

Glory to Ukraine! 

Share this post


Link to post
Share on other sites

The disadvantage of that workaround, IIRC, is that the VP8/vorbis versions of YouTube videos sometimes don't appear straight away, so some new videos you may have to wait awhile until you can play them using that configuration.
:)

Share this post


Link to post
Share on other sites
4 minutes ago, Dave-H said:

The disadvantage of that workaround, IIRC, is that the VP8/vorbis versions of YouTube videos sometimes don't appear straight away, so some new videos you may have to wait awhile until you can play them using that configuration.

I don't think it'll be a problem, but if you know a better solution, tell us ;)

Share this post


Link to post
Share on other sites

Unfortunately I haven't any other suggestions.
It works fine for me with Firefox 52.3.0 ESR.
If it doesn't work for you, even after exhaustively following all the procedures, it's a bit of a mystery.
:(

Share this post


Link to post
Share on other sites

I have followed the steps above, however still does not work (FF 52.4.0 ESR , XP SP3). In the addons opions I can see the PCD module, however the following message appears: Primetime Content Decryption Module provided by Adobe Systems, Inc will be installed shortly, however it does not update/install. It is set to Always Activate, updates on.

I tried restarting the OS, FF, disabled firewall, same message

I have checked all these

media.gmp-eme-adobe.enabled (boolean, true)

media.gmp-eme-adobe.forceSupported (boolean, true; FF 49.0+)

media.gmp-eme-adobe.forcevisible (boolean, true; FF 45-48, no longer used in 49.0+)

media.gmp-eme-adobe.visible (boolean, true; FF 49.0+)

media.gmp-eme-adobe.version (string, 17; required for manual install now that automatic install is no longer an option)

media.gmp-eme-adobe.abi (string, x86-msvc-x86; not required, you can set it if you want to more closely mimic automatic install)

media.gmp-eme-adobe.lastUpdate (integer, 1500000000; not required, you can set it if you want to more closely mimic automatic install)

media.gmp.decoder.enabled (boolean, true)

media.eme.enabled

they are all correct

I see somewhere it was suggested to modify the string
media.gmp-manager.url  aus5.mozilla.org/update/3/GMP/%VERSION%/%BUILD_ID%/%BUILD_TARGET%/%LOCALE%/%CHANNEL%/%OS_VERSION%/%DISTRIBUTION%/%DISTRIBUTION_VERSION%/update.xml
from %Vesion% to %51.0% to mimic an older version, but this didn't work

Edited by DrWho3000
update

Share this post


Link to post
Share on other sites
9 hours ago, DrWho3000 said:

I have followed the steps above, however still does not work (FF 52.4.0 ESR , XP SP3). In the addons opions I can see the PCD module, however the following message appears: Primetime Content Decryption Module provided by Adobe Systems, Inc will be installed shortly, however it does not update/install. It is set to Always Activate, updates on.

I tried restarting the OS, FF, disabled firewall, same message

I have checked all these

media.gmp-eme-adobe.enabled (boolean, true)

media.gmp-eme-adobe.forceSupported (boolean, true; FF 49.0+)

media.gmp-eme-adobe.forcevisible (boolean, true; FF 45-48, no longer used in 49.0+)

media.gmp-eme-adobe.visible (boolean, true; FF 49.0+)

media.gmp-eme-adobe.version (string, 17; required for manual install now that automatic install is no longer an option)

media.gmp-eme-adobe.abi (string, x86-msvc-x86; not required, you can set it if you want to more closely mimic automatic install)

media.gmp-eme-adobe.lastUpdate (integer, 1500000000; not required, you can set it if you want to more closely mimic automatic install)

media.gmp.decoder.enabled (boolean, true)

media.eme.enabled

they are all correct

I see somewhere it was suggested to modify the string
media.gmp-manager.url  aus5.mozilla.org/update/3/GMP/%VERSION%/%BUILD_ID%/%BUILD_TARGET%/%LOCALE%/%CHANNEL%/%OS_VERSION%/%DISTRIBUTION%/%DISTRIBUTION_VERSION%/update.xml
from %Vesion% to %51.0% to mimic an older version, but this didn't work

Try this link:

media.gmp-manager.url  aus5.mozilla.org/update/3/GMP/51.0/20170413192749/WINNT_x86-msvc-x86/en-US/release/Windows_NT%205.1/default/default/update.xml

 

Share this post


Link to post
Share on other sites

tried that modifying the string then restarting ff Still shows Primetime Content Decryption Module provided by Adobe Systems, Inc will be installed shortly,

however it does not update/install. It is set to Always Activate, updates on.

tried the manual update said there wasn;t any

Share this post


Link to post
Share on other sites

Mine also stopped working, I had used the fixes previously for when it stopped working at version 52. So, I came back here to try to the Primetime manual install and I got stuck at the same place as DrWho3000. It was still sitting on "...will be installed shortly". HOWEVER, I set updates to Off, set the pref to this suggested by roytam1:

media.gmp-manager.url aus5.mozilla.org/update/3/GMP/51.0/20170413192749/WINNT_x86-msvc-x86/en-US/release/Windows_NT%205.1/default/default/update.xml

Then went back to Add-Ons and clicked on Check for Updates, and it installed :-) I'm good for YouTube videos, but I was good there, anyway...at least they were playing and I didn't notice a problem. The problem that brought me back here was that Facebook videos were not playing for me (one of my own livestreams). I still don't have that working right for some reason.

Share this post


Link to post
Share on other sites

@DrWho3000 & @procrastistamper
Adobe re-enabled access to the install package some time after it had disappeared, so currently the GUI method still works. It may disappear again at any time though (and not come back again), so I'm going to keep the manual method as the main one in the OP.

As for your problems: as long as you have all the prefs set right (cOrReCt cAsE, no typos like %51.0%), both the GUI method and the manual method should currently work. I ran tests with 52.4.0 ESR and saw no issues with either process. Based on @roytam1's contribution, I thought maybe they'd changed things so that %CHANNEL% being esr would no longer work, but changing only %VERSION% was still sufficient.

I believe you should still be able to install the plugin even if it later turns out it won't work properly (no SSE2, non-Intel, etc.) If something doesn't work with your everyday profile, create a new profile (with firefox -P) and try with that one. Disable automatic update checks - while I haven't been able to reproduce this, FF could run its auto-update while you're in the middle of things and mess things up for you. (Checking for updates without all the prefs set can leave you in an inconsistent state and you'd have to start from the beginning.) Since pre-existing plugins are initially enabled in a new profile, disable them all. Enter the preferences all in one go (copy&paste can avoid typos ;)) and don't fiddle with the Plugins page until you've added everything; best to close it beforehand, actually, to avoid an update check at the wrong time. If using the manual method, add all the preferences first, then close FF, then add the plugin files, then restart FF and verify. If it didn't take, make sure you've added the files in the right profile folder (open it from about:support). If still failing, recheck that all your prefs are still set the way you entered them and FF hasn't messed with them.

Assuming you can get Primetime working with a clean profile, make sure you start the installation as fresh as possible on your existing profile. Go to about:config, search for gmp-eme-adobe and use the Reset menu item to remove all those prefs, then close FF, then delete the gmp-eme-adobe folder under your profile, then open FF and do everything just as you did with the new profile. If it still doesn't take, try to eliminate possible external interference (such AV blocking the plugin files, firewall blocking download attempts). This seems unlikely to affect Primetime installation, but you can try and see if disabling all your browser extensions changes anything. (They can definitely interfere with playback, for example I've seen Video DownloadHelper mess up chunked streaming (as opposed to playing a single MP4 file) with its hooks.)

Can't really think of anything else that might help right now - it's a "works for me" situation after all. If all else fails, you could always try the custom Pale Moon XP builds with added MP4 playback capabilities @roytam1 and some others have been contributing.

Edited by mixit

Share this post


Link to post
Share on other sites

I've just noticed that Facebook videos have gone back to using the Flash Player for some reason.
I haven't knowingly changed anything.
YouTube still seems to be using HTML5.
Has this happened to anyone else?
I thought that Facebook videos had become a bit clunky, and some are not now playing automatically either, but I'm not sure exactly when this changed.
:(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×