Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Comos

Using up-to-date JRE on WinXP

Recommended Posts


From the log files, it could be coming from your system user32.dll and ms visual c++ runtime 10 also seems missing.

Perhaps you could post your user32.dll version and date and install the c++ runtime.

Share this post


Link to post
Share on other sites

Finally managed to get some time, to dig into this problem.The chksk /F /R took a while, but didn't show up any critical errors. After I run the sfc /scannow , which didn't reported any issues.However after the sfc, the installer ended shortly, stating that there is not Windows Installer used so I installed again the Windows Installer 4.5.After that it still reports the issue like before.Meanwhile I tried to reinstall (repair) the Microsoft Visual C++ 2010 Redistributable,but again without luck.

The USER32.DLL version is 5.1.2600.5512 (xpsp.080413-2105)

Share this post


Link to post
Share on other sites

Uhm... Which is very weird.

According to your logs, everything starts with a call to the function GetProcAddress which fails to load SetProcessDPIAware in user32. In other words, Java checks your system before initialising the GUI and fails before actually being able to launch it. Since it's not necessary, you could try to edit the application's manifest to set DpiAware to false, but:

1) I'm not sure whether it would actually make it run or it would end up with another error (probably the latter).

2) This is not the right approach since it's a system-related issue; 100%.

I'm not even actually sure about the requirements of Java, but I have .NET (1.0, 1.1, 2.0, 3.0, 3.5, 4.0) and C++ (2005, 2008, 2010, 2012, 2013, 2015) installed; do you have them installed too?

Edited by FranceBB

Share this post


Link to post
Share on other sites
19 hours ago, FranceBB said:

Uhm... Which is very weird.

According to your logs, everything starts with a call to the function GetProcAddress which fails to load SetProcessDPIAware in user32. In other words, Java checks your system before initialising the GUI and fails before actually being able to launch it. Since it's not necessary, you could try to edit the application's manifest to set DpiAware to false, but:

1) I'm not sure whether it would actually make it run or it would end up with another error (probably the latter).

2) This is not the right approach since it's a system-related issue; 100%.

I'm not even actually sure about the requirements of Java, but I have .NET (1.0, 1.1, 2.0, 3.0, 3.5, 4.0) and C++ (2005, 2008, 2010, 2012, 2013, 2015) installed; do you have them installed too?

C++ what I have installed is: 2005 ATL Update kb973923 v8.0.50727.4053, 2005 redist, 2008 v9.0.30411, v9.0.30729, v9.0.30729.4148, v9.0.30729.6161, 2010 v10.0.30319, 2013 v12.0.30501.0, 2015 Redist v14.0.23026.0.
.NET (2.0 SP2, 3.0 SP2, 3.5 SP1, 4 Client Profile, 4 Extended)

Share this post


Link to post
Share on other sites

Uhm... This is so weird...

C++ installed, .NET installed, check disk that didn't report any errors as well as sfc/scannow...

That's weird, really. I mean, if it works on our machines, then it's a system-related issue, but everything seems fine on your system... Besides, I have a localised version of XP and Java installed fine anyway, so it's not even that. I could edit the application's manifest, but I'm not actually sure whether it's the right thing to do. Maybe is something in the registry. I mean, maybe there's an entry created by a former version that hasn't been deleted when you tried to uninstall and install everything again and that is now in conflict with the installation, or maybe it's a previous installation which failed but still created some entries... Try to look for Java entries in the registry (use the search function) and see if there's something about the latest installation (I mean the version that fails to install). If you actually find something, write it down here in the forum and we'll tell you whether is safe to delete it/modify it or not.

Edited by FranceBB

Share this post


Link to post
Share on other sites
On 20. 5. 2016 at 8:42 PM, FranceBB said:

Uhm... This is so weird...

C++ installed, .NET installed, check disk that didn't report any errors as well as sfc/scannow...

That's weird, really. I mean, if it works on our machines, then it's a system-related issue, but everything seems fine on your system... Besides, I have a localised version of XP and Java installed fine anyway, so it's not even that. I could edit the application's manifest, but I'm not actually sure whether it's the right thing to do. Maybe is something in the registry. I mean, maybe there's an entry created by a former version that hasn't been deleted when you tried to uninstall and install everything again and that is now in conflict with the installation, or maybe it's a previous installation which failed but still created some entries... Try to look for Java entries in the registry (use the search function) and see if there's something about the latest installation (I mean the version that fails to install). If you actually find something, write it down here in the forum and we'll tell you whether is safe to delete it/modify it or not.

I already tried to remove all the crap from the registry with JavaRa.I checked the registy, but seems nothing suspicious apart,that there are keys from the last working version 1.8.0u51.Path to this version I have still in the enviroment variables.However I still find some keys,that I expect that should be removed.I have made an export with Nirsoft's regscanner,that you can take a look.

JavaRegKeys.reg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...