Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


WinClient5270

Last versions of software for Windows Vista and Windows Server 2008

Recommended Posts

@FantasyAcquiesce

Thanks for your info... :) BUT...

The latest version available on the linked site is 3.0.205.0 and yes, min Windows version compatible is Windows Vista (32-bit and 64-bit) - no surprise then that the client wouldn't run under XP...

The downloaded standalone installer has a digital SHA1 signature of May 20th 2018 :angry: ; even worse, when the installer is extracted/installed, the browser has a buildID of 20150421120931 (i.e. April 21st 2015); in this case, New Moon is just a generic UNBRANDED fork name, not to be confused with @roytam1's unbranded builds... :P

The BlackHawk browser build is based on Pale Moon 25 (platform is Gecko 25.3.0), so extremely outdated security/features-wise -_-; IMHO, that browser deserves an entry inside digital history books, not installed in one's Vista machine today... :(

(OT: I honestly hope you're well - stay safe :) )

  • Upvote 2

Share this post


Link to post
Share on other sites

Posted (edited)
7 hours ago, rryan22 said:

Is Reallusion Software a last version of Windows Vista?

7 hours ago, rryan22 said:

Is Reallusion Software working on Windows 2000?

@dencorso : Methinks the above two posts are just outright "plug" attempts for the referenced payware software manufacturer :realmad: ; new MSFN user @rryan22 has just subscribed 6 hours ago with the (apparent) sole intent of making those two posts... :sneaky: And while the country of origin has been declared as the UK, the quality of the English language used points more to a translation machine/web bot, e.g.:

7 hours ago, rryan22 said:

Do who needs a Reallusion Software unofficially on Windows 2000, let it know if it needs it!

Just to be on the clear, I have nothing personal against payware (coders certainly have to make a living) or people without an adequate command of the English language (which is the default in these forums...). However, unless @rryan22 has personally tested every individual piece of payware software he has mentioned as the last one working on Vista/Win2k, then I'll continue to treat his posts as disguised advertisement attempts... BTW, should any of the claims made be true, why isn't a transparent approach of accessing those older, still payware, software versions offered? :dubbio:

Edited by dencorso
rryan22 just fell down the memory hole...
  • Like 2
  • Upvote 2

Share this post


Link to post
Share on other sites

Just like qbittorrent towards the end of last year, another open-source bit torrent client, Transmission, has progressed past Windows Vista (and XP) support :( :angry: ...

Transmission is a well known bit-torrent client, especially popular among Mac users, preffered due to its low memory footprint on the host system; its home site is hosted at: 

https://transmissionbt.com/

while the open-source code is hosted at GitHub: 

https://github.com/transmission/transmission

While the back-end is cross-platform, the Windows port/front-end builds on the popular Qt Framework (much like the Windows port of qbittorrent); over the last two years, official releases appeared to have remained stagnant at version 2.94 (issued on May 1st 2018), built with Qt FW 5.6.0.

Some days ago, new official release v3.00 came to light which, most sadly, has minimum WinOS requirements met by Windows 7; v3.00 has been built using Qt 5.14.2 which, by itself, denies any XP+Vista support; earlier in this very thread it was detailed that the last Qt version with FULL Vista support was 5.6.3 (with some rare app exceptions cited that manage to run under Vista while built on Qt 5.7.x/5.9.x); it's still possible, because I haven't bothered to check, that the core Transmission code now intentionally targets Win7+ and thus the breakage is not entirely due to the move to a higher Qt version :dubbio:...

To cut it short, Transmission v2.94 from 2018 is now the EoS'ed version for both Windows XP SP3/Windows Vista SP2

(official links to MSI installers:)  transmission-2.94-x86.msi  transmission-2.94-x64.msi

With the popular (but adware/bloatware/spyware) uTorrent application having abandonned XP+Vista several months ago, the addition of Transmission (along with qbittorrent) to the list of bit-torrent clients that aren't maintained anymore under Vista limits extremely the choice of such a client under that OS (with, off-the-top-of-my-head, the closed-source Tixati being one of the last available choices... :( ) ...

  • Upvote 1

Share this post


Link to post
Share on other sites

My friend, with all due respect: those die-hards like me who eschew a full-body velostat gimp-suit can keep using the good old free, no-installation-needed (portable), single executable, µTorrent v.2.0.2.19648, which keeps working like clockwork. All others had better move on to 10 release 2004   :puke:  (or whatever)...  :angel

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

@dencorso Agreed.  Just because the latest release is no longer compatible with XP, doesn't mean that the last release that is won't suddenly stop working (we've seen some rather unscrupulous examples of that elsewhere over the 6 or so years since XP's "official" EoS).

My understanding is that, while Bittorrent has added new features to its protocols over the years since it was introduced, the basic architecture is more or less the same, and virtually all clients, new and old, can still connect to it just fine, just without the advanced features of newer versions.  Unless I'm missing something?

 

On 5/27/2020 at 12:20 PM, dencorso said:

...full-body velostat gimp-suit...

With all the paranoia surrounding the coronavirus lately, this is actually becoming a real life phenomena, something I never thought would happen!  (I kid you not, I recently came across a headline (from a reputable source) that stated that some people are *wearing hazmat suits on airplanes* because of the extreme fear of acquiring the virus!)  While i won't be stupid and go put myself in a situation where I'd be infected, I'm not going to live in that kind of fear.  Same applies to old Windows and software.  While I will use newer, safer software when appropriate (online shopping, banking transactions, etc.), I'm not going to stop using XP, Vista or 7 (or any software thence developed) simply because MS isn't releasing patches for them anymore!

Enough said.

c

Edited by cc333
  • Like 1

Share this post


Link to post
Share on other sites
51 minutes ago, cc333 said:

Unless I'm missing something?

No, you aren't. There was some talk of vague vulnerabilities, AFAIK never known to have ever been exploited since then, which, IMO were just the usual FUD to force people to update to adware-ladden and or telemetry-ladden later versions. The adware could be prevented from installing and/or removed afterwards, but you know most people won't bother or be able to do that. µTorrent v.2.0.2.19648 was the last that was a single executable requiring no installation at all, so IMO is the one with best cost to benefit up to now. :yes:

Share this post


Link to post
Share on other sites
27 minutes ago, dencorso said:

No, you aren't.

Thought so!  I like to know what I'm using, how it works and why, so I'm glad I figured it out successfully in this case!

Anyway, back to the topic at hand (sorta), I use Transmission on Mac all the time, as it is the only BT client I've used (for Mac, anyway) whose UI is sensible and easy to use.  i knew it also supported Linux, but until today, I didn't know (or had forgotten) that there was a Windows port that ran on XP/Vista!

c

Share this post


Link to post
Share on other sites
On 9/18/2019 at 3:42 AM, Jaguarek62 said:

Hi everyone,

So today rockstar released a new launcher for their games. Including my favorite GTA V. There's small catch. It no longer supports Vista. I have found a bypass, but I'm not sure for how long this is going to work.

You need to uninstall the new launcher. Grab the old one (Vista saves folders history maybe you can find it there in "Installers" folder) and install it. Now you need to delete "PlayGTAV.exe". Copy "GTAVLauncher" to your desktop and name it "PlayGTAV.exe" and put it to your gta v folder. That's it. I have tried it only on steam version so i have no idea if this is going to work on dvd version.

 

Cheers

Is that method still working? I had no luck on my GTA 5. I didn't had folder history cause i recently install it, so i download it and i renamed the GTAVLauncher to PlayGTAV.exe and it prompt "Please launch GTA V using PlayGTAV.exe" when i launching it. Maybe i wrongly download the version?

 

Share this post


Link to post
Share on other sites
Posted (edited)
On 7/2/2018 at 11:13 PM, WinClient5270 said:

Looks like GIMP has dropped support for Windows Vista as of version 2.10.0 (stable; 2.9 dev) :(

As such, I have added GIMP 2.8.22 to the list as the last version for Windows Vista:

Actually, 2.10.0 x64 runs on Vista. Download gimp-2.10.0-x64-setup.exe from https://download.gimp.org/mirror/pub/gimp/v2.10/windows/ and you will notice that the installer doesn't block Vista like those for later 2.10 releases. The module that calls SetThreadErrorMode in later releases doesn't call it in this one.

huh? 404? what a shame since 2.10.2's installer blocks Vista!

Edited by win32
download is back up
  • Like 2

Share this post


Link to post
Share on other sites
On 6/18/2020 at 10:42 PM, win32 said:

Actually, 2.10.0 x64 runs on Vista. Download gimp-2.10.0-x64-setup.exe from https://download.gimp.org/mirror/pub/gimp/v2.10/windows/ and you will notice that the installer doesn't block Vista like those for later 2.10 releases. The module that calls SetThreadErrorMode in later releases doesn't call it in this one.

huh? 404? what a shame since 2.10.2's installer blocks Vista!

Thank you for clarifying. Updated:

On 3/1/2016 at 8:31 PM, WinClient5270 said:

Video & Photo Editing Software:

...

GIMP 2.10.0 (FREEOS) Download from vendor here.

Share this post


Link to post
Share on other sites
Posted (edited)

Phew... After over an hour, I have finally checked every single link on the list to make sure everything still worked, and fixed quite a few broken ones. I hadn't done this since around 2017, so hopefully all the links should be working now for a while :)

Edited by WinClient5270
  • Like 1
  • Upvote 1

Share this post


Link to post
Share on other sites
Posted (edited)

I did installed 3d youtube downloader 1.19.4 beta on my server 2008 the software runs but its not downloading the videos which is very strange because the same software runs on Windows 7 sp1 perfectly Anyone have any suggestion?

Edited by Nandor
Solved the problem the default path was non existent when i changed to the root it started saving the videos so yes it is working on server 2008

Share this post


Link to post
Share on other sites

Under DVR/PVR Software, NextPVR no longer has ONG support for Vista, and a legacy download link for version 4.2.5 seems to be needed: https://forums.nextpvr.com/showthread.php?tid=59880. (Recent 5.x versions require .NET Core, which was shown not to work on Vista earlier in this thread.)

Also, Microsoft’s electronic program guide service ended on April 2, 2020, which greatly reduces the appeal of adding TV Pack 2008 to Vista systems with Windows Media Center.

  • Upvote 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...