Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


WinClient5270

Last versions of software for Windows Vista and Windows Server 2008

Recommended Posts

Is there anyone here with a DX11 capable GPU that could test if Cuphead still works on Vista? I've tried it yesterday, but it crashes shortly after choosing the slot you want your saved game to be on:

cuphead.thumb.png.dd97a8c99160a7288a63b15652b478c1.png

Older version, 1.1.5, still works fine though. Not sure if it happens because my GPU is only capable of DX10 or Cuphead  stopped being compatible with Vista altogether. Also, links to the last Vista compatible version of Rufus in the first post now return a 404 found page, correct links are https://github.com/pbatard/rufus/releases/download/v2.18/rufus-2.18.exe and https://github.com/pbatard/rufus/releases/download/v2.18/rufus-2.18p.exe.

Share this post


Link to post
Share on other sites

1 hour ago, Kwasiarz said:

Is there anyone here with a DX11 capable GPU that could test if Cuphead still works on Vista? I've tried it yesterday, but it crashes shortly after choosing the slot you want your saved game to be on:

Older version, 1.1.5, still works fine though. Not sure if it happens because my GPU is only capable of DX10 or Cuphead  stopped being compatible with Vista altogether. Also, links to the last Vista compatible version of Rufus in the first post now return a 404 found page, correct links are https://github.com/pbatard/rufus/releases/download/v2.18/rufus-2.18.exe and https://github.com/pbatard/rufus/releases/download/v2.18/rufus-2.18p.exe.

According to GrandAdmiralThrawn of xin.at, new builds support only DX11 due to upgrade of Unity engine to 2017.4.9f1: http://wp.xin.at/archives/4626#comment-161620

Edited by IntMD

Share this post


Link to post
Share on other sites
9 hours ago, IntMD said:

According to GrandAdmiralThrawn of xin.at, new builds support only DX11 due to upgrade of Unity engine to 2017.4.9f1: http://wp.xin.at/archives/4626#comment-161620

I'm not a gamer, but Vista SP2 with Platform Update supports DX11. Cuphead reportedly requires Geforce 9600 GT or higher (which would rule out my system in any case).

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, Vistapocalypse said:

I'm not a gamer, but Vista SP2 with Platform Update supports DX11. Cuphead reportedly requires Geforce 9600 GT or higher (which would rule out my system in any case).

True, but Kwasiarz has mentioned that his GPU only capable of DX10 and below, so.

Share this post


Link to post
Share on other sites

Calibre 3.48 is the last version of e-book management software, that works on Vista.

  • Like 1
  • Upvote 1

Share this post


Link to post
Share on other sites
9 hours ago, artomberus said:

Calibre 3.48 is the last version of e-book management software, that works on Vista.

Welcome back artomberus! :hello: Note at Calibre's Download for Windows page confirms what you are saying.

  • Like 1

Share this post


Link to post
Share on other sites
On 10/5/2019 at 6:39 PM, Vistapocalypse said:

Welcome back artomberus! :hello:

Yes, long time since I wrote here - but I check this topic regularly ;) Just usually there is nothing to add)

It seems that Viber was not mentioned? Version 6.8.2 still working for me in Vista. 2 years after the release of the application :)

  • Like 2

Share this post


Link to post
Share on other sites
4 hours ago, artomberus said:

It seems that Viber was not mentioned? Version 6.8.2 still working for me in Vista. 2 years after the release of the application :)

Have you tried newer versions of Viber on Vista? They probably won't work in light of Viber | Supported platforms. Is it still possible to download version 6.8.2 from viber.com? I see a download link for Windows XP at bottom right of Download | Viber, but it gives even older version 6.0.1.5. However some third-party sites have 6.8.2.

  • Upvote 1

Share this post


Link to post
Share on other sites

@Vistapocalypse, yes, I tried version 6.8.5 - it gives an error about dll incompatibility. I downloaded Viber from FileHippo. https://filehippo.com/download_viber_for_windows/history/6/  In the end of page. Unfortunately, we can no longer officially download Viber 6.8.2.

UPD. Here is the "almost official" link (to 6.8.1, not 6.8.2 :( ), through webarchive - http://web.archive.org/web/20170606091256/https://download.cdn.viber.com/desktop/windows/ViberSetup.exe  It must work.

Edited by artomberus
new link
  • Like 1

Share this post


Link to post
Share on other sites
Quote

Viber for Desktop is synced to your mobile account. To activate Viber for Desktop, you will need an active Viber account on your mobile phone.

Was this requirement already present in version 6.8.2? It might be a good replacement for Skype in any case.

Share this post


Link to post
Share on other sites
1 hour ago, Vistapocalypse said:

Was this requirement already present in version 6.8.2? It might be a good replacement for Skype in any case.

Yes. It asks about mobile account at first start.

Edited by artomberus
  • Like 1

Share this post


Link to post
Share on other sites
On 9/29/2019 at 10:57 PM, Kwasiarz said:

Is there anyone here with a DX11 capable GPU that could test if Cuphead still works on Vista? I've tried it yesterday, but it crashes shortly after choosing the slot you want your saved game to be on:

cuphead.thumb.png.dd97a8c99160a7288a63b15652b478c1.png

Older version, 1.1.5, still works fine though. Not sure if it happens because my GPU is only capable of DX10 or Cuphead  stopped being compatible with Vista altogether. Also, links to the last Vista compatible version of Rufus in the first post now return a 404 found page, correct links are https://github.com/pbatard/rufus/releases/download/v2.18/rufus-2.18.exe and https://github.com/pbatard/rufus/releases/download/v2.18/rufus-2.18p.exe.

i can if you want , 1060 gtx here on vista sp2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...