Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


WinClient5270

Last versions of software for Windows Vista and Windows Server 2008

Recommended Posts

Posted (edited)

One thing I overlooked: The absolute final version of LibreOffice for Windows Vista has been released; version 5.4.7.2. LibreOffice 5.4.x is now EOL and will no longer receive updates. Since this was the last version to support Vista (and XP too I believe), this means that Vista is no longer supported by LibreOffice.

I have updated the list with this information:

On 3/1/2016 at 8:31 PM, WinClient5270 said:

Office Suites:

...

LibreOffice 5.4.7.2 (FREEOS) Download from vendor: x86  x64

Edited by WinClient5270
  • Upvote 1

Share this post


Link to post
Share on other sites

Version 1.1.14 Released Dec. 4, 2017 1.4 MiB Works with Firefox for Android 56.0a1 and later, Firefox 56.0a1 and later
Source: https://addons.mozilla.org/en-US/firefox/addon/umatrix/versions/

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)
12 hours ago, Chronius said:

About uMatrix, it seems that the latest version for Firefox 52/Pale Moon and other browsers similar to those is in fact version 1.1.4, which can be found here:

https://github.com/gorhill/uMatrix/releases/tag/1.1.4

and not 1.0.0 mentioned in the OP. (it's the one named "uMatrix.firefox.xpi")

Thanks for letting me know! Fixed. :)

12 hours ago, Osan said:

Version 1.1.14 Released Dec. 4, 2017 1.4 MiB Works with Firefox for Android 56.0a1 and later, Firefox 56.0a1 and later
Source: https://addons.mozilla.org/en-US/firefox/addon/umatrix/versions/

You must have misread; @Chronius said 1.1.4, not 1.1.14. However the requirements are the same for both versions (Firefox 56 or later). However, despite the developers claiming to only support Firefox 56 or later with this version, Version 1.1.4 works just fine with Firefox 52.9.0:

pBxLNPJxSmG_zAip7EbBJQ.png

However, you must download and install it manually via the developers' GitHub page (as linked by @Chronius) as trying to install it from the Firefox Add-on page results in this message:

mWqM86ssT42ZdBb3LBge1w.png

You must also disable the extension signature requirement, otherwise Firefox won't let you install it. To learn how to do this, go here.

 

Anyway, I have added Umatrix 1.1.4 as the last version for Firefox 52 ESR as a UNS entry, since this isn't officially supported, but still works as long as you follow what I outlined above.

On 3/1/2016 at 8:31 PM, WinClient5270 said:

Final versions of Add-ons/Plug-ins for Firefox 52 ESR:

...

Umatrix 1.1.4 (FREEOS, UNS) Requires certain procedures to be installed as this isn't officially supported (but despite this, works fine); go here for more details.

Edited by WinClient5270
  • Like 1
  • Upvote 1

Share this post


Link to post
Share on other sites
Posted (edited)

Another thing: SMITE recently announced that their games will no longer support Windows Vista (and XP) starting in September of this year:

https://smitescrub.com/2018/08/22/smite-to-no-longer-support-windows-xp-and-windows-vista/
 

Also, I doubt anyone here uses this software, but ApexSQL Diff no longer supports Windows Vista/Server 2008 starting with the 2018 release, meaning that ApexSQL Diff 2017 R6 is the last version for these operating systems.

Source: https://blog.apexsql.com/apexsql-diff-2018-product-update-alert/

On 3/1/2016 at 8:31 PM, WinClient5270 said:

Software/Game Development:

ApexSQL Diff 2017 R6 ($$$CS) Requires SP2.

Edited by WinClient5270

Share this post


Link to post
Share on other sites
16 hours ago, WinClient5270 said:

Another thing: SMITE recently announced that their games will no longer support Windows Vista (and XP) starting in September of this year:

https://smitescrub.com/2018/08/22/smite-to-no-longer-support-windows-xp-and-windows-vista/
 

Also, I doubt anyone here uses this software, but ApexSQL Diff no longer supports Windows Vista/Server 2008 starting with the 2018 release, meaning that ApexSQL Diff 2017 R6 is the last version for these operating systems.

Source: https://blog.apexsql.com/apexsql-diff-2018-product-update-alert/

Umatrix 1.1.4 from the oficial firefox addons page is signed and no workaround is necessary so you can download the file with right click

Share this post


Link to post
Share on other sites
Posted (edited)

It appears that Comodo Free Antivirus now only supports Windows 7 or higher :(

EDIT:  Actually it appears to install  :)

 

Edited by Jody Thornton

Share this post


Link to post
Share on other sites

Sorry all for the inactivity lately, I've been extremely busy with my job for the past 2 weeks so I haven't had time to be online much... However now that that's over, I should be online regularly from now on :)

Well since I was last online, Firefox support for Windows Vista has finally come to an end as of September 5. Since this date, when viewing the "About" box, rather than simply saying "up to date", you're now given a message that you can't perform further updates on the system:

V8d_azCPSsu-w2oxwHPKbQ.png

As such, I have also removed all ONG tags from other Firefox 52-based browsers that had it (such as Tor Browser & SeaMonkey) as it's unlikely that these browsers will receive any further updates on Windows Vista.

Firefox 52 ESR has also been removed from the download site for Firefox ESR, and Firefox 60 is the only listing now.

On August 27, 2018 at 10:27 AM, Jody Thornton said:

It appears that Comodo Free Antivirus now only supports Windows 7 or higher :(

EDIT:  Actually it appears to install  :)

 

It even works on Windows XP from my testing, so I'd say that Vista is officially supported along with it, it's just not clarified on their website.

SUMMARY OF CHANGES TO THE LIST FOR SEPTEMBER 9, 2018:

  • Fixed broken download link for AOL Shield Browser v1.0.0.35.
  • Fixed broken download link for Comodo IceDragon 52.0.0.4.
  • Changed download link for Firefox 52 ESR to Mozilla FTP download link since the browser has been removed from Mozilla's download page for Firefox ESR.
  • Added NoScript 5.1.8.6 as last version for Firefox 52 ESR in "Final versions of Add-ons/Plugins for Firefox 52 ESR" section.
  • Removed all information regarding Firefox 52 End of Life, as the browser is now EOL as of September 5, 2018 and will receive no further updates. This also means that any Firefox 52 derivatives will also more than likely receive no further updates.
Edited by WinClient5270
  • Like 1
  • Upvote 1

Share this post


Link to post
Share on other sites
2 hours ago, WinClient5270 said:

It even works on Windows XP from my testing, so I'd say that Vista is officially supported along with it, it's just clarified on their website.
 

Yes Comodo AV is running on my mom's XP box, so I can 100% confirm this.

 

  • Upvote 2

Share this post


Link to post
Share on other sites
4 hours ago, Jody Thornton said:

Yes Comodo AV is running on my mom's XP box, so I can 100% confirm this.

 

Oops, I made a typo... Meant to put that it was not clarified on their website since they seem to be keen on advertising support for Windows 7.

However, I'll monitor compatibility closely with the current ONG AV software listings as I wouldn't be surprised if the EOL of Avast AV for XP/Vista on 01/01/2019 will cause a domino effect of other vendors following suit, similar to when Google Chrome dropped support in April 2016... :unsure:

Edited by WinClient5270

Share this post


Link to post
Share on other sites

Another thing I overlooked: the last version of the Mozilla Thunderbird email client has also been released for Windows Vista (and XP) - version 52.9.1. The latest version, 60.0, requires Windows 7 or later, so I have added 52.9.1 as the last version for Windows Vista to the Email Clients section:

On 3/1/2016 at 8:31 PM, WinClient5270 said:

E-mail Clients:

...

Mozilla Thunderbird 52.9.1 (FREEOS) Download from Mozilla here (choose your language/country from the listing, and you should then be able to download the appropriate installer).

Share this post


Link to post
Share on other sites

The last version of Noscript classic is 5.1.8.7:

 

https://noscript.net/getit

Quote

Notice: you may need to open about:config and set your xpinstall.signatures.required preference to false in order to install, since Mozilla doesn't support signatures for legacy add-ons anymore

 

NoScript Classic has been updated to fix a vulnerability that allows full bypass of Tor Browser older than v8.0.

:hello:

 

 

Edited by Sampei.Nihira
  • Like 2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×