Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
jonfrederick

Windows Broadband device USB Verizon modem will not autoconnect

Recommended Posts

Working with Windows 8.1 and using a USB Verizon 4G LTE Modem as a Windows Broadband device on a mobile asset, and when signal is very low for a period of time the modem will "disconnect" from the VZ network and will not auto connect once the signal gets stronger.

 

The end users are finding this to be inconvenient for them that the modem doesn't auto connect. I'd rather have them keep their eyes on the road then checking the connection.

 

I have researched this on the Verizon site and the internet for answers to remedy this, without success.

 

Is there a registry key or a setting that I might be over looking that will cause the connection to keep trying until it connects?

 

To write a script for the Windows Broadband to check the connection state, signal strength, and reestablish connection that will run under a non-admin account would be great, but to be honest I don't know where to begin to make script for that, found no examples during my search.

 

Does anyone have any ideas, suggestion?

 

Jon 

Share this post


Link to post
Share on other sites

How do you go about fixing the issue manually?

 

I have a similar thing with my cell phone on Verizon's network. It is supposed to be on 4G LTE all the time, but sometimes if the signal drops it will disconnect from the 4G signal and connect to the 3G signal. This doesn't actually cause me a performance problem because I don't use big data on the phone. The way I can get it back to 4G is to put it in airplane mode, then turn off airplane mode. Then it reconnects to 4G.

 

I bring this up because it is possible that there is a shared hardware behaviour at work here and not necessarily just a software issue.

 

What is the model of the modem device you are using?

Share this post


Link to post
Share on other sites

The end users as mentioned expect it to just work (like most do), so they may go for minutes to hours before noticing the Verizon modem is not connected, at which point they either restart the mobile pc or open the Windows wireless list of connections, and click connect for the Verizon 4G LTE connection.

 

When the end users go into the Verizon connection in the Windows wireless connection list the option for "connect automatically" is selected including the option for "roam automatically".

 

We use the Pantech UML290 USB 4G/LTE modems for our Paramedic's mobile computers and when its in place the Paramedics' set the modem to 3G only, but the non-auto connect happens in either mode 3G or 4G.

 

I have done more research on scripts for batch file or power-shell, enough to make your head hurt.

 

So far the only script I have found that may hold promise is a batch file that does run in Windows 8.1.

 

ping -n 1 google.com
if %errorlevel% EQU 0 goto end
netsh wlan disconnect interface=”Wireless Network Connection”
TIMEOUT 5
netsh wlan connect ssid=”My Wireless Network” Name=”My Wireless Network” Interface=”Wireless Network Connection”
:end

 

It works as written; now I just need to spin up a mobile computer with the modem, alter the script and test it. No holding my breath, willing to give a shot.  

However if the script does work, its far from being what I need for 24/7/365 operation.

Edited by jonfrederick

Share this post


Link to post
Share on other sites

We use the Pantech UML290 USB 4G/LTE modems

Looking that model up on google with "disconnect" sure brings up a lot of results. Have you tried different driver versions? Also in Device Manager, is there power settings for the device?

Share this post


Link to post
Share on other sites

Currently using driver version 4.14.8 from Pantech, have not yet back rev'd and or seen if there is a newer version as of yet.

 

Yeah I looked in device manager for a power setting for the device, I don't see a tab and or option in the device option list.

Share this post


Link to post
Share on other sites

I realized just now that I did not mention I am letting Windows manage the connection (but I'm think that was guessed already), no VZ Access Manager is involved.

Share this post


Link to post
Share on other sites

Found a good path to go down for this. Requires more work, however looks like what might be required to accomplish the task. Helpful nugget that I came across finally; c:\ProgramData\Microsoft\WwanSvc

 

<Name>Verizon Wireless</Name>
<IsDefault>true</IsDefault>
<SubscriberID>31-*****----***-467</SubscriberID>
<SimIccID>8*********-----***4</SimIccID>
<HomeProviderName>02</HomeProviderName>
<AutoConnectOnInternet>true</AutoConnectOnInternet>
<ConnectionMode>manual</ConnectionMode>
<Context>
<AccessString>Internet</AccessString>
<Compression>DISABLE</Compression>
<AuthProtocol>NONE</AuthProtocol>
</Context>
</MBNProfile>

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...