Jump to content

Aero Glass for Win8.1+ 1.4


bigmuscle
 Share

Recommended Posts

 

 Aero Glass for Win8.1+ v1.4

* hardcoded symbol patterns for current version of DWM in Win8.1* lots of stability and performance fixes and code refactoring

 

Trying to make a decision about whether to replace the Aero Glass components on a perfectly functioning Win 8.1 setup with the new release.

 

Is 1.4 compellingly better for use on Win 8.1 than its predecessor, which seems perfectly stable and fast?

 

I've tested it in a Win 8.1 VM; it appears to work fine.  

 

Up above, "hardcoded" is mentioned.  Is 1.4 equally flexible as 1.3 if Microsoft should update the DWM components for Win 8.1?  Will 1.4 attempt to compensate by downloading symbols, as past versions have done?

 

-Noel

Edited by NoelC
Link to comment
Share on other sites


Up above, "hardcoded" is mentioned.  Is 1.4 equally flexible as 1.3 if Microsoft should update the DWM components for Win 8.1?  Will 1.4 attempt to compensate by downloading symbols, as past versions have done?

Version 1.4 is just successor of 1.3.1 regardless the Windows version.

May be I used wrong words but "hardcoded symbol patterns" simply means that you can be 100% sure that this version does not need external PDB files for DWMCORE/UDWM up to this date (should be 9600.17795). Version 1.3.1 was 100% ensured only up to build 9600.17415, but if I remember correctly significant changes after 17415 were only in 32-bit Windows.

I know this may be a stupid question, but has anyone tried this on the 10525 insider build to see if it still works? Honestly, I don't think it will but figured it couldn't hurt to ask.

It should work but only experimentally. You may need symbol files in some cases which were not released by Microsoft yet. Edited by bigmuscle
Link to comment
Share on other sites

I've tested it in a Win 8.1 VM; it appears to work fine.  

 

 

Already saw a glitch with 1.4 when getting ready to log into my Win 8.1 workstation.  When the lock screen slides up, it ends up all broken up.  This was after logging off only.  I'm going to reboot the whole system just to be sure it's not a transient issue.

 

BrokenLogonScreen.jpg

 

Edit:  It does it after bootup as well.

 

The logon prompt background seems to jump in reducing stages of transparency as I type, as does the blue screen between logon and the actual desktop.  But all the problems seem to be limited to the logon process.  Everything on the desktop seems to be working okay.  I can live with this.

 

Note that I am using the March 8 UxThemeSignatureBypass DLLs.

 

debug.log:

 

[2015-08-26 14:53:17][0xA08:0x42C0] Installing DWM hook...

[2015-08-26 14:53:17][0xA08:0x42C0] User: SYSTEM

[2015-08-26 14:53:17][0xA08:0x42C0] Module: C:\AeroGlass\DWMGlass.dll

[2015-08-26 14:53:17][0x2754:0x4A40] Machine ID: ...

[2015-08-26 14:53:17][0x2754:0x4A40] Checking key ... for ID ......

[2015-08-26 14:53:17][0x2754:0x4A40] Hook (USER32.dll!DrawTextW from udwm.dll) installed

[2015-08-26 14:53:17][0x2754:0x4A40] Hook (GDI32.dll!CreateBitmap from udwm.dll) installed

[2015-08-26 14:53:17][0x2754:0x4A40] Hook (GDI32.dll!CreateRoundRectRgn from udwm.dll) installed

[2015-08-26 14:53:17][0x2754:0x4A40] Aero Glass for Win8.1+ 1.4.0.200 x64 correctly loaded (C:\AeroGlass\DWMGlass.dll).

[2015-08-26 14:53:17][0x2754:0x5798] DBGHELP: Symbol Search Path: .;SRV*C:\AeroGlass\symbols*http://msdl.microsoft.com/download/symbols

[2015-08-26 14:53:17][0x2754:0x5798] Loading settings (flags = 0x1) from HKEY 0x0000000000000390 for session #2

[2015-08-26 14:53:17][0x2754:0x5798] dwmcore.dll version 6.3.9600.17795

[2015-08-26 14:53:17][0x2754:0x5798] udwm.dll version 6.3.9600.17415

[2015-08-26 14:53:30][0x2FA8:0x433C] Machine ID: ...

[2015-08-26 14:53:30][0x2FA8:0x433C] Checking key ... for ID ......

[2015-08-26 14:53:30][0x2FA8:0x433C] Hook (USER32.dll!DrawTextW from udwm.dll) installed

[2015-08-26 14:53:30][0x2FA8:0x433C] Hook (GDI32.dll!CreateBitmap from udwm.dll) installed

[2015-08-26 14:53:30][0x2FA8:0x433C] Hook (GDI32.dll!CreateRoundRectRgn from udwm.dll) installed

[2015-08-26 14:53:30][0x2FA8:0x433C] Aero Glass for Win8.1+ 1.4.0.200 x64 correctly loaded (C:\AeroGlass\DWMGlass.dll).

[2015-08-26 14:53:30][0x2FA8:0x2C1C] DBGHELP: Symbol Search Path: .;SRV*C:\AeroGlass\symbols*http://msdl.microsoft.com/download/symbols

[2015-08-26 14:53:30][0x2FA8:0x2C1C] Loading settings (flags = 0x1) from HKEY 0x0000000000000000 for session #3

[2015-08-26 14:53:30][0x2FA8:0x2C1C] dwmcore.dll version 6.3.9600.17795

[2015-08-26 14:53:30][0x2FA8:0x2C1C] udwm.dll version 6.3.9600.17415

[2015-08-26 15:09:52][0x570:0x574] Installing DWM hook...

[2015-08-26 15:09:53][0x570:0x574] User: SYSTEM

[2015-08-26 15:09:53][0x570:0x574] Module: C:\AeroGlass\DWMGlass.dll

[2015-08-26 15:09:53][0x208:0xE00] Machine ID: ...

[2015-08-26 15:09:53][0x208:0xE00] Checking key ... for ID ......

[2015-08-26 15:09:53][0x208:0xE00] Hook (USER32.dll!DrawTextW from udwm.dll) installed

[2015-08-26 15:09:53][0x208:0xE00] Hook (GDI32.dll!CreateBitmap from udwm.dll) installed

[2015-08-26 15:09:53][0x208:0xE00] Hook (GDI32.dll!CreateRoundRectRgn from udwm.dll) installed

[2015-08-26 15:09:53][0x208:0xE00] Aero Glass for Win8.1+ 1.4.0.200 x64 correctly loaded (C:\AeroGlass\DWMGlass.dll).

[2015-08-26 15:09:53][0x208:0xE08] DBGHELP: Symbol Search Path: .;SRV*C:\AeroGlass\symbols*http://msdl.microsoft.com/download/symbols

[2015-08-26 15:09:53][0x208:0xE08] Loading settings (flags = 0x1) from HKEY 0x0000000000000000 for session #1

[2015-08-26 15:09:53][0x208:0xE08] dwmcore.dll version 6.3.9600.17795

[2015-08-26 15:09:53][0x208:0xE08] udwm.dll version 6.3.9600.17415

 

-Noel

Edited by NoelC
Link to comment
Share on other sites

The old version of UxThemeSignatureBypass64 works well with AeroGlass 1.4  13cc734b6757aed5.JPG 

 

UxThemeSignatureBypass64.dll   http://nashdisk.ru/62807a/

 

My debug http://pastebin.com/37qb9iq5

 

And Aero 7 Theme  8d664abe35a4ec64.JPG 6e41b632b19d820c.JPG

 

I'll try this uxtheme64 and this aero theme (could you link me?) that seems to solve the problem in inactive windows text (barely readable gray).

 

*EDIT*

 

Firefox seems not have particular issues (excluding the known limitation of windows 10 said at first post)

What atlas/layout do you use? (I found a 7aero theme, but probably is "outdated")

In explorer.exe, white caption (how did you do?) isn't respected (other windows does).

Edited by Hadden
Link to comment
Share on other sites

i have 2 problems with firefox.. and i don't know if it depends on firefox or other.

20150826_15311275p5d.jpg20150826_153319rnq51.jpg

can you fix it?

 

ps. latest debug version of aero glass worked well on firefox (only for image 1)

 

sorry for my bad english

You must had recently updated firefox to v40 as I faced that same problem to when I updated firefox. As firefox had changed it UI to match Windows 10 looks. But if you install add-on "Classic Theme Restorer" it has a option to bring back it previous UI which will fix those buttons problem. As you see on my screenshot.

Screenshot%205_zpsevgulidx.png

Link to comment
Share on other sites

 

I've tested it in a Win 8.1 VM; it appears to work fine.  

 

 

Already saw a glitch with 1.4 when getting ready to log into my Win 8.1 workstation.  When the lock screen slides up, it ends up all broken up.  This was after logging off only.  I'm going to reboot the whole system just to be sure it's not a transient issue.

 

BrokenLogonScreen.jpg

 

Edit:  It does it after bootup as well.

 

The logon prompt background seems to jump in reducing stages of transparency as I type, as does the blue screen between logon and the actual desktop.  But all the problems seem to be limited to the logon process.  Everything on the desktop seems to be working okay.  I can live with this.

 

Note that I am using the March 8 UxThemeSignatureBypass DLLs.

 

debug.log:

 

[2015-08-26 14:53:17][0xA08:0x42C0] Installing DWM hook...

[2015-08-26 14:53:17][0xA08:0x42C0] User: SYSTEM

[2015-08-26 14:53:17][0xA08:0x42C0] Module: C:\AeroGlass\DWMGlass.dll

[2015-08-26 14:53:17][0x2754:0x4A40] Machine ID: ...

[2015-08-26 14:53:17][0x2754:0x4A40] Checking key ... for ID ......

[2015-08-26 14:53:17][0x2754:0x4A40] Hook (USER32.dll!DrawTextW from udwm.dll) installed

[2015-08-26 14:53:17][0x2754:0x4A40] Hook (GDI32.dll!CreateBitmap from udwm.dll) installed

[2015-08-26 14:53:17][0x2754:0x4A40] Hook (GDI32.dll!CreateRoundRectRgn from udwm.dll) installed

[2015-08-26 14:53:17][0x2754:0x4A40] Aero Glass for Win8.1+ 1.4.0.200 x64 correctly loaded (C:\AeroGlass\DWMGlass.dll).

[2015-08-26 14:53:17][0x2754:0x5798] DBGHELP: Symbol Search Path: .;SRV*C:\AeroGlass\symbols*http://msdl.microsoft.com/download/symbols

[2015-08-26 14:53:17][0x2754:0x5798] Loading settings (flags = 0x1) from HKEY 0x0000000000000390 for session #2

[2015-08-26 14:53:17][0x2754:0x5798] dwmcore.dll version 6.3.9600.17795

[2015-08-26 14:53:17][0x2754:0x5798] udwm.dll version 6.3.9600.17415

[2015-08-26 14:53:30][0x2FA8:0x433C] Machine ID: ...

[2015-08-26 14:53:30][0x2FA8:0x433C] Checking key ... for ID ......

[2015-08-26 14:53:30][0x2FA8:0x433C] Hook (USER32.dll!DrawTextW from udwm.dll) installed

[2015-08-26 14:53:30][0x2FA8:0x433C] Hook (GDI32.dll!CreateBitmap from udwm.dll) installed

[2015-08-26 14:53:30][0x2FA8:0x433C] Hook (GDI32.dll!CreateRoundRectRgn from udwm.dll) installed

[2015-08-26 14:53:30][0x2FA8:0x433C] Aero Glass for Win8.1+ 1.4.0.200 x64 correctly loaded (C:\AeroGlass\DWMGlass.dll).

[2015-08-26 14:53:30][0x2FA8:0x2C1C] DBGHELP: Symbol Search Path: .;SRV*C:\AeroGlass\symbols*http://msdl.microsoft.com/download/symbols

[2015-08-26 14:53:30][0x2FA8:0x2C1C] Loading settings (flags = 0x1) from HKEY 0x0000000000000000 for session #3

[2015-08-26 14:53:30][0x2FA8:0x2C1C] dwmcore.dll version 6.3.9600.17795

[2015-08-26 14:53:30][0x2FA8:0x2C1C] udwm.dll version 6.3.9600.17415

[2015-08-26 15:09:52][0x570:0x574] Installing DWM hook...

[2015-08-26 15:09:53][0x570:0x574] User: SYSTEM

[2015-08-26 15:09:53][0x570:0x574] Module: C:\AeroGlass\DWMGlass.dll

[2015-08-26 15:09:53][0x208:0xE00] Machine ID: ...

[2015-08-26 15:09:53][0x208:0xE00] Checking key ... for ID ......

[2015-08-26 15:09:53][0x208:0xE00] Hook (USER32.dll!DrawTextW from udwm.dll) installed

[2015-08-26 15:09:53][0x208:0xE00] Hook (GDI32.dll!CreateBitmap from udwm.dll) installed

[2015-08-26 15:09:53][0x208:0xE00] Hook (GDI32.dll!CreateRoundRectRgn from udwm.dll) installed

[2015-08-26 15:09:53][0x208:0xE00] Aero Glass for Win8.1+ 1.4.0.200 x64 correctly loaded (C:\AeroGlass\DWMGlass.dll).

[2015-08-26 15:09:53][0x208:0xE08] DBGHELP: Symbol Search Path: .;SRV*C:\AeroGlass\symbols*http://msdl.microsoft.com/download/symbols

[2015-08-26 15:09:53][0x208:0xE08] Loading settings (flags = 0x1) from HKEY 0x0000000000000000 for session #1

[2015-08-26 15:09:53][0x208:0xE08] dwmcore.dll version 6.3.9600.17795

[2015-08-26 15:09:53][0x208:0xE08] udwm.dll version 6.3.9600.17415

 

-Noel

 

 

I also have the same issue on my Windows 8.1 machine.

 

- Liang

Link to comment
Share on other sites

 

i have 2 problems with firefox.. and i don't know if it depends on firefox or other.

20150826_15311275p5d.jpg20150826_153319rnq51.jpg

can you fix it?

 

ps. latest debug version of aero glass worked well on firefox (only for image 1)

 

sorry for my bad english

You must had recently updated firefox to v40 as I faced that same problem to when I updated firefox. As firefox had changed it UI to match Windows 10 looks. But if you install add-on "Classic Theme Restorer" it has a option to bring back it previous UI which will fix those buttons problem. As you see on my screenshot.

Screenshot%205_zpsevgulidx.png

 

thank you!

the only problem now are these bugs of aero glass that you see in the screen

20150826_15311275p5d.jpg

  • Upvote 1
Link to comment
Share on other sites

 

I've tested it in a Win 8.1 VM; it appears to work fine.  

 

 

Already saw a glitch with 1.4 when getting ready to log into my Win 8.1 workstation.  When the lock screen slides up, it ends up all broken up.  This was after logging off only.  I'm going to reboot the whole system just to be sure it's not a transient issue.

 

BrokenLogonScreen.jpg

 

Edit:  It does it after bootup as well.

 

The logon prompt background seems to jump in reducing stages of transparency as I type, as does the blue screen between logon and the actual desktop.  But all the problems seem to be limited to the logon process.  Everything on the desktop seems to be working okay.  I can live with this.

 

Note that I am using the March 8 UxThemeSignatureBypass DLLs.

 

debug.log:

 

[2015-08-26 14:53:17][0xA08:0x42C0] Installing DWM hook...

[2015-08-26 14:53:17][0xA08:0x42C0] User: SYSTEM

[2015-08-26 14:53:17][0xA08:0x42C0] Module: C:\AeroGlass\DWMGlass.dll

[2015-08-26 14:53:17][0x2754:0x4A40] Machine ID: ...

[2015-08-26 14:53:17][0x2754:0x4A40] Checking key ... for ID ......

[2015-08-26 14:53:17][0x2754:0x4A40] Hook (USER32.dll!DrawTextW from udwm.dll) installed

[2015-08-26 14:53:17][0x2754:0x4A40] Hook (GDI32.dll!CreateBitmap from udwm.dll) installed

[2015-08-26 14:53:17][0x2754:0x4A40] Hook (GDI32.dll!CreateRoundRectRgn from udwm.dll) installed

[2015-08-26 14:53:17][0x2754:0x4A40] Aero Glass for Win8.1+ 1.4.0.200 x64 correctly loaded (C:\AeroGlass\DWMGlass.dll).

[2015-08-26 14:53:17][0x2754:0x5798] DBGHELP: Symbol Search Path: .;SRV*C:\AeroGlass\symbols*http://msdl.microsoft.com/download/symbols

[2015-08-26 14:53:17][0x2754:0x5798] Loading settings (flags = 0x1) from HKEY 0x0000000000000390 for session #2

[2015-08-26 14:53:17][0x2754:0x5798] dwmcore.dll version 6.3.9600.17795

[2015-08-26 14:53:17][0x2754:0x5798] udwm.dll version 6.3.9600.17415

[2015-08-26 14:53:30][0x2FA8:0x433C] Machine ID: ...

[2015-08-26 14:53:30][0x2FA8:0x433C] Checking key ... for ID ......

[2015-08-26 14:53:30][0x2FA8:0x433C] Hook (USER32.dll!DrawTextW from udwm.dll) installed

[2015-08-26 14:53:30][0x2FA8:0x433C] Hook (GDI32.dll!CreateBitmap from udwm.dll) installed

[2015-08-26 14:53:30][0x2FA8:0x433C] Hook (GDI32.dll!CreateRoundRectRgn from udwm.dll) installed

[2015-08-26 14:53:30][0x2FA8:0x433C] Aero Glass for Win8.1+ 1.4.0.200 x64 correctly loaded (C:\AeroGlass\DWMGlass.dll).

[2015-08-26 14:53:30][0x2FA8:0x2C1C] DBGHELP: Symbol Search Path: .;SRV*C:\AeroGlass\symbols*http://msdl.microsoft.com/download/symbols

[2015-08-26 14:53:30][0x2FA8:0x2C1C] Loading settings (flags = 0x1) from HKEY 0x0000000000000000 for session #3

[2015-08-26 14:53:30][0x2FA8:0x2C1C] dwmcore.dll version 6.3.9600.17795

[2015-08-26 14:53:30][0x2FA8:0x2C1C] udwm.dll version 6.3.9600.17415

[2015-08-26 15:09:52][0x570:0x574] Installing DWM hook...

[2015-08-26 15:09:53][0x570:0x574] User: SYSTEM

[2015-08-26 15:09:53][0x570:0x574] Module: C:\AeroGlass\DWMGlass.dll

[2015-08-26 15:09:53][0x208:0xE00] Machine ID: ...

[2015-08-26 15:09:53][0x208:0xE00] Checking key ... for ID ......

[2015-08-26 15:09:53][0x208:0xE00] Hook (USER32.dll!DrawTextW from udwm.dll) installed

[2015-08-26 15:09:53][0x208:0xE00] Hook (GDI32.dll!CreateBitmap from udwm.dll) installed

[2015-08-26 15:09:53][0x208:0xE00] Hook (GDI32.dll!CreateRoundRectRgn from udwm.dll) installed

[2015-08-26 15:09:53][0x208:0xE00] Aero Glass for Win8.1+ 1.4.0.200 x64 correctly loaded (C:\AeroGlass\DWMGlass.dll).

[2015-08-26 15:09:53][0x208:0xE08] DBGHELP: Symbol Search Path: .;SRV*C:\AeroGlass\symbols*http://msdl.microsoft.com/download/symbols

[2015-08-26 15:09:53][0x208:0xE08] Loading settings (flags = 0x1) from HKEY 0x0000000000000000 for session #1

[2015-08-26 15:09:53][0x208:0xE08] dwmcore.dll version 6.3.9600.17795

[2015-08-26 15:09:53][0x208:0xE08] udwm.dll version 6.3.9600.17415

 

-Noel

 

Same here with Win 8.1 + Aero Glass 1.4

Link to comment
Share on other sites

thank you!

the only problem now are these bugs of aero glass that you see in the screen

 

 

20150826_15311275p5d.jpg

I don't have that problem. I use firefox Beta 41 and I tried firefox Release 40 and still didn't get that problem. I'm using Windows 10 Build 10525

Link to comment
Share on other sites

 

thank you!

the only problem now are these bugs of aero glass that you see in the screen

 

 

20150826_15311275p5d.jpg

I don't have that problem. I use firefox Beta 41 and I tried firefox Release 40 and still didn't get that problem. I'm using Windows 10 Build 10525

 

the problem is in aero glass 1.4.. the latest debug version of aero glass worked very well! I'm waiting a new update

Link to comment
Share on other sites

I've tested it in a Win 8.1 VM; it appears to work fine.

Already saw a glitch with 1.4 when getting ready to log into my Win 8.1 workstation.  When the lock screen slides up, it ends up all broken up.  This was after logging off only.  I'm going to reboot the whole system just to be sure it's not a transient issue.

 

BrokenLogonScreen.jpg

 

Edit:  It does it after bootup as well.

 

The logon prompt background seems to jump in reducing stages of transparency as I type, as does the blue screen between logon and the actual desktop.  But all the problems seem to be limited to the logon process.  Everything on the desktop seems to be working okay.  I can live with this.

I don't see this problem on my machine. Everything looks correct - is it really related to Aero Glass itself?

EDIT: yes, I was able to reproduce it - it seems to appear in release only but not in debug build. weird :-/

Edited by bigmuscle
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...