Jump to content
MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. ×

safely remove hardware icon doesn't work windows 7


chris1946
 Share

Recommended Posts

Hi All,

 

I have a problem in windows 7 pro 64 bit. The icon for safely removing hardware doesn't work anymore. When I click on it nothing happens.

I tried the -  RunDll32.exe shell32.dll,Control_RunDLL hotplug.dll  - workaround but all I get from that is a message that the usb device is not removable.

 

Any ideas what could be the problem.

 

 

Chris

Link to comment
Share on other sites


The one in questin is a Seagate Black Armour external drive which I have been using for over a year with no problems. It is set as Fast Removal (Standard). 

I have had no problems in the past, and I can't pinpoint when the icon stopped working. It used to work with usb sticks etc. but not anymore. I have the feeling that 

a Windows update might have caused it, but I can't imagine which one.

Link to comment
Share on other sites

It could be a program you have installed is causing the problem. Take a look at any recently installed programs and see if there are any that might change how external drives are used. I did a little research and found (for example) that sometimes Acronis software can cause similar issues.

Link to comment
Share on other sites

  • 1 month later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...