Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Dave-H

Standby Mode in XP

Recommended Posts

I've been trying to get the standby mode working on my 32 bit XP SP3 installation.

At the moment it's greyed out.

Windows 8.1 x64 on the same system works fine, including hibernate mode, so I'm puzzled why it won't work on XP with exactly the same hardware.

 

I've done research on this of course, but so far have drawn a blank.

 

The system BIOS has ACPI modes S1 and S3 available, and you can select either or both.

I have both selected.

 

Device Manger reports the system as an ACPI Multiprocessor PC, which is correct.

 

All the hardware that has a Power Management tab in Device Manager has "allow the computer to turn off this device to save power" checked, and "Allow this device to bring the computer out of standby" un-checked.

 

The Power Options applet in Control Panel only has thee tabs, "Power Schemes", Advanced, and "UPS".

The Advanced tab has no options except to show or hide the taskbar icon or determine what the power button does.

My XP netbook where standby does work has many more options available.

 

Running powercfg /availablesleepstates gives this -

 

The following sleep states are not available on this system:
Standby (S1)
Standby (S2)
Standby (S3)
Hibernate

 

So basically, no power saving modes available at all!

 

I did play around with the dumppo.exe program, thinking that this might be able to force the modes on, but no joy.

 

Anyone any idea why this should be?

As I said, it all works fine on Windows 8.1 on the same hardware.

 

Drivers are said to be the usual culprit for this, but all my devices have the latest driver available for them, and none are older that 2008, when they surely would have been designed to support standby modes!

The drivers are of course all very different on Windows 8.1, not least because it's a 64 bit system.

Any suggestions welcome.

Cheers,

Dave.

:)

Edited by Dave-H

Share this post


Link to post
Share on other sites

Has no-one any suggestions on this at all?

Surely I'm not the only one who's come up against this problem?!

:unsure:

Share this post


Link to post
Share on other sites

The Power Options applet in Control Panel only has thee tabs, "Power Schemes", Advanced, and "UPS".

 

There should be at least one further tab, named "Hibernate"... :wacko:

 

Maybe a look at Kelly's Korner, in case you haven't already done so, can be of help... :unsure:

Share this post


Link to post
Share on other sites

Yep, something odd about that missing. (Something is amiss.)

 

FWIW, I rooted through Kelly's Corner (when up and through Archive) and if you see something that you can't seem to obtain, I may have it tucked away.

Share this post


Link to post
Share on other sites

Thanks guys!

Actually I do have the Intel chipset drivers installed.

They are the most recent I could find, version 9.4.0.1026, which is later than the link points to, which is 8.3.1.1009.

I did try installing the earlier version, but it made no difference.

 

I then decided to do something I've never actually done before, and uninstall all the system devices in Device Manager and let them re-install.

As the system is actually originally an upgrade from Windows 2000 I thought that maybe there were things hanging around from that.

Sadly after a lot of messing around reinstalling most of the hardware drivers after doing that, it's still exactly the same as before, no power saving modes!

:no:

Device Manager does say it's an ACPI system, with the "Microsoft ACPI-Compliant System" driver correctly installed, so this is all still a bit of a mystery.

The system BIOS only appears to support ACPI S1 and S3 sleep modes, and you can select either or both. I have both selected.

I believe that hibernate is S4 mode, so I wouldn't expect that to work necessarily (although it does on Windows 8.1) but standby is S3 I think, so that surely should be available and working.

:)

Share this post


Link to post
Share on other sites

Have you tried to activate hibernation from the command-line, in a DOS box?

If not, please do it, just in case... the command ought to be:

 

C:\>  powercfg  /hibernate  on

 

You can start with:

 

C:\>  powercfg  /query

 

then try to activate hibernation, then query again just to see if it worked... :unsure:

Share this post


Link to post
Share on other sites

Hi den!

:hello:

I already tried powercfg /hibernate on with no result.

powercfg /query gives this -

Name Ashfield CourtNumerical ID 8Turn off monitor (AC) After 120 minsTurn off monitor (DC) After 5 minsTurn off hard disks (AC) NeverTurn off hard disks (DC) After 10 minsSystem standby (AC) Not SupportedSystem standby (DC) Not SupportedSystem hibernates (AC) Not SupportedSystem hibernates (DC) Not SupportedProcessor Throttle (AC) Not SupportedProcessor Throttle (DC) Not Supported

I do also have a netbook with Windows XP on it which does support all these modes, so I'm going to do some comparisons of the relevant registry entries.

I can't believe that just transplanting the registry entries over will bring it to life on the first machine, but you never know!

:)

Edited by Dave-H

Share this post


Link to post
Share on other sites

Thanks, many of my references have said that the graphics driver is the number one suspect in this sort of problem.

I don't see why installing an earlier version would fix it though, surely a later version is more likely to support the power saving modes than an earlier one?

The situation is complicated for me as I have two physical graphics cards installed at the moment!

I should say at this point that my system has been through many configuration changes over the years, and the power saving modes have never worked with any hardware or software configuration in XP, either with the present motherboard or its predecessor, regardless of what graphics card was fitted.

:no:

Share this post


Link to post
Share on other sites

Thanks, many of my references have said that the graphics driver is the number one suspect in this sort of problem.

I don't see why installing an earlier version would fix it though, surely a later version is more likely to support the power saving modes than an earlier one?

I see. Then, as you say there is no later version (I'll have to believe you on that because I don't know the video card(s) nor the driver(s) version(s)), I suggest you do nothing and see if it fixes your problem.

Share this post


Link to post
Share on other sites

The details of the cards are in my signature.

The ATI X-850 is using Catalyst 10.2 on XP, the Nvidia 210 is using the GeForce 340.52 driver.

Both are the most recent 32 bit XP drivers for their respective cards.

I nearly always used ATI cards on my previous AGP motherboard, updating the drivers every time new ones came out.

As I said, the power saving options have never worked for me on XP, even then.

:)

Share this post


Link to post
Share on other sites

I checked the registry entries on the XP machine I have where the power saving modes do work, but couldn't find anything conclusive that was fundamentally different from the machine where they don't work.

Does anyone know exactly where the entries relevant to the power saving modes are stored?

:)

Share this post


Link to post
Share on other sites

Dave, since you admit that hibernation or standby in XP has never worked on this particular motherboard, regardless of which graphics card you have used with this motherboard, and you have used several over the years, and I believe you said that you have tried more than one driver with a few if not all of the graphics cards, I think that you might be asking the wrong question.  Instead of asking why standby does not work with XP, maybe you should ask why standby does work with Windows 8.1 x64.
 
As to XP, I'm guessing that something might be missing on this particular motherboard, either in the required hardware or in the BIOS, that XP needs in order to invoke standby, and nothing you try to copy over from a different XP system where standby works is going to change that.  So why/how does Windows 8.1 x64 get standby to work?  Since I don't use Windows 8.x, and I have no desire to, I have no idea of the answer to that question or how to find it.  But someone else might.
 
If you still want to pursue the question from the XP angle, then I have to agree with Ponch that you have nothing to lose by trying older drivers for your graphics boards.  I know you "don't see why installing an earlier version would fix it though", but then are you saying that everything computer related makes sense? :) This wouldn't be the first time that older versions of a driver or app worked better than later ones for a particular situation.

 

Have you found any comments on the web from other users of this motherboard that have complained that they couldn't get standby to work?  Surely others would have mentioned that at some time unless the manufacturer specified from the beginning that feature was not available on that motherboard.

 

Seriously, if you want to truly verify that standby just will not work in XP with this motherboard, I think you'll need to strip your system down to it's very basics, such as minimal number of drives, only one graphics card, minimal number of extra hardware, ie remove cameras, printers, etc, and do a very basic XP install and see if standby will work.  I would even try older drivers for both the motherboard and graphics card that date back to when the boards first came out, assuming that both the motherboard and graphics cards were originally rated for use with each other and with XP.  With a simplified install setup, if you try drivers from the original ones up to the latest you can find and nothing works to enable XP to use standby, then you might have to resign yourself to knowing that it just won't work.  But at least then you can know that you tried everything you could.

 

If you can get it to work, then you can start adding things back until it quits working.  Then you just have to figure out what is causing the incompatibility and go from there.

 

I realize that the simplified XP system is a far cry from the system you want to use, but surely you agree that your system, multiple graphics cards from different manufacturers, multi-boot 98SE, XP and Win 8.1, etc., can make troubleshooting problematic, to say the least.

 

Just my two cents.

 

Cheers and Regards

 

Edit: Added 98SE to the list of your multi-boot OS

Edited by bphlpt

Share this post


Link to post
Share on other sites

Wise words, bphlpt! :thumbup

I fully agree with your advice.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×