Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Recommended Posts

Ok, I got NoelC's png working and the GUI für Aero Win8 is working fine on my side.

I also injected the ModernFrame.dll and it is also working fine.

 

However it seems that the new Edge browser is playing it's own game. When I open it I see the Aero Frame appearing just like for any other App, but once loaded Edge is extending itself over the border, hiding the Aero design and also lacking the icons like close now:

Edge.png

Share this post


Link to post
Share on other sites

Works fine if you have the Atlas Layout file with the Theme Atlas image.

 

attachicon.gif2015-07-30_010944.png

Did you use the Aero glass gui to get this working? Also how did you explorer/other windows to be black?

Share this post


Link to post
Share on other sites

Ok, I got NoelC's png working and the GUI für Aero Win8 is working fine on my side.

 

Just for the record, that's not the theme atlas file I published you're showing.  That looks like Big Muscle's file.  But good on you for getting a combo working.

 

I know many people crave Aero Glass very much, but it seems to me that most folks should wait until Big Muscle publishes a final version.  The current version is clearly described as being for testing only.

 

-Noel

Edited by NoelC

Share this post


Link to post
Share on other sites

Just for the record, that's not the theme atlas file I published you're showing.  That looks like Big Muscle's file.  But good on you for getting a combo working.

 

I know many people crave Aero Glass very much, but it seems to me that most folks should wait until Big Muscle publishes a final version.  The current version is clearly described as being for testing only.

 

-Noel

 

 

My bad, I was sure I had it ... but of course you're right, I messed it when testing around - now I have it ;)

 

And yes, I know it's for testing, that's why I report that Edge is not behaving well with ModernFrame.dll - that's what testing is about, or? :)

Share this post


Link to post
Share on other sites

Glad you got it.

 

I wasn't speaking to you, specifically.  Mostly I think people are expecting a final version, because of their incredible desire for Aero Glass, and Big Muscle's product is just not quite there yet.

 

-Noel

Share this post


Link to post
Share on other sites

And yes, I know it's for testing, that's why I report that Edge is not behaving well with ModernFrame.dll - that's what testing is about, or? :)

I didn't know that I distributed ModernFrame.dll with AeroGlass for build 10240. So probably my mistake...

  • Upvote 1

Share this post


Link to post
Share on other sites

Glad you got it.

 

I wasn't speaking to you, specifically.  Mostly I think people are expecting a final version, because of their incredible desire for Aero Glass, and Big Muscle's product is just not quite there yet.

 

-Noel

Well, if you know what you are doing, this debug version is beautiful for the most part!  I am very happy to see it working, and even though the ModernFrame.dll is for a previous version of Windows 10, it does add some color, and works to a certain extent.

  • Upvote 2

Share this post


Link to post
Share on other sites

Seems to work better for me if I don't use any custom theme atlases.

 

The only graphical glitch I've seen right now is that sometimes when you close dwm.exe it causes the start menu tile grid to look a bit weird if you hover over them.

To fix that I log out and in again.

Edited by shelter

Share this post


Link to post
Share on other sites

Had a weird issue just now, was RDPed in from work and everything was great, I just got home and logged into the machine and everything was corrupt on screen and DWM elements were not displaying correctly, a simple reset of dwm.exe fixed it but here's my debug.log if it helps track down the cause of the issue.

debug.txt

Share this post


Link to post
Share on other sites

rp

Qjg8cmo.png

 

http://i.imgur.com/sEOU0wo.png

 

Window Metrics (Win 8.1)

Windows Registry Editor Version 5.00[HKEY_CURRENT_USER\Control Panel\Desktop\WindowMetrics]"SmCaptionWidth"="-330""BorderWidth"="-15""SmCaptionHeight"="-330""CaptionWidth"="-330""IconTitleWrap"="1""ScrollHeight"="-255""CaptionHeight"="-330""CaptionFont"=hex:f1,ff,ff,ff,00,00,00,00,00,00,00,00,00,00,00,00,90,01,00,00,\  00,00,00,01,00,00,05,00,53,00,65,00,67,00,6f,00,65,00,20,00,55,00,49,00,00,\  00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\  00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00"ScrollWidth"="-255""MenuWidth"="-285""SmCaptionFont"=hex:f1,ff,ff,ff,00,00,00,00,00,00,00,00,00,00,00,00,90,01,00,\  00,00,00,00,01,00,00,05,00,53,00,65,00,67,00,6f,00,65,00,20,00,55,00,49,00,\  00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\  00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00"MenuFont"=hex:f4,ff,ff,ff,00,00,00,00,00,00,00,00,00,00,00,00,90,01,00,00,00,\  00,00,01,00,00,05,00,53,00,65,00,67,00,6f,00,65,00,20,00,55,00,49,00,00,00,\  00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\  00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00"StatusFont"=hex:f4,ff,ff,ff,00,00,00,00,00,00,00,00,00,00,00,00,90,01,00,00,\  00,00,00,01,00,00,05,00,53,00,65,00,67,00,6f,00,65,00,20,00,55,00,49,00,00,\  00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\  00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00"MenuHeight"="-285""MessageFont"=hex:f4,ff,ff,ff,00,00,00,00,00,00,00,00,00,00,00,00,90,01,00,00,\  00,00,00,01,00,00,05,00,53,00,65,00,67,00,6f,00,65,00,20,00,55,00,49,00,00,\  00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\  00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00"IconFont"=hex:f4,ff,ff,ff,00,00,00,00,00,00,00,00,00,00,00,00,90,01,00,00,00,\  00,00,01,00,00,05,00,53,00,65,00,67,00,6f,00,65,00,20,00,55,00,49,00,00,00,\  00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\  00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00"Shell Icon Size"="32""PaddedBorderWidth"="-20""AppliedDPI"=dword:00000060"IconSpacing"="-1125""IconVerticalSpacing"="-1125""MinAnimate"="1" 

Like this atlas, thx!

Share this post


Link to post
Share on other sites

here a blue atlas for 10240.

 

Very nice indeed, an alternative version could be that the window close button is slightly red instead of blue and highlights to even more red when hovering over it.

 

* Oh, just after I commented I noticed the post above. It's kind of what I suggested.

Edited by shelter

Share this post


Link to post
Share on other sites

Hey Big Muscle, are you thinking of bringing back support for FrameMargin settings?  Just curious.

 

-Noel

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×