Jump to content

K-Lite Unattended Install through WPI


 Share

Recommended Posts

Hello.  I just recently created an unattended installation for the K-Lite Codec Pack and added it into WPI.  We had previously just been running the standard EXE with no problems.

 

The unattended installation uses a BAT file and INI file where the BAT file can be run silently.  I pathed WPI to the newly created BAT file but when running this, I receive a message from the installer that "The following applications are currently using files that need to be updated by this installer: Microsoft HTML Application host (MSHTA.exe)".

 

So basically, it wants WPI to be closed in order to run the installation.  The BAT file runs fine by itself.  Here is the contents of the bat file that is being run:

 

@echo Installing: K-Lite Codec Pack
@"Q:\WinImage\Software\K-Lite Codec Pack\K-Lite_Codec_Pack_1065_Full.exe" /verysilent /norestart /LoadInf=".\klcp_full_unattended.ini"
@echo Done!

 

Any suggestions on how to add this into WPI to get around this message?

 

Thanks.

Link to comment
Share on other sites


For a very long time I have been running klite from within a winrar sfx package.

 

I use the following in it:

 

;The comment below contains SFX script commandsSetup=klcp_full_unattended.batTempModeSilent=1Overwrite=2Update=U
 
I haven't re-visited other options as this has worked for me for at least eight years.
 
You could try running this in the commandline:
 
{START} %wpipath%\Install\klcp_full_unattended.bat
Link to comment
Share on other sites

 

For a very long time I have been running klite from within a winrar sfx package.

 

I use the following in it:

 

;The comment below contains SFX script commandsSetup=klcp_full_unattended.batTempModeSilent=1Overwrite=2Update=U
 
I haven't re-visited other options as this has worked for me for at least eight years.
 
You could try running this in the commandline:
 
{START} %wpipath%\Install\klcp_full_unattended.bat

 

 

Thanks for the reply.  I plugged in the command but it only brings up a command prompt pathed out to where I ran WPI from and does not run the bat file.

Link to comment
Share on other sites

  • 1 month later...

Did that work for you?
I had some trouble with it several years ago. If you don't specify a path to an exe inside a batch file, it will attempt to run the exe in the folder that the batch was run from. The issue I kept running into was the batch files I was trying to execute with WPI weren't located properly. (I'm sure that's user error on my part).

 

What Kels is saying is the same thing I've been doing. Just to give a little more detail to his answer:

Use winRAR to make an sfx (self-extracting) archive that contains the klite installer, the answer file (which you generate by following the instructions here: www.codecguide.com/silentinstall.htm) and the klite batch file.

What I do is have the sfx extract everything to "C:\Temp", then automatically execute the batch file from that location.

Link to comment
Share on other sites

  • 3 weeks later...

This is how I install it:

"%wpipath%\Install\Multimedia\Codec Packs\K-Lite Codec Pack v10.6.0 Full.exe" /verysilent /norestart /LoadInf="%wpipath%\Install\Multimedia\Codec Packs\K-Lite Codec Pack v10.6.0 Full - Unattended Settings.ini"

As you can see I just put the full path for the INI file. No need for an SFX archive.

Edited by Francesco
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...