Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


NoUserName

D-Link DGE-528T Gigabit Ethernet Adapter only reads 100 mb & not 1

Recommended Posts

Hi,

I've a D-Link DGE-528T Gigabit Ethernet Adapter PCI.

Connected to Dell OptiPlex GX620.

Built-in NIC is disabled from bios setup for the machine.

Running on Windows 8.1 Pro WMC 32x with 3 GB Ram.

I am using CAT.6 cable connected to a D-Link Gigabit Switch.

There are another 4 identical machine in the local network and all are reading 1 Gbps except this one.

Cables are all the same for all machines and same copy of windows with exact image using arconis true image.

I've tried all trouble shooting using google but no way out.

I updated 

These are the settings from device manager for this device:

DL23Hcvl.jpg

VSz6xPLl.jpg

Gc1mWdzl.jpg

fXoPtOyl.jpg

7RFWsaIl.jpg

YXfYGGxl.jpg

ruPexzvl.jpg

zAQsz2hl.jpg

AkxiB7El.jpg

p1nfi0xl.jpg

CMifevtl.jpg

beJhxL7l.jpg

dxKDJTzl.jpg

wI1fDmKl.jpg

3QErSicl.jpg

 

 

 

So please help as this is very urgent for business purposes especially that vendor says it is working and nothing wrong with it.

Thanks a lot.

Edited by NoUserName

Share this post


Link to post
Share on other sites

Guest

A loose connection can cause intermittent negotiation issues. Is it safe to assume you've tried swapping cables around to be certain that the issue is not a bad cable? 100 Mbit uses only two Ethernet pairs compared to the four pairs needed for gigabit to work.

Share this post


Link to post
Share on other sites

A loose connection can cause intermittent negotiation issues. Is it safe to assume you've tried swapping cables around to be certain that the issue is not a bad cable? 100 Mbit uses only two Ethernet pairs compared to the four pairs needed for gigabit to work.

Yes I swapped cables. but still the same :(

Share this post


Link to post
Share on other sites

To try to fix your problem:

Set "Auto Disable Gigabit" to Disabled on all machines.

 

Auto Disable Gigabit: running on gigabit speed consumes more power. This option automatically disables it when there is no need for faster connection.

Auto Disable Gigabit(PowerSaving)

To achieve power saving mode, the driver can auto disable the Gigabit when the cable is re–linked. Options Description

Disable Disable the capability of Auto Disable Gigabit. (default)

Re-Link, Battery When use battery, auto disable gigabit when re-link.

Re-Link, Battery or AC Auto disable gigabit when re-link.

Set "Speed and Duplex" to Auto on the problematic machine, then on other machines. I've seen both cases, when "Auto" prevents reaching full speed, or when full speed can be reached only on "Auto".

After changing one setting, reboot (all machines + the switch + router, if any) and test.

For general speed/optimization:

Maximize with the arrow up both "Receive buffers" an "Transmit buffers". I haven't seen a machine in the last 20 years that had a problem with this, and the driver usually still sets the maximum conservatively.

If not using Wake On Lan, disable "Shutdown Wake-On-Lan" "Wake on Magic Packet" and "Wake on pattern match"; set "WoL & Shutdown Link Speed" to "Not Speed Down".

If nothing works and still desperate, try disabling various Offload options. I had one case when one of them caused similar symptoms (the NIC not able to reach full speed).

GL

Edited by GrofLuigi

Share this post


Link to post
Share on other sites

What is the model of the switch?

Are there no other devices on the switch besides the 5 computers?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...