Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


aymon102

an autounattend.xml file work for win 7 & 8.1

Recommended Posts


The answer files I use for Windows 7 and 8 are the same except the product key is different. So if you just didn't have the ProductKey object, the file would work with both.

Share this post


Link to post
Share on other sites

Here is a Working .xml I use for my Windows 7 Pro x86 Installs, just revise the language, time zone etc as needed..DP :whistle:

<!-- UA Answer file for Windows(R) 7 Edition X86 --><!-- NOTE: Stops at format/partition screen then completes install to desktop when done! --><!-- Setup= GEEKS Computers, Windows Professional, en-US and Eastern Standard Time --><!-- This answer file generated by: GEEKS Computer SERVICES - 01.20.14 --><?xml version="1.0" encoding="utf-8"?><unattend xmlns="urn:schemas-microsoft-com:unattend"><!-- Specifies Language with code -->  <settings pass="windowsPE">    <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">      <SetupUILanguage>        <UILanguage>en-US</UILanguage>         </SetupUILanguage>         <InputLocale>0409:00000409</InputLocale>            <SystemLocale>en-US</SystemLocale>            <UILanguage>en-US</UILanguage>            <UserLocale>en-US</UserLocale>    </component><!-- Specifies OS and TRIAL KEY To Install (From the Sources Product.ini file provided by Microsoft) --><!-- Windows 7 ULTIMATE – D4F6K-QK3RD-TMVMJ-BBMRX-3MBMV--><!-- Windows 7 PROFESSIONAL – HYF8J-CVRMY-CM74G-RPHKF-PW487--><!-- Windows 7 HOME PREMIUM – RHPQ2-RMFJH-74XYM-BH4JX-XM76F--><!-- Windows 7 HOME BASIC – YGFVB-QTFXQ-3H233-PTWTJ-YRYRV--><!-- Windows 7 STARTER – 7Q28W-FT9PC-CMMYT-WHMY2-89M6G-->    <component name="Microsoft-Windows-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">      <ImageInstall>        <OSImage>          <InstallFrom>            <MetaData wcm:action="add">              <Key>/IMAGE/NAME</Key>              <value>Windows 7 PROFESSIONAL</value>            </MetaData>          </InstallFrom>          <InstallToAvailablePartition>false</InstallToAvailablePartition>          <WillShowUI>OnError</WillShowUI>        </OSImage>      </ImageInstall> <!--Skips Product Key Screen and inserts specified global Install Key (Only for ua install and cannot be activated! )--> <!--Default Keys for UA Deployment - http://pastebin.com/4r196eNh-->        <UserData>        <ProductKey>          <Key>HYF8J-CVRMY-CM74G-RPHKF-PW487</Key>          <WillShowUI>OnError</WillShowUI>        </ProductKey>        <Organization>Microsoft</Organization>        <FullName>OEM-PC</FullName>        <AcceptEula>true</AcceptEula>      </UserData>    </component>  </settings><!-- Disables UA Notificiation when programs try to install software or make changes to the computer. "false" -->  <settings pass="offlineServicing">    <component name="Microsoft-Windows-LUA-Settings" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">        <EnableLUA>false</EnableLUA>        </component>  </settings><!-- Specifies that Plug and Play devices are not uninstalled. "True" -->   <settings pass="generalize">    <component name="Microsoft-Windows-PnpSysprep" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">        <PersistAllDeviceInstalls>true</PersistAllDeviceInstalls>        </component>  </settings><!-- Specifies Computer Name and Device Manager name as "Work-PC" -->  <settings pass="specialize">    <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">      <ComputerName>Home-PC</ComputerName>    </component>    <component name="Microsoft-Windows-Security-Licensing-SLC-UX" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">      <SkipAutoActivation>true</SkipAutoActivation>    </component><!-- IE Component Settings Over Ride any .reg or .cmd settings! -->     <component name="Microsoft-Windows-IE-InternetExplorer" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">             <DisableOOBAccelerators>true</DisableOOBAccelerators>             <DisableFirstRunWizard>true</DisableFirstRunWizard>             <EnableLinksBar>false</EnableLinksBar>             <FilterLevel>High</FilterLevel>             <Home_Page>http://www.Bing.com/</Home_Page>             <BlockPopups>yes</BlockPopups>             <SuggestedSitesEnabled>false</SuggestedSitesEnabled>             <PlaySound>false</PlaySound>             <ShowInformationBar>true</ShowInformationBar>             <ShowMenuBar>true</ShowMenuBar>       </component>   </settings><!-- Creates Local User Account Name as "Administrator" -->  <settings pass="oobeSystem">    <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">      <UserAccounts>        <LocalAccounts />        <AdministratorPassword>          <Value />        </AdministratorPassword>      </UserAccounts>      <AutoLogon>        <Password>          <Value />        </Password>        <Enabled>true</Enabled>        <LogonCount>999</LogonCount>        <Username>Administrator</Username>      </AutoLogon>      <Display>          <ColorDepth>32</ColorDepth>          <DPI>96</DPI>          <HorizontalResolution>1366</HorizontalResolution>          <RefreshRate>70</RefreshRate>          <VerticalResolution>768</VerticalResolution>      </Display>      <Themes>         <ThemeName>OEM</ThemeName>         <DesktopBackground>%WINDIR%\Web\Wallpaper\CA-wp3.jpg</DesktopBackground>         <DefaultThemesOff>false</DefaultThemesOff>      </Themes><!-- Specifies the System Properties Information -->       <OEMInformation>          <Logo>%WINDIR%\System32\OEM\CorpLogo.bmp</Logo>          <Manufacturer>Geeks Computer Services</Manufacturer>          <Model>Microsoft Windows® Inc.</Model>          <SupportHours>24/7</SupportHours>          <SupportPhone>1-800-Microsoft (642-7676)</SupportPhone>          <SupportURL>http://support.microsoft.com/contactus/#/</SupportURL>      </OEMInformation>            <OOBE>      <!--1 Specifies that important and recommended updates are installed automatically.-->      <!--2 Specifies that only important updates are installed.-->      <!--3 Specifies that automatic protection is disabled. Updates are available manually through Windows Update.-->         <NetworkLocation>Work</NetworkLocation>        <HideEULAPage>true</HideEULAPage>        <ProtectYourPC>3</ProtectYourPC>        <HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE><!-- Rem out SkipMachine and SkipUser to Prompt for User Name -->        <SkipMachineOOBE>true</SkipMachineOOBE>        <SkipUserOOBE>true</SkipUserOOBE>      </OOBE><!-- Specifies Time Zone and Visual Effects -->      <DisableAutoDaylightTimeSet>true</DisableAutoDaylightTimeSet>      <TimeZone>Eastern Standard Time</TimeZone>      <VisualEffects>              <FontSmoothing>ClearType</FontSmoothing>      </VisualEffects><!--Specifies First Log-On Commands after Windows Setup-->      <FirstLogonCommands>                                <!-- RUN SCRIPT before first logon - wpi.cmd -->                <SynchronousCommand wcm:action="add">                <Description>RUNASADMIN Privileges For WPI.cmd</Description>                     <Order>1</Order>                                  <CommandLine>cmd /c reg.exe add "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers" /v "%WINDIR%\Setup\Scripts\wpi.cmd" /t REG_SZ /d RUNASADMIN /f</CommandLine>                </SynchronousCommand>                 <SynchronousCommand wcm:action="add">                <Description>WINDOWS POST INSTALLER</Description>                    <Order>2</Order>                    <CommandLine>cmd /c %Windir%\setup\scripts\wpi.cmd</CommandLine>                </SynchronousCommand>                                <SynchronousCommand wcm:action="add">                 <Description>DISABLE UAC</Description>                     <Order>3</Order>                     <CommandLine>cmd /c reg.exe add "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System" /v EnableLUA /t REG_DWORD /d 0 /f</CommandLine>                </SynchronousCommand>                 <!-- <SynchronousCommand wcm:action="add">  -->                    <!-- <Description>CLEANUP</Description> -->                    <!-- <Order>4</Order> -->                <!-- <CommandLine>cmd /c %Windir%\cleanup.cmd</CommandLine> -->                <!-- </SynchronousCommand> -->                 <!-- <SynchronousCommand wcm:action="add"> -->                  <!-- <Description>REBOOT SYSTEM</Description> -->                     <!-- <Order>5</Order> -->                     <!-- <CommandLine>cmd /c %Windir%\system32\shutdown.exe /r /f /t 0</CommandLine> -->                 <!-- </SynchronousCommand> -->                                       </FirstLogonCommands>    </component>  </settings>  </unattend>

Share this post


Link to post
Share on other sites

thanks for replaying

is There is a way to add two product keys one for each windows

or make windows ignore this?

Share this post


Link to post
Share on other sites

NO YOU CANNOT PUT TWO KEYS IN ONE XML. THIS HAS BEEN DISCUSSED HERE BEFORE RECENTLY. USE THE SEARCH FUNCTION AT THE TOP OF THIS PAGE.

HERE IS THE TOPIC FOR LAZY PEOPLE THAT WANT GIFTS INSTEAD OF WORKING FOR IT -

http://www.msfn.org/board/topic/170809-multiple-windows-7-versions-on-same-iso-unattended-product-key/

AND QUIT YELLING. WE HEAR YOU JUST FINE, DAMMIT!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...