Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


ChrisR

WIn8.1SE

Recommended Posts

After booting with Win8.1SE and then using GetWaikTools.exe is giving Checksum missmatch error.

The Tools are not available in that case.

It would be nice if this problem can be solved, since GetWaikTools is such a handy Tool :)

post-132150-0-46173700-1398757226_thumb.

Share this post


Link to post
Share on other sites

Hi wimb,

that's properly a missing ADVPACK.DLL in system32 (or syswow64 on x64 PE).

I'll drop this dependency in some future version.

Share this post


Link to post
Share on other sites
Thanks, indeed ADVPACK.DLL is missing in syswow64 on x64 PE. By adding ADVPACK.DLL, GetWaikTools works well :)

It is in system32 for 32-bit build.


If you drop this dependency, what do you think to change also Win8.1 ADK by ADK for Windows 8.1 Update

Share this post


Link to post
Share on other sites

Hmm, if anyone can give me a valid reason for ADK update than yes.

But as far I can see it, all changes of the Update are only for the WimBoot feature.

And cause Wimboot features depend on WOF driver, one needs a Windows 8.1 updated OS,

that already has all these tools

Share this post


Link to post
Share on other sites

Hi JFX and Chris,

advpack.dll is indeed missing in SysWOW64 of Win8.1SE

I can confirm that adding the file + mui solved the issue.

:)

  • Upvote 1

Share this post


Link to post
Share on other sites
Thanks to enlighten me on ADK 8.1 update. I asked without knowing what changes are made or the most that it could bring ;)

This is OK like that :)


Share this post


Link to post
Share on other sites
Disable Display off 10min
RegHiveLoad,Tmp_System,%RegSystem%RegWrite,HKLM,0x4,Tmp_System\ControlSet001\Control\Power\User\PowerSchemes\381b4222-f694-41f0-9685-ff5bb260df2e\7516b95f-f776-4464-8c53-06167f40cc99\3c0bc021-c8a8-4e07-a973-6b14cbcb2b7e,ACSettingIndex,0RegHiveUnLoad,Tmp_System

Thanks :) it is better than "powercfg.exe /change /monitor-timeout-ac 0" in autorun.cmd

In addition, to not to turn off the hard drive when Plugged in:

RegWrite,HKLM,0x4,Tmp_System\ControlSet001\Control\Power\User\PowerSchemes\381b4222-f694-41f0-9685-ff5bb260df2e\0012ee47-9041-4b5d-9b77-535fba8b1442\6738e2c4-e8a5-4a42-b16a-e040e769756e,ACSettingIndex,0

For both keys, there is also DCSettingIndex to change the timeout on battery, if needed.

I made a new plugin "Power options", to choose the timeout for monitor and hard disk when Plugged in or on Battery.

Share this post


Link to post
Share on other sites

For me it builds with no errors but there are tons of dead shortcuts on the start menu. Did I do something wrong? Most of the links aren't a problem but I am trying to get the Hirem's boot cd stuff to work. For me that's make or break on whether I can use this. The shortcuts for Hirem's don't work.

Share this post


Link to post
Share on other sites
I do not want to talk more about Hi ren's. 

It has many free application but also some illegals like mini XP which is moreover deleted when processing the plugin.

The plugin is here as is, without the ISO and files and nothing more, I'm sure you understand ;) .

 

Otherwise for shortcuts, you mean those of HBCD or others startmenu shortcuts also.

The shortcuts are created at startup and the target is checked before creating, as far as I know ! unless you are using makeshorctus plugin.

Can you give me some examples with the target of the shortcut and location of the actual file ?

For untouched HBCD plugin you should have the shorcut target with Y:\HBCD\HBCDMenu.exe and the exe present in Y:\HBCD folder.

:)

Share this post


Link to post
Share on other sites

I am not getting a y drive at all. Could it be that I am using the 8.1 update iso instead of rtm iso? I have tried this with and without the make shortcuts . If I don't use make shortcuts I seen no trace of the hirem apps at all.

Share this post


Link to post
Share on other sites

So it is related to your Win8.1se CD or rather USB3, I guess, which is not recognized at startup and so not (re)mounted on the Y: drive.

Once started, do you see your CD/USB media with the tag file Cdusb.Y at root. How is it in device manager, try also Renew USB3 in StartMenu\Computer Management\Drivers
I guess you also have a Warning Icon on the desktop, it is a shortcuts to MountPEmedia.log .

Can you try by replacing 1-files.script in the build folder and to rebuild, if it brings something.

1-files.7z

Share this post


Link to post
Share on other sites
Project Updated: Win8.1SE_2014-05-19

 


Main Features:

PXE Support: New. Mapping Drive Y from Network instead of CD-ROM/USB. Thanks 2aCD

PowerShell: New. command-line shell and associated scripting language built on .NET Framework. based on 2aCD' Win7PE plugin. 

Remote Desktop Connection: New. Remote Desktop Connection (RDC) 8.0

Power Options: New. Turn off display, Turn off hard disk (minutes On battery and Plugged in.

1 - Copy Files: choose the user logo. drvmain.sdb driver compatibility file added to fixed some USB3 issue.

2 - Shell & Config: Add a3x association, Pintool 1.2.4: Pin to Classic Shell 3.5.1 and 4, thanks neon2m. ProductOptions changed for x64 build to disable activate windows watermark after 3 hours.

IE Proxy Settings: Define Internet explorer Proxy for Win8.1SE

Classic Shell: updated to version4.1.0. Thanks fuwi

Imdisk: updated version 1.8.0

Opera v12: Updated version 12.17

WinNTSetup3: Updated version 3.5.1

WinContig: updated version 1.20b

Copy to USB-Device BCD BootMGR: Set BCD timeout & description in efi BCD

Rufus: updated version 1.4.7.455

Adjustments, improvements here and there.

 

 


Important: Always Check Win8.1SE topic post 1 to get latest updates and informations.

 

:)
Edited by ChrisR

Share this post


Link to post
Share on other sites

 

Project Updated: Win8.1SE_2014-05-19
 

Main Features:
PXE Support: New. Mapping Drive Y from Network instead of CD-ROM/USB. Thanks 2aCD
PowerShell: New. command-line shell and associated scripting language built on .NET Framework. based on 2aCD' Win7PE plugin. 
Remote Desktop Connection: New. Remote Desktop Connection (RDC) 8.0
Power Options: New. Turn off display, Turn off hard disk (minutes On battery and Plugged in.
1 - Copy Files: choose the user logo. drvmain.sdb driver compatibility file added to fixed some USB3 issue.
2 - Shell & Config: Add a3x association, Pintool 1.2.4: Pin to Classic Shell 3.5.1 and 4, thanks neon2m. ProductOptions changed for x64 build to disable activate windows watermark after 3 hours.
IE Proxy Settings: Define Internet explorer Proxy for Win8.1SE
Classic Shell: updated to version4.1.0. Thanks fuwi
Imdisk: updated version 1.8.0
Opera v12: Updated version 12.17
WinNTSetup3: Updated version 3.5.1
WinContig: updated version 1.20b
Copy to USB-Device BCD BootMGR: Set BCD timeout & description in efi BCD
Rufus: updated version 1.4.7.455
Adjustments, improvements here and there.
 
 
Important: Always Check Win8.1SE topic post 1 to get latest updates and informations.
 
:)

 

Tried that still get missing shortcuts. I am trying to figure out how to upload screenshots to this forum to show you what I am getting.

Share this post


Link to post
Share on other sites

I think i might have figured out whats happening. Instead of it auto assigning the USB or ISO or DVD to the Y: drive its getting assigned as D: drive or some other letter. If I go and run Hirens from the d: drive that works if I manually go there. So is there a setting I need to change to ensure it uses the proper drive letter?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×