Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Kelsenellenelvian

WPI v8.7.2 Release Thread

Recommended Posts

If this works correctly:

   var timerID=null;   timerID=setTimeout("ins_iTimer()",1000);  // Update display
I think that could be replaced by:

   var timerID=setTimeout("ins_iTimer()",1000);  // Update display
Cheers and Regards

The first one isn't good, because mshta works excessively and may block the system!

The second code is perfect.

Thanks and regards

Share this post


Link to post
Share on other sites

I dont know if anyone else got this but I just downloaded and copied over my configs and I get the following errors:

Line: 26

character: 1

Error: 'bit64' is undefined

code: 0

url: file:///C:/WPI_v8.7.2/UserFiles/config.js

and

Line: 631

character: 7

Error: unable to get property 'toString' of undefinded or null reference

code: 0

url: file:///C:/WPI_v8.7.2/WPIScripts/check.js

I launch a clean copy and i dont see anything about 64bit processing under options wizard in tools area?

I am doing something wrong?

Thank you for all the hard work on this app. I just donated also.

I think it is solved here:

http://www.msfn.org/board/topic/158272-languages-themes-manuals-mods/?p=1068519

and below tis post.

You can try it and download files: configwizard.js and updatewizard.js.

Tested and works fine.

Regards

*Edit: it's also needed to update the language file!!

Edited by myselfidem

Share this post


Link to post
Share on other sites

Hi Guys! I updated WPI to new version but now WPI is not showing any program in the main window, i tested it on 5 computers running Windows 7, but on Windows XP and it showed all programs.

Can anyone help me?

Thanks in advance!

post-378795-0-60504900-1394742468_thumb.

post-378795-0-27426100-1394742485_thumb.

Share this post


Link to post
Share on other sites

Could you share your config.js file to make a test?

Thank you

*Edit: Strange...But no files downloaded from Mediafire at this time!

Edited by myselfidem

Share this post


Link to post
Share on other sites

Thanks!

Tested and works fine using the new files given as download...Try it, please.

Regards

Edited by myselfidem

Share this post


Link to post
Share on other sites

Hi! With a clean install and your files, copying my config.js it works! But i have a problem with 3 items category, in config.js they have no category and if i fix that, wpi won't show any item again.

Thanks!

Share this post


Link to post
Share on other sites

Could you share your new config.js with 3 categories fixed and I will try.

Note: You can also put your old config.js (8.0.0) inside UserFiles folder and it will be updated (8.7.0) using the new files given !

Tanks

*Edit: Tested adding 3 categories missing and no trouble found. Works fine for me !

Edited by myselfidem

Share this post


Link to post
Share on other sites

Hi People,

 

I updated WPI from 8.6.3 to 8.7.2 with two Problems:

 

1) Not possible to switch off the count-down to start;

     solved with the new WPI.hta.

2) Old config.js not compatible with 8.7.2: solved too by deleting the lines (option not present in the new Versio).

   

    bit64[pn]=['yes'];
    bit64[pn]=['no'];

What I would need now are actual language files for german and italian: can somebody give me a link to?

 

Thanks, Thiersee

Share this post


Link to post
Share on other sites

hey, what you mean with "rewind button" never worked ? (i have a old wpi version here - where i can switch between the titles - between installation... - but maybe i changed something there...)

 

- do you need it ? :D

Share this post


Link to post
Share on other sites

you got a p.m. ;)

 

update: if you meant the fast forward/fast backward button... - and not skipping the tracks (fast backward - doesnt work at my wmp at all - but i dont update, and still got xp...)

 

you maybe wanna check this code - have made it in the past with some help - for a theme with active desktop & wmp

<IMG SRC="Docs.jpg" BORDER=0 STYLE="position: absolute; top: 0cm; left: 0cm; width: 1152px"><script type="text/javascript"><!--	function song( aID ){	document.getElementById('music1').innerHTML="<embed type='application/x-mplayer2' id='music2' pluginspage='http://www.microsoft.com/Windows/MediaPlayer/' src='"+document.getElementById(aID).value+"' name='MediaPlayer1' width='300' height='75' controltype='2' showcontrols='1' showstatusbar='1' AutoStart='true'></embed>";	}//--></script><div id="Liste" STYLE="border:1px solid #000;position: absolute; top:0px;right: 0%;display:block;">	<select  id="cancion" onchange="song( this.id )" size="1" STYLE="color:#9bF;background-color:#000;width:298px;margin:0px;padding:0px;"> 	   <option value="none">::::::::::::: Choose Your Song Here :::::::::::::</option>	   <option value="http://urltosong1playlist.m3u">Playlist 1</option>	   <option value="C:\WINDOWS\Resources\Themes\Docs\Install.m3u">Install.m3u</option>	   <option value="http://urltosong3playlist.m3u">Playlist 3</option>	   <option value="http://urltosong4playlist.m3u">Playlist 4</option>	   <option value="http://urltosong5playlist.m3u">Playlist 5</option>		   <option value="http://urltosong5playlist.m3u">Playlist 3435</option>		</select>	<input type="file" id="DateiFaenger" onchange="song( this.id )" STYLE="position: absolute; top:22px;right: 0%;width:298px;margin:0px;padding:0px;"></div>	<div id="music1" STYLE="position: absolute; top:41px;right: 0%;">	<embed type="application/x-mplayer2" id="music1"		pluginspage="http://www.microsoft.com/Windows/MediaPlayer/" 		src="" 		name="MediaPlayer1" 		width="300"		height="50"		controltype="2" 		showcontrols="1"		showstatusbar="1"		AutoStart="0"></embed></div>
Edited by R4D3

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...