Jump to content

cannot connect to https sites after few minutes


Recommended Posts

ive been dealing with this issue for 2 weeks now and im stuck. when i start a browser (any) i can open any website both http and https but after couple of minutes i can no longer open any https sites.

so far i have tried:

  • uninstalled every security app i had inc AV, Firewall, emet, sandboxie
  • cleared ssl state
  • enabled all ssl versions under internet options
  • clearing browser cache
  • installing a fresh browser with no addons installed
  • in chrome i tried net-internals>socks>flushing
  • registering all the necessary DLL files for secure connections
  • sfc /scannow
  • resetting all settings to default under internet option menu

im loosing my mind, nothing seem to work. and i thought maybe its a problem with my isp but other computers on the network dont have any issues.

anyone has any idea what could be the cause? thanks

Link to comment
Share on other sites

Well, sounds like a virus, you could use Toolbar Cop , run Hijack this or after all the Time spent already you could just do a clean install of Win 8 and start fresh, which only takes about 20 mins for me..DP

Link to comment
Share on other sites

I know you put in the tag "all browsers" but you didn't bring it up in your post. According to your signature I presume this means you primarily use Chrome. Have you tried both the Desktop IE10 and the Metro Modern IE10?

Link to comment
Share on other sites

It sounds like something might be on a delayed start on your PC that is causing the problem. From your description it sounds like you experience this:

Turn on PC, open browser. Go to HTTPS site and it works. Wait some minutes, try again and it doesn't work.

But I wonder if this scenario would also happen:

Turn on PC. Wait like 20 minutes. Go to https site and it doesn't work.

Link to comment
Share on other sites

  • 2 weeks later...

Have you got your PCs clock set to the right date?

Normally having it set wrong would lock you out of https sites straight away but it's worth checking

Edited by malum
Link to comment
Share on other sites

yes the time was set correctly. forgot to mention it in my first post.

in case anyone come across this post with the same issue, i did not manage to find the problem and therefore no solution. i re-installed my windows.

thanks all for your replies!

Link to comment
Share on other sites

I had the same prbleme before and it pissed me off because Facebook didn't work and some others sites too -.-


It was a problem my box from my internet provider, IPv6 had some problems and I had to turn it off and Facebook and the others sites worked again !



Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...