Jump to content
MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. ×

Recommended Posts

I got this message "ERROR: cannot create a file when that file already exists" while installing RC3. I had already ended aerohost.exe and dwm.exe, deleted minidump.dmp, debug.log, moved symbols folder out of the Aeroglass folder and left licence.key as is then copied the RC3 files over the RC2 files. There is nothing in the new debug.log to say which file gave the error. RC3 was working when install.bat completed but I decided to reboot because of this error but nothing appears broken.

I'm getting this same error, and while I can manually run aerohost.exe and get it to work, it doesn't run when I log in. What am I doing wrong?

Link to post
Share on other sites

The problem is that Aero Glass is already running and the files are in use.

Possibly the easiest way to update the software after it's already installed is to rename the 6 existing files (I put _RC2 at the end), then copy the new files from the .7z file into the same folder. Then reboot.

This works because Windows allows you to rename a file that's in use.

-Noel

Link to post
Share on other sites

The problem is that Aero Glass is already running and the files are in use.

Possibly the easiest way to update the software after it's already installed is to rename the 6 existing files (I put _RC2 at the end), then copy the new files from the .7z file into the same folder. Then reboot.

This works because Windows allows you to rename a file that's in use.

-Noel

Thanks for the tip... I did create a new (previously unusued) folder and unzip the files to it, and then ran the install.bat from there. Still though I get that error. :huh:

Link to post
Share on other sites

Good news. For me mostly. :)

I mentioned I would do a CPU update- which will also test the upgrade mechanism at BMs website.

So yesterday, after modifying my new Xeon X5460 with a Dremel and a 771 pin swap sticker, I mechanically had a chip that fits a 775 socket.

http://www.delidded.com/lga-771-to-775-adapter/#bios-mod

Then after some POST warnings, I quickly learned I had to mod my P5E-VM BIOS, add the Socket771 Xeon micro codes & Re-Flash it apparently. :o

I had been forewarned. I could put the old e8200 back in.... get back running.

Decided to go to bed instead. Think about it and Google the problem on a different computer in the morning over fresh coffee.

Turns out AMI is the easiest to change luckily. A nice guy by the name 'MaxWar' showed me which page to read;

http://www.overclock.net/t/1431723/mod-lga775-support-for-lga771-xeon-cpus/860

The job itself is rather minor- but getting this information took a mornings effort to find where to ask.

Later today after the system finally booted back into Win8.1 the debug.log notes the machine.id is now invalid for my Glass license.key

So I cut and pasted the new machine ID found in the latest log into http://glass8.berlios.de/ and Generated a new copy. (I already have two keys on file... probably).

Received and Pasted the new key file into the Glass folder... everything is fine again.. and we are at Pre-Release of AeroGlass now!!

A lightly refreshed machine to run 2014. Now Xeon powered.

Cheers!

Link to post
Share on other sites

Okay,

I have looked all pages and i now have white buttons in the right above corner.

I did not found anything about the text in white or the blur on the taskbar.

Can anyone help ?

Thanks.

The win81_x64_rc3 is also working fine for me.

Has someone an idea on the questions below ?

Thanks.

@gontie, maybe because you're on battery at the time

Thanks for your proposition, i don't know how but at the second reboot, it did work.

When i unplug the power cable aero still work, so i suppose that was not the issue.

Last question, how can i make that the buttons in the right above corners are white ?

This is what i have http://www78.zippyshare.com/v/29124201/file.html

This is what i looking for : http://glass8.berlios.de/win81beta2.png

Also last question (sorry for all these questions) can we enable the blur for the taskbar ?

http://www70.zippyshare.com/v/55188772/file.html

Link to post
Share on other sites

Thanks, Marco993. I had forgotten that aerohost.exe is started by a scheduled task so forgot to delete the task (the xml file in %systemroot%\System32\Tasks being the duplicate file).

I got this message "ERROR: cannot create a file when that file already exists" while installing RC3. I had already ended aerohost.exe and dwm.exe, deleted minidump.dmp, debug.log, moved symbols folder out of the Aeroglass folder and left licence.key as is then copied the RC3 files over the RC2 files. There is nothing in the new debug.log to say which file gave the error. RC3 was working when install.bat completed but I decided to reboot because of this error but nothing appears broken.

I'm getting this same error, and while I can manually run aerohost.exe and get it to work, it doesn't run when I log in. What am I doing wrong?

Did you check Task Scheduler? If the task to start aerohost.exe is missing or the task details are incorrect, recreate/amend it and see if aerohost.exe starts at boot up.

Edited by DrStrange
Link to post
Share on other sites

I am running Windows 8.1 x64(legal full version). Installation went smooth, but after restart I am getting two erros. I forgot to write down exact text, but first was something that theme dll was incompatible and second that shell dll was incompatible

Any fix for this?

Edited by yager
Link to post
Share on other sites

Doesn't work to me.. It installs (I think) without errors but when I reboot (if needed), I don't have nothing changed (aerohost not loaded?)

Maybe it caused by leftovers of previous versions? What can I try? I want my glass back ^^

UPDATE:

Whoops. Seems I had wrong path to aerohost in control panel. I corrected and now works.... The theme used, it's a bit flat however. Can I use a custom resource theme like previous version? Which one? :)

Edited by Hadden
Link to post
Share on other sites

Did you check Task Scheduler? If the task to start aerohost.exe is missing or the task details are incorrect, recreate/amend it and see if aerohost.exe starts at boot up.

Thanks! That was it. It had an old path in it.

Link to post
Share on other sites

UPDATE:

Whoops. Seems I had wrong path to aerohost in control panel. I corrected and now works.... The theme used, it's a bit flat however. Can I use a custom resource theme like previous version? Which one? :)

How did you do that?

Link to post
Share on other sites

UPDATE:

Whoops. Seems I had wrong path to aerohost in control panel. I corrected and now works.... The theme used, it's a bit flat however. Can I use a custom resource theme like previous version? Which one? :)

How did you do that?

In control panel > admin tools > scheduled tasks, there is an Aero Glass activity, edit and correct the path to where the aerohost.exe is, then stop and restart the task. It'll starts :)

With some colour colorization, the theme appears too flat (with other colours doesn't happen) expecially on inactive windows.. there's a workaround for that? (maybe I missed to set a parameter)

It's possible to have perfect round corner also using a theme? (as Vista did)

I'll continue to test (I should say "use" instead xD) it, however it's pretty stable and nice; thanks again big muscle =)

RE-EDIT: Disabling "theme signature bypass", the inactive windows are not flat anymore =D

Edited by Hadden
Link to post
Share on other sites

It's really simple to update to a newer version since RC2. First kill aerohost.exe in the Task Manager, then kill dwm.exe, too. Aero Glass is then fully unloaded, so you can delete the old Aero Glass files without any renaming tricks. After updating the files, restart the task in the Task Scheduler. It should not be necessary to update the task itself as it's unlikely that it will change. It's simply there to load Aero Glass at boot time.

Link to post
Share on other sites

I've been using AeroGlass from the very first beta for Windows 8. Now I've moved to Windows 8.1 and still been using it, a really nice piece of software :D however, even with the most recent version I cannot understand how to get window titles glow effect and aero stripes as seen in all the screenshots here, I've got the transparency, yes, but nothing else :huh: I've downloaded some theme resources pngs, noelc's glow.bmp, put them all in the AeroGlass folder, even played with AeroConfigurator but to no avail. Can anyone help me with this? Thanks in advance

post-376963-0-88460700-1388945480_thumb.

Edited by kientrongtran
Link to post
Share on other sites

I've been using AeroGlass from the very first beta for Windows 8. Now I've moved to Windows 8.1 and still been using it, a really nice piece of software :D however, even with the most recent version I cannot understand how to get window titles glow effect and aero stripes as seen in all the screenshots here, I've got the transparency, yes, but nothing else :huh: I've downloaded some theme resources pngs, noelc's glow.bmp, put them all in the AeroGlass folder, even played with AeroConfigurator but to no avail. Can anyone help me with this? Thanks in advance

To be able to use a custom glow.bmp, themeatlas.png and glow effects I believe you must have the dwm symbols installed.

Link to post
Share on other sites

Example (my files are in C:\BIN):

Windows Registry Editor Version 5.00[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\DWM]"CustomThemeAtlas"="C:\\BIN\\themeatlas.png""ColorizationGlassReflectionIntensity"=dword:00000030"CustomThemeReflection"="C:\\BIN\\AeroGlassReflectionImage.png""TextGlowMode"=dword:00000001

-Noel

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...