Jump to content

Help with install from USB


Recommended Posts

I've been having a right nightmare trying to install XP on my old laptop from USB. The disk drive is broke and USB is my only option. I wiped the hard drive using KillDisk, and then tried to intall using booting software (cant remember the name) ... however it gave me some sort of upgrade error and I needed to insert the windows disc into the disk drive.

So, I did some research and found this site where I followed a guide and used WinSetupFromUSB. All seemed great until I run into another problem. My hard drive isn't in the list of existing partions and unpartioned space, only the USB disk drive is.

The hard drive is working as and recognised in BIOS and was also visible in KillDisk when I wiped it. So how come it doesn't display when trying to install windows via USB?

I am confused as to why this is happening.Can anyone shed some light on this issue and help me install XP.


Link to comment
Share on other sites

If you have a SATA drive and controller, try going into the BIOS and change the controller from AHCI to IDE.

Link to comment
Share on other sites

Prepare the USB disk with WinSetupFromUSB 1.0 beta8. Replace \DPMS\DPMS.iso with this file:


Start from USB. First select "Auto-detect and use F6 SATA/RAID/SCSI Driver", then continue as usual with First part of Windows Setup.

Or integrate in your source BTS mass storage driver pack, making sure Text mode option is selected and redo the USB disk:


Or integrate the appropriate single SATA/AHCI driver in your source using nLite for example:


Link to comment
Share on other sites

That didn't work :(

Still only displays the USB Stick. Althought something new did pop up before the first screen loaded ... "try (hd0,0) FAT32:"

What should I do now?

Link to comment
Share on other sites

I must of been being thick.. method 2 worked perfectly... thank you so much.

Althought I have no sound, or LAN or wireless drivers for it, will have to dig those out now :)

Edited by turbo
Link to comment
Share on other sites

In the device manager, there are exclaimation marks next to a few devices.

Audio Device on HD Audio Bus


SM Bus Controller

Video Controller

Video Controller (VGA Compatible)

I am trying to install the wlan driver first to enable me to browse and download without having to keep swapping files via usb. I've been to the realtek website, tried a few different driver downloads and none of them seem to work for me.

I am double checked that it is the correct driver for the correct OS, but no avail.

Any help would be greately appreciate :)


Link to comment
Share on other sites

The concept of "detail" means what EXACT hardware you are on (possibly including Vid/PID/PCI ID's of the devices you are having an issue with drivers) AND the EXACT driver (including a link to it) that you attempted using unsuccessfully AND an EXACT description of WHAT happened when you made your attempt, like a driver not loaded error or a cannot start this device/service error AND the Code associated to the error (if any).

A quick reference (standard litany):


Start with just the RTL8187B_WLAN_Adapter.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...