Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 

Sign in to follow this  

Interrupts and Strange ProcessExplorer Behaviour

Recommended Posts

Dear All,

I am running Windows 7 Professional 64-bit on an ASUS UL50VT laptop (I will write in detail why this laptop model is a little strange, please see information after the dash line).

Long story short process explorer reports and almost constant CPU usage by Interrupts/DPC's of 20%. For a snapshot of ProcessExplorer please see the image in the provided link:

PE Snapshot

So I ran xperf (for about 2 minutes), but to my surprise neither DPC's nor Interrupts show a CPU use close to 20%. Please see the etl file in the link provided:


So what is going on here, I am utterly confused, and your help is greatly appreciated. If you are interested in the history of the issue and what I have tried before please see additional information below.



I must confess that before posting here I have done these tests before, and in the etl files I could see my nvidia drivers being problematic. UL50VT has 2 display adapters One Intel and an NVIDIA G210M, and uses an ASUS proprietary technology to switch between the 2 and ASUS stopped driver support for these in 2009.

Some people managed to build custom driver packages and I was using one of those. When I had that driver package I did run the same routine tests and the nvidia drivers were problematic (it showed clearly in the etl file).

Now I have gone back to the official ASUS drivers, and when I saw process explorer reporting similar interrupt use I tried a billion things to fix the issue. I disabled usb ports from the bios, and network adapters and audio drivers, but to no awail. I tried a bunch of drivers for all components (all official ASUS drivers). A couple of full reinstalls of the system but this issue with interrupts was not resolved.

But now that xperf does not show any interrupt/dpc use but process explorer reporting almost constant %20 use I am seriously confused and your help is greatly appreciated.




Share this post

Link to post
Share on other sites

Dear MagicAndre1981 (replied at sysinternals as well),

I understand there are graphic issues, the problem is that this driver:


is not compatible with my computer.

As I said in the Additional Information, ASUS has a special controller between the intel and nvidia card, making official nvidia drivers not even install.

To overcome this issue some people did release supposedly stable 260.xx drivers, I have tried them and they make the issue even worse.

The strange thing is that I have been using this laptop for 3-4 years and did quite a lot of re-installs. ProcessExplorer was always a must in the system, and this is the first time I am seeing this issue.

Could it be a Directx update that is causing the issue? If so how can I use and older version of Directx?



Share this post

Link to post
Share on other sites

So I have Installed Service Pack 1 but there is absolutely no effect. Any more ideas?

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.