Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Windows 3.1 hangs on splash screen

Recommended Posts

I don't understand the point of your experiments. :w00t:

The ONLY advised status of the partition entry is with CHS and LBA both correct (i.e. balanced), what may be up to test (but I don't think it is in your specific case) could be the actual CHS geometry (it is not to be taken as "given" that in all cases the actual 255/63 geometry is used). 

Making experiments with intentionally or casually wrong ones seems to me like proving nothing.

And - even if I understand how you have no possibility right now to do otherwise - limiting the test to a single stick on a single (same) motherboard (and/or being unable to do "proper" tests on other motherboards9 doesn't exclude that the issue is related to either the specific stick (either controller or single item malfunctioning)  or to the specific motherboard (specific BIOS or its specific USB stack).

You could try using RMPREPUSB that has an internal (actually "better" than the HP and MS tools) partitioning/formatting tool and see what happens. :unsure:



Share this post

Link to post
Share on other sites

Posted (edited)

I am sorry if I wasted time. :(

I am using four different USB flash drives and a small 16MB SD card for my experiments. I used RMPREPUSB already to make my FAT16 and FAT32 USB-FDD's (for my FAT12 one MKBT). I shall explore RMPrepUSB further, also other tools like Flashboot you mentioned in your last link.

What I forgot mentioning from my latest experiments is that ALL eight Windows 3.1 (Express) installations gave exact same configuration files. 

Regarding the swapfile: I found in the Windows 3.1 Resource Kit that a "swap file" can only be made on drives with 512 byte sector-size (Windows Resource Kit, p. 245)

Edited by deomsh

Share this post

Link to post
Share on other sites
Posted (edited)
On ‎12‎-‎5‎-‎2018 at 11:51 AM, jaclaz said:

It remains "strange" since DOS 7.1 should have no issues with both 0B and 0C, and Windows 3.1 should know nothing about BOTH 0B and 0C (and thus treat - or fail to treat - both exactly in the same way).

I solved my earlier incompatibilities between my two legacy BIOS's (spontaneous reboots with some partition types) and not starting Windows 3.1 in Enhanced mode with temporary swapfile if booted from another flash drive or floppy drive. It seemes to be DOS-related, I will explore that later.

I made as a first start a FAT16 USB-HDD with RMPrepUSB, which resulted in an unintended experiment. This USB-HDD has two partitions, a normal one and a very small one with Partition ID 21 (a reserved partition ID). During setup, Windows 3.1 gave a pop-up screen with following text. "The partitioning scheme used on your hard disk prevents the creation of a permanent swap file. You can create a temporary swapfile".


The last was not true in case of my USB-HDD: no starting in Enhanced mode with temporary swap file. As soon I set the partition ID of the second partition to 00 or 01, everything was back to "normal". 

I only found that this could be a "check" because of possible bootsector virus.

https://books.google.nl/books?id=d3AlDwAAQBAJ&pg=PT188&lpg=PT188&dq=partition+scheme+used+on+your+hard+disk+prevents+the+creation+of+a+permanent+swapfile&source=bl&ots=sVtXOf5VFy&sig=80Pzvtwm7DrGG7m5cPCGSYi-tRk&hl=nl&sa=X&ved=0ahUKEwil06mLgInbAhVCsKQKHa__CP0Q6AEIJzAA#v=onepage&q=partition scheme used on your hard disk prevents the creation of a permanent swapfile&f=false

BTW: the pop-up above seemed not to be MS-DOS-version related (I tried MS-DOS5.0 and MS-DOS 6.22 too).

After that I made a few dozens of new installations on different USB flash drives with both my two legacy BIOS's. The only results I want to mention:

  • On a FAT16 (06) partition a permanent swap file was possible (in case of MS-DOS 7.1 the peculiar drive must be unlocked with "LOCK [Drive]:")
  • In case of two normal partitions on a USB-HDD only the Partition type of the partition where Windows 3.1 was started from "rules". If installed on a FAT (06) or FAT32 (0B) partition there were no problems, even if the temporary swap file resided on a FAT16X (0E), or FAT32X (0C) partition. Not the other way round, which is consistent with my earlier reports.

Concerning the "partitioning scheme" error, I found Q82373.


BTW To be sure I repeated my experiments on a 3.2GB HDD: I could reproduce the "partitioning scheme" error, but on the HDD there was NO PROBLEM using a temporary swap file instead and starting in Enhanced mode from a FAT32X/0C partition. So maybe this error is a dead end.



Edited by deomsh
corrections and addititons

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.