Jump to content

3rd party drivers


 Share

Recommended Posts

i'm trying to have my unattended install install drivers automatically whilst installing.

I've downloaded the x64 Win7 driverpack from driverpacks.net

Unzipped and put in a folder called Drivers.

I've put this folder in..

sources\$OEM$\$1\Drivers

and in my autounattend.xml the code is...

    <settings pass="windowsPE">
<component name="Microsoft-Windows-PnpCustomizationsWinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<DriverPaths>
<PathAndCredentials wcm:keyValue="d37a5f8b" wcm:action="add">
<Path>C:\Drivers</Path>
</PathAndCredentials>
</DriverPaths>
</component>
</settings>

and

    <settings pass="auditSystem">
<component name="Microsoft-Windows-PnpCustomizationsNonWinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<DriverPaths>
<PathAndCredentials wcm:keyValue="d37a5f8b" wcm:action="add">
<Path>C:\Drivers</Path>
</PathAndCredentials>
</DriverPaths>
</component>
</settings>

The folders copy, but the network drivers do not get installed automatically.

Is there something wrong to my approach? Does the $oem$ folder get copied after installation?

Link to comment
Share on other sites


Using this command in the WindowsPE settings pass would try to install the drivers in Windows PE, not in Windows. Using this command in the AuditSystem pass would only take effect if you booted into Audit Mode. According to the article 'Add Device Drivers During Windows Setup', you could use this in the OfflineServicing pass. This is also touched upon in the article 'How Configuration Passes Work' which shows how the different passes work. Based on your post, I believe the OfflineServicing pass matches what you are intending to accomplish.

Hope this helps,

David

Windows Outreach Team - IT Pro

Link to comment
Share on other sites

I believe this will help you. Just have your drivers (or driverpacks) extracted in as many subfolders as you want and it will find it during install. Have them in "dvdroot"\sources\$OEM$\$$\PnPdrvrs\w7x64 or whatever you want to name the final directory. A caviat is that for an all in one install it will copy both architectures wasting a little time.

  <settings pass="windowsPE">

<component name="Microsoft-Windows-PnpCustomizationsWinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<DriverPaths>
<PathAndCredentials wcm:keyValue="1" wcm:action="add">
<Path>\sources\$OEM$\$$\PnPdrvrs\w7x64</Path>
</PathAndCredentials>
</DriverPaths>
</component>

<component name="Microsoft-Windows-PnpCustomizationsWinPE" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<DriverPaths>
<PathAndCredentials wcm:keyValue="1" wcm:action="add">
<Path>\sources\$OEM$\$$\PnPdrvrs\w7x86</Path>
</PathAndCredentials>
</DriverPaths>
</component>


</settings>
<settings pass="offlineServicing">

<component name="Microsoft-Windows-PnpCustomizationsNonWinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<DriverPaths>
<PathAndCredentials wcm:keyValue="1" wcm:action="add">
<Path>\Windows\PnPdrvrs\w7x64</Path>
</PathAndCredentials>
</DriverPaths>
</component>

<component name="Microsoft-Windows-PnpCustomizationsNonWinPE" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<DriverPaths>
<PathAndCredentials wcm:keyValue="1" wcm:action="add">
<Path>\Windows\PnPdrvrs\w7x86</Path>
</PathAndCredentials>
</DriverPaths>
</component>

</settings>

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...