Jump to content
MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. ×

WPI v8.4.6 Release thread


Recommended Posts

WPI.exe? Been stripped to the bone! Might be missing some key resources they are looking for....

I just got answer from Avira, it is a false positive and will be fixed with upcoming signature updates.

I updated my Antivirus and it seems they already fixed it. :)

Link to comment
Share on other sites


Howdy!

I run WPI from a network share to update workstations. I used to start it from a batch script, but it no longer works with 8.4.6. Now I get an error that says "A previous WPI instance has not been closed correctly. Please close WPI correctly to allow the Internet Explorer debugging keys to be properly restored." Then I get a blank WPI.hta window. It works fine if I run it from my portable drive or map a network drive first before running the script, so that's my workaround for the moment. My batch script is just below. Any ideas?


if "%allusersprofile%"=="%systemdrive%\ProgramData" goto Vista
SET allstart=%ALLUSERSPROFILE%\Start Menu\Programs
SET userstart=%USERPROFILE%\Start Menu\Programs
SET alldesktop=%ALLUSERSPROFILE%\Desktop
goto WPI
:Vista
SET allstart=%ALLUSERSPROFILE%\Microsoft\Windows\Start Menu\Programs
SET userstart=%USERPROFILE%\AppData\Roaming\Microsoft\Windows\Start Menu\Programs
SET alldesktop=%SYSTEMDRIVE%\Users\Public\Desktop
goto WPI
:WPI
SET download=%~dp0
SET quicklaunch=%APPDATA%\Microsoft\Internet Explorer\Quick Launch
SET userdesktop=%USERPROFILE%\Desktop
ftype htafile="%windir%\system32\mshta.exe" "%%1"
pushd %~dp0
cd wpi
wpi.exe
popd

Link to comment
Share on other sites

OK OK

I have contacted Francesco about making the exe stay running until mshta is done (The wpi process)

I will post a new version as soon as I get the binaries.

P.S. Don't wanna be mean but for all those running from a network share please remember WPI is not free for business or corp uses. (I have only sold 3 of those licenses and get VERY little in donations)

Edited by Kelsenellenelvian
Link to comment
Share on other sites

OK OK

I have contacted Francesco about making the exe stay running until mshta is done (The wpi process)

I will post a new version as soon as I get the binaries.

P.S. Don't wanna be mean but for all those running from a network share please remember WPI is not free for business or corp uses. (I have only sold 3 of those licenses and get VERY little in donations)

Talked to francesco..

He will post a fixed one as soon as he can test it out.

Here is the launcher from 8.2.2 it will work for your purposes for now. (You just will miss out on a couple of the updates)

Edited by Kelsenellenelvian
Link to comment
Share on other sites

  • 4 months later...

hi,

after I update 8.4.6 this code doesn't seem to work anymore;

I use it with RunOnceEx. And My .msi programs don't wait each other to finish its install. They begin to install even if others don't finish.


@ECHO OFF

FOR %%i IN (D E F G H I J K L M N O P Q R S T U V W X Y Z) DO IF EXIST %%i:\CD.txt SET CDROM=%%i:

SET KEY=HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnceEx

for /f "delims=: tokens=1" %%i in ("%~dp0") do set drive=%%i:
set wpipath=%drive%\wpi

REG ADD %KEY% /V TITLE /D "Uygulamalar Yukleniyor" /f

REG ADD %KEY%\998 /V 1 /D "%wpipath%\WPI.exe" /f

REG ADD %KEY%\999 /VE /D "Driverpacks Finisher" /f
REG ADD %KEY%\999 /V 1 /D "%SystemDrive%\DPsFnshr.exe" /f

EXIT

Link to comment
Share on other sites

  • 1 month later...

OK OK

I have contacted Francesco about making the exe stay running until mshta is done (The wpi process)

I will post a new version as soon as I get the binaries.

P.S. Don't wanna be mean but for all those running from a network share please remember WPI is not free for business or corp uses. (I have only sold 3 of those licenses and get VERY little in donations)

I am having the same issue that midiboy is having with the WPI.exe no longer running (i previously used 8.1). I used to be able to have wpi and all files in my sysprep file run before teh desktop loads but now WPI runs as well as the next installation which has been causing issues. I tried using the 8.2 executable but i have been getting the IE Debug script errors when running WPI.

has a new version of the executable been released that keeps wpi.exe running?

Thanks ahead of time

Link to comment
Share on other sites

8.4+ has a new exe....

I tried the exe from 8.4 and it has the same issue where the wpi.exe process doesn't run, only mhsta.exe. I am running WPI from sysprep so the next commands is running before WPI is finished doing what it has to do

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...