Jump to content
MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. ×

2 Strange Occurences


Recommended Posts

XP SP3 here.

I just tried un-checking "noguiboot" in msconfig, and when I do so the "apply" button doesn't become selectable. If I then re-check the box, apply does become selectable, and if I uncheck the box again and hit apply, the new setting (un-checked box) is NOT applied.

Also, I tried to set up a guest account and password for the Admin account, hit apply and ok, then rebooted, and none of these settings took effect (the guest account was still off, no pasword required for admin account).

I'm stumped. This is not a nlite install and I have turned some services off, carefully, using proper guides.

Thanks

Edited by xmf
Link to post
Share on other sites

XP SP3 here.

I just tried un-checking "noguiboot" in msconfig, and when I do so the "apply" button doesn't become selectable. If I then re-check the box, apply does become selectable, and if I uncheck the box again and hit apply, the new setting (un-checked box) is NOT applied.

Do you have permissions to edit the \boot.ini file?

And if you make changes to it using msconfig - does your boot.ini file get updated with them?

Link to post
Share on other sites

What services did you turn off?

Pics attached

Do you have permissions to edit the \boot.ini file?

And if you make changes to it using msconfig - does your boot.ini file get updated with them?

Also, make sure that the file "boot.ini" is not set as read-only.

I searched for boot.ini (including hidden) and only found "boot.ini.backup" in windows/pss

post-276866-0-16597900-1319940358_thumb.

post-276866-0-02877100-1319940366_thumb.

Link to post
Share on other sites

Have you unchecked: Hide protected system files (recommanded)?

And, you could see the boot.ini file at the root of your Oprerating System - HDD (C:\) -

Edited by myselfidem
Link to post
Share on other sites

Also, make sure that the file "boot.ini" is not set as read-only.

Have you unchecked: Hide protected system files (recommanded)?

And, you could see the boot.ini file at the root of your Oprerating System - HDD (C:\) -

Thanks, so boot.ini does exist and it was set to read-only - so I unchecked "read-only" and rebooted. However, I still can't get the "apply" button to appear when I uncheck "noguiboot" in msconfig. Also, although the Guest account is on and the admin acct is pass protected, I'm still not getting a log in screen or password prompt. It just boots straight into the admin acct.

Link to post
Share on other sites

You can keep boot.ini file with Read only!

If you want change the boot.ini file you can browse to:

Control Panel | System | Properties

Select: Advanced Tab

At the bottom => Startup and Recovery.

Choose: Settings

Change

The boot.ini file will be opened and you can write the new line:

Boot.ini


[boot loader]
timeout=5
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professionnel" /NOEXECUTE=OPTIN /FASTDETECT /NOGUIBOOT

http://support.micro...kb/289022/en-us

Save and exit!

Restart the computer!

You can first save the original boot.ini with notepad (for example) with copy/paste:

Example: my Original Boot.ini file (Multiple boot: Windows XP, Windows Vista and Windows 7)


;
;Warning: Boot.ini is used on Windows XP and earlier operating systems.
;Warning: Use BCDEDIT.exe to modify Windows Vista boot options.
;
[boot loader]
timeout=5
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professionnel" /NOEXECUTE=OPTIN /FASTDETECT
c:\CMDCONS\BOOTSECT.DAT="Console de r‚cup‚ration Microsoft Windows XP" /CMDCONS

http://support.micro...kb/102873/en-us

http://support.micro...kb/314081/en-us

Edited by myselfidem
Link to post
Share on other sites

I edited boot.ini and rebooted, and now the noguiboot check-box even functions properly in msconfig again! (a mystery to me)

With the logon/guest account issue, I forgot I had checked "autologin" in tweakUI. I had to uncheck that option and go into the registry in order to prevent the admin acct from being hidden in the welcome/login screen.

Now everything appears to be working properly. Thanks all

Edited by xmf
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...