Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Hella

Getting the ATI Mobility FireGL V5000 / Mobility Radeon X700 to work w

Recommended Posts

I tried with vemp graphic driver who work pretty well but no direct 3D in it . I got the SciTech Display Doctor, i will try it again but if i remember it was not pretty good yet.

During this time i was looking for mesa3D generic driver but i didnt get yet how to use it. I will make new test today and keep you in touch.

Share this post


Link to post
Share on other sites

Thanks for the mesa3D. SciTech Display Doctor :- not free ware & can not be used/installed while using main display driver. There is Linux source code for FireGL 5000 https://launchpad.net/ubuntu/hardy/i386/xorg-driver-fglrx-envy/1:7.1.0-8-6+2.6.24.503-503.33  The latest Mobile driver I found was https://download.lenovo.com/ibmdl/pub/pc/pccbbs/mobiles/vftp1gme.exe 2004. Cov3rt is specific about Catayist 4.11, direct download here http://dl2.opendrivers.com/dl_file.php?dl=dl2&brand=display-and-video%2Fati-technology&file=wme-8-03-98-3-041103a-019079e.exe&check=c861ca602t7b2a&driver=44ak5t Remember to remove the quotations around the file. I would try this version as Cov3rt suggests. In the quest to get better performance not all cards worked anymore, like nVidia driver 81.98 killed off the 6200 PCI cards in a CPU short out BSOD. nVidia 6200 PCI had to use 77.72 drivers.

PS I made a discovery, I had ATI2CQAG.DL_ from ATI 6.2 renamed _ATI2CQAG.DL_ & using ATI vs 5.9 ATI2CQAG.DL_ 17/8/2005. If vs 6.2 is used there is no 3D working with 9500. The early LH driver's infs load into registry untouched but not compatible as a driver install. 9500 does use same chip as 9700 I should have looked at inf not WWW, X700 & X850 didn't though.

Edited by Goodmaneuver
mistakenly shown nVidia driver

Share this post


Link to post
Share on other sites

Well I come for give some news so im still stuck by the same trouble. I tried SciTech Display Doctor but the drivers never wanted take over the microsoft driver so i wasnt able at all to use it. So I actually give up find a working driver for the Radeon Moblity X700 under WIn9X. I use actually the driver VBEMP who work perfectly except still no 3D accellerate. I tied to use mesa3D with but for the game i tried (Unreal) its not worked properly i will try the inject plugin in.

FOr conclude, most of the game i wanted played get patched or some tweak make them working under xp. So i will stick to xp for this old laptop but i will still keep my partition under WIndows 98 in case someone find the solution to this ATI Drivers problems.

Event the DHModtool in all version could solve my trouble but i dont find the drivers requiere or its not working at all with Win9X.

 

 

Share this post


Link to post
Share on other sites
On 11/19/2019 at 11:28 AM, JasonSlaye said:

I dont know if this post will be read again but man, i got a asus laptop with a mobility radeon X700. I try your solution but i may fail, i find catalyst 4.11 but not sure its a good one.

I had this : "RADEON X700 Series Secondary   " = RV410_ENU, PCI\VEN_1002&DEV_5653&SUBSYS_0940103C&REV_00
"RADEON X700 Series Secondary   " = RV410_ENU, PCI\VEN_1002&DEV_5653

 

but i looked in the inf there is no RV410. So i looked to the xp version and the model is : "ATI MOBILITY RADEON X700" = ati2mtag_M26, PCI\VEN_1002&DEV_5653&SUBSYS_11B21043
"ATI MOBILITY RADEON X700 " = ati2mtag_M26, PCI\VEN_1002&DEV_5652&SUBSYS_18811043
"ATI MOBILITY RADEON X700  " = ati2mtag_M26, PCI\VEN_1002&DEV_5652&SUBSYS_19621043
"ATI MOBILITY RADEON X700   " = ati2mtag_M26, PCI\VEN_1002&DEV_5653&SUBSYS_11221043

 

SO i make a copy of the catalyst driver 4.11 and i add the last line. Well its worked but i got limited to 2 color and 16 color and the c panel for ATI no want start.

I edited the xp driver with making a copy of all the register files, ini and inf than i rename from C2 to C9X. Then again drivers is taken but not possible to install the ati software and use it.

The color is still limited to 2 or 16 color. If you read my message can you help me or make me a package with your driver for this graphic card ?

 

THanks you

15 hours ago, Goodmaneuver said:

Did you try the Catalyst 4.11 drivers I found and follow Cov3rt's instructions again?
 

Hello, well using catalyst 4.11 it something i did the first before i post here, its in my first post. After that LoneCrusader make me give up on it because it was not working.

I didnt retry with your link cause its not work actually:

http://dl2.opendrivers.com/dl_file.php?dl=dl2&brand=display-and-video%2Fati-technology&file=wme-8-03-98-3-041103a-019079e.exe&check=c861ca602t7b2a&driver=44ak5

I will retry and this is link for the drivers i find : http://www.opendrivers.com/download/driver-18305.html

This conversation of vogons bring 4.7 and 5.9 catalyst drivers too : https://www.vogons.org/viewtopic.php?t=45116&p=449707

Share this post


Link to post
Share on other sites

Yep, unfortunaly my friend, still not work, i still get the faded away screen when i restart after i apply the drivers, even Catalyst not recognized them.

I even modified my inf file for give more information on the hardware but it seems this graphic card want only listen the driver with M26 settings in.

Share this post


Link to post
Share on other sites

Yes updating inf would be good if driver worked. Forcing the install is all that is required to test the driver. As you know, update driver, and choose manually the driver to try from within the install list. I think that some laptops used two different GPUs, one for the screen and the other for the VGA output. One was in chip IGP and the other was external graphics like the ATI driver. This would show up in Device Manager I would expect though as two separate display adapters. I wonder if plugging in an external monitor would switch off the laptop screen? Have monitor plugged in before powering up the laptop to see. If it does then this is worth a try to use the VGA output and try the driver.
 

Edited by Goodmaneuver

Share this post


Link to post
Share on other sites

Well i remember in some early reinstall of WIndows 98 i got the two devices listed in the driver list but since i deleted one it never got back even after some reinstall. I should propably make a full new install with a WIn98SE without unofficial patch for get it back. Maybe do you get a tips for reveal it.

Share this post


Link to post
Share on other sites

Maybe do a New Hardware search from the Control Panel.

 

Share this post


Link to post
Share on other sites

Did XP show the 2 drivers? If it does then plug in external monitor to exercise that area of hardware. See what the driver is from XP. Try and fill up your hard drive if you only have one, in case it starts to get write errors.  @cov3rt might have used an earlier driver as Catalyst 4.11 has already an inf for x700, it just doesn't add up. I have found some DNA drivers https://www.guru3d.com/files-archive found in September 2004.

* Added support for:
-:RADEON X600 SERIES
-:RADEON X800 XT
-:RADEON MOBILITY 9800
-:RADEON MOBILITY X300
-:RADEON MOBILITY X600
-:RADEON MOBILITY M28 (Mx8)
-:ATI FireGL D1100
-:ATI FireGL V5100
-:ATI FireGL V7100
-:ATI FireGL V7200

I tried this driver and it looks like DNA drivers did not support Win98 no matter how old they are. It has not got M26 either, it has got M22, M24 & M28.

Driver version 4.14.01.9150 date 20/10/2004 for Win98 here https://www.helpjet.net/Fs-64531818-59851182-67091790-devices.html It does not have x*** series cards.

Edited by Goodmaneuver
Remove session ID link

Share this post


Link to post
Share on other sites

JasonSlaye:
- i got the two devices listed in the driver list but since i deleted one it never got back
- I should propably make a full new install with a WIn98SE
- Maybe do you get a tips for reveal it.

Hi JasonSlaye.

I can't help with your specific hardware but an OS re-install is almost never required.

This works well for me for stubborn hardware installs and undesirable driver purges.

- Right-click C:\WINDOWS\INF and select Find.
- Complete several keyword searches to identify failed drivers, for you maybe ATI, fire, v5000.
- Temporarily rename each file extension to temporarily disable it. On my system for example, rename
DXNVIDIA.INF to DXNVIDIA.INF_DISABLE and DXNVIDIA.PNF to DXNVIDIA.PNF_DISABLE.
- Several renames may be needed if numerous undesirable drivers were previously installed.
- To ensure nothing was missed repeat searches with similar keywords but now use Find -> Containing text, as *.inf file names may not be intuitive to the hardware device.
- Note culprit INF files may be located in C:\WINDOWS\INF\OTHER, in which case all Find searches should have 'Include subfolders' checked off.
- Right-click My Computer -> Properties -> Device Manager tab and remove all entries under Display Adapters.
- Reboot and your system will find the new video card, then install the desired driver.

Share this post


Link to post
Share on other sites

>> I tried SciTech Display Doctor but the drivers never wanted take over the microsoft driver so i wasnt able at all to use it.

The driver file may have been in use and in RAM. If you know the name of the file/s, I think it was OpenGL32.dll, but not sure now, copy SciTech one over in safe mode or from DOS on a startup floppy. If it is not OpenGL32.dll rename OpenGL32.dll to disable it, in safe mode if necessary. If the Microsoft file is 16bit then move it by left clicking on it and drag to an empty folder after a fresh reboot. 16 bit files can be deleted by deleting the folder they are in or they need to be highlighted then press delete key if right clicking cannot delete or rename.

>> - Right-click My Computer -> Properties -> Device Manager tab and remove all entries under Display Adapters.

This is done in safe mode otherwise unused devices do not show. Sound driver removal like this can destroy a good system if drivers like streaming devices are removed. These are usually named Microsoft but are not always in use so if using HPSysDig.exe then these devices show as unused but they are just not in use at the moment and should not be removed as they do not come back I found.

Edited by Goodmaneuver

Share this post


Link to post
Share on other sites

Once again:

On 11/20/2019 at 1:56 AM, LoneCrusader said:

Forget Catalyst 4.11

:angel

There's nothing special about Catalyst 4.11. The only thing significant about it was the fact that it added BETA support for some Xxxx series cards.

"BETA CATALYST 4.11 release for RADEON X300, RADEON X600, and RADEON X800 AGP Series"

This support remained in the later non-Beta releases, no doubt with improvements!

Edited by LoneCrusader
add links

Share this post


Link to post
Share on other sites

Catalyst 4.11 driver was the first for Xxxx cards but I did not think it was a Betta driver, it was distributed with the graphics cards. The link I have given even though it says it is 4.14.01.9150 it is an earlier driver that does not contain any Xxxx series card support, it is the previous driver.

I have found an Omega driver from MajorGeeks.com that is for Win9x that contains Radeon mobility FireGL 9000 :- rad_w9x_omega_2637.exe 2nd month 2004 so no x700 series.

I think Cov3rt has talked about this elsewhere though it may have been for nVidia, we probably need to talk with them some more. 
 

Edited by Goodmaneuver

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...