Jump to content

OnePiece Post SP3 AIO 4.5.1


hag672
 Share

Recommended Posts

Hi:

I'm not trying to be a pain...

I looked at OnePiece Post SP3 AIO 4.5.1, and it shows .net 1.1 as a part of the onepiece installation.

I have an older pprogram that I usea as one of my specialized pieces of software so I can navagate my computer due to my disability. It requires .net 1.1.4xxx (can't remember the other few numbers to run. I integrated the onepiece with nlite, and used Kel's entries_removal.ini because I could not get the winnt.sif to turn off components correctly.

When I went to view components in the add/remove Windows components. I found .net 2.0, 3.0, 3.5, and 4.0 NO 1.1.4xxx.

When I attempted to run my specialized software it would not run because .net 1.1.4xxx was not installed. It offered to install i, and I selected YES, but the setup would not install it because it found another version of .net already installed.

I went into Windows Componenets in Add/Remove, and removed .net 2.0 to see if that would work. It didn't. When I went into Windows Components again undr add/remove to reinstall .net 2.0 I was asked for Windows XP Professional CD2. I only had one CD. I inserted it, and pointed it to the i386 folder, and still was asked for CD2.

Either way I was in limbo land.

I even created another integation first integrating .net 1.1.4, then the onpiece, then using rvmi to remove the unwanted components, and then nlite again to add the final components and weaks.

It still did not work, and .net 1.1.4xxx was not integrated.

Is there a way of updating the onepiece to integrate .net 1.1.4xxx as it shows .netfx1.1 within the onepiece.

Please help or I am really stuck.

Much thanks,

hag672 :unsure:

Link to comment
Share on other sites


OnePiece Update pack for .NET Framework 1.1 by default will not be shown on 'Add/Remove Windows Components' list.

What you need to do is to remove 'hide' for Entries.ini (You can unpack the big archive to edit Entries.ini)

Then repack back.

Edit as follows in Entries.ini

[Sysoc]
;NetFx11=ocgen.dll,OcEntry,NetFx11.inf,hide,7
NetFx11=ocgen.dll,OcEntry,NetFx11.inf,,7

After you integrate, there should be 2 folders as follows:

C:\WINDOWS\Microsoft.NET\Framework\v1.0.3705

C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322

You can also check in 'Add/Remove Windows Components' that 1.1 is listed. See below screenshot (36.6MB is v1.1)

(with OnePiece_Windows_XP_Post-SP3_UpdatePack_v4.6.1_ENU.7z)

Mr9Ju.png

Hope that helps

Link to comment
Share on other sites

As hag672 says

When I attempted to run my specialized software it would not run because .net 1.1.4xxx was not installed.
but I guess he needs the components of this one C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322. Does it matter if it shows under Add/Remove Programs if it IS installed? Yet, there is an alternative. If the update does show, you can uninstall it, install .NET Framework 1.1.4.xxxx from an installer and see if that does the trick.

I've added the topic to my watch list and am ready to jump in as soon as the slightest breakthrough is made. Not having any experience with this particular Update Pack makes it a little difficult.

Cheers

Link to comment
Share on other sites

OnePiece Update pack for .NET Framework 1.1 by default will not be shown on 'Add/Remove Windows Components' list.

What you need to do is to remove 'hide' for Entries.ini (You can unpack the big archive to edit Entries.ini)

Then repack back.

Edit as follows in Entries.ini

[Sysoc]
;NetFx11=ocgen.dll,OcEntry,NetFx11.inf,hide,7
NetFx11=ocgen.dll,OcEntry,NetFx11.inf,,7

After you integrate, there should be 2 folders as follows:

C:\WINDOWS\Microsoft.NET\Framework\v1.0.3705

C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322

You can also check in 'Add/Remove Windows Components' that 1.1 is listed. See below screenshot (36.6MB is v1.1)

(with OnePiece_Windows_XP_Post-SP3_UpdatePack_v4.6.1_ENU.7z)

Mr9Ju.png

Hope that helps

I ent into the onepiece 7z file, and edited the entries.ini file to remove hide. I used nlite to integrate the onepiece, and rvmi to remove unwanted components with kel's entries removal.ini. I then used nlite to add all other files and tweaks.

Much thanks,

hag672 :blink:

Edited by hag672
Link to comment
Share on other sites

As hag672 says

When I attempted to run my specialized software it would not run because .net 1.1.4xxx was not installed.
but I guess he needs the components of this one C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322. Does it matter if it shows under Add/Remove Programs if it IS installed? Yet, there is an alternative. If the update does show, you can uninstall it, install .NET Framework 1.1.4.xxxx from an installer and see if that does the trick.

I've added the topic to my watch list and am ready to jump in as soon as the slightest breakthrough is made. Not having any experience with this particular Update Pack makes it a little difficult.

Cheers

Hi:

I edited the entries.ini file to remove "Hide", and after the installation I did find .net Framework. I uninstalled it, and went to instal my copy of .net framework 1.1.4x, and after the files extracted I received a setup error saying it could not be installed because there was already another version of .net framework installed.

I mistyped the version of the onepiece being used. I am using OnePiece 4.6.1.

: :blink:

Edited by hag672
Link to comment
Share on other sites

Dun know if this will work. Pls test in WM first. Perhaps just tell entries.ini not to install 1.1 in the first place. so that you could install your own version of 1.1.4x

[Sysoc] 
;NetFx11=ocgen.dll,OcEntry,NetFx11.inf,,7

Link to comment
Share on other sites

Dun know if this will work. Pls test in WM first. Perhaps just tell entries.ini not to install 1.1 in the first place. so that you could install your own version of 1.1.4x

[Sysoc] 
;NetFx11=ocgen.dll,OcEntry,NetFx11.inf,,7

Sorry, it didn't work. I first did what you showed to rem out the netfx11. After building a new integration I found that .net wants to have no other version installed.

I then built a new integration, this time remming out all .net11 through .net4 in the entries.ini file. After building a new integration I had now included .net11, .net20sp2, .net 35.sp1, and .net40.

I created a SVCPACK folder for each, and an associated entries.ini file. .net1.1 and .net40 installed. .net2 and 3.5 did not install. Neither did Adobe Reader 10.01.

Also when dotnetfx11 instaled it showed all dialogs and needed user input even with the /q switch.

Here are all 4 entries.ini files for each dotnetfx SVCPACK:

;entries_dotnetfx11.ini

;This section contains version information to nLite & RVM_Integrator;

[general]

builddate=05/25/2010

description=Addon Microsoft .NET Framework 1.1

language=English

title=Microsoft .NET Framework 1.1

version=1.1.4322.5473

website=http://www.microsoft.com

Windows=XP

[EditFile]

I386\SVCPACK.INF,SetupHotfixesToRun,AddProgram

[AddProgram]

dotnetfx11.exe /q

;entries_dotnetfx20sp2.ini

;This section contains version info for RyanVM Integrator & nLite

[general]

builddate=05/25/2011

description=Addon Microsoft .NET Framework 2.0 SP2

language=English

title=Microsoft .NET Framework 2.0 SP2

version=2.2.30729.1

website=http://www.microsoft.com

Windows=XP

[EditFile]

I386\SVCPACK.INF,SetupHotfixesToRun,AddProgram

[AddProgram]

dotnetfx20sp2.exe /q

;entries_dotnetfx35sp1.ini

;This section contains version information to nLite & RVM_Integrator;

builddate=05/25/2011

description=Addon Microsoft .NET 3.5 SP1 Framework 3.5 SP1

language=English

title=Microsoft .NET Framework 3.5 SP1

version=3.5.30729.1

website=http://www.microsoft.com

Windows=XP

[EditFile]

I386\SVCPACK.INF,SetupHotfixesToRun,AddProgram

[AddProgram]

dotnetfx35sp1.exe /qb /norestart

;entries_dotnetfx40

;This section contains version info for RyanVM Integrator & nLite

[general]

builddate=05/25/2011

description=Addon Microsoft .NET Framework 4.0

language=English

title=Microsoft .NET Framework 4.0

version=4.0.30319.1

website=http://www.microsoft.com

Windows=XP

[EditFile]

I386\SVCPACK.INF,SetupHotfixesToRun,AddProgram

[AddProgram]

dotnetfx40.exe /Q /norestart

Much thanks for your idea :blink:

hag672

Edited by hag672
Link to comment
Share on other sites

Sorry to hear it didn't work

I have no idea now but just some more suggestion to test:

Download this checker http://www.tmgdevelopment.co.uk/versioncheck.htm to check further

Check if HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP\v1.1.4322 exists even if you have not install 1.1 thru AIO package

Search for Mscorlib.dll if it also installed on your VM. (refer: http://support.microsoft.com/default.aspx?ID=KB;EN-US;Q318785)

regards

Edit: See if this link helps.

[Components]
netfx11 = off

Edited by Geej
Link to comment
Share on other sites

Sorry to hear it didn't work

I have no idea now but just some more suggestion to test:

Download this checker http://www.tmgdevelopment.co.uk/versioncheck.htm to check further

Check if HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP\v1.1.4322 exists even if you have not install 1.1 thru AIO package

Search for Mscorlib.dll if it also installed on your VM. (refer: http://support.microsoft.com/default.aspx?ID=KB;EN-US;Q318785)

regards

Edit: See if this link helps.

[Components]
netfx11 = off

The onepiece that I have been using is 4.6.1. I mistakenly put 4.5.1 in the topic title. as for the components section of winnt.sif, it seems to be ignored by nlite. Kell gave me an entries_removal.ini file to remove some files, and I REMMed out all netfx files... ;netfx11,,7

.net 1.1.4322 installs so does .net40. .net20sp2 and .net35sp1 does not. Neither does Adobe Reader 10.0.1.

much thanks : :blink:

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...