Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
Cloaky

[Q] Windows 7 SP1 and Sony Vaio

Recommended Posts

Well, I got a Sony Vaio from the S series that came with Windows 7 professional installed but I can't install the SP1 on it... any ideas why? It doesn't even show on the Windows Update.

Thanks.

Share this post


Link to post
Share on other sites

check this KB article:

You do not have the option of downloading Windows 7 SP1 when you use Windows Update to check for updates

http://support.microsoft.com/kb/2498452/en-us

Also try to download the Sp1 from the Downloadcenter and run it.

If the Sp1 Installer fails to install the Sp1, please run the Windows Explorer and go to the folder "C:\Windows\Logs\CBS\" and copy all files to your document folder, also copy the setupapi.dev.log from the folder C:\Windows\Inf, the "C:\Windows\WindowsUpdate.log" and the file "C:\Windows\winsxs\poqexec.log" to your document folder (otherwise you can't upload it), zip all files into 1 ZIP and upload the zip to medoafire.com and post a link here.

Share this post


Link to post
Share on other sites

check this KB article:

You do not have the option of downloading Windows 7 SP1 when you use Windows Update to check for updates

http://support.microsoft.com/kb/2498452/en-us

Also try to download the Sp1 from the Downloadcenter and run it.

If the Sp1 Installer fails to install the Sp1, please run the Windows Explorer and go to the folder "C:\Windows\Logs\CBS\" and copy all files to your document folder, also copy the setupapi.dev.log from the folder C:\Windows\Inf, the "C:\Windows\WindowsUpdate.log" and the file "C:\Windows\winsxs\poqexec.log" to your document folder (otherwise you can't upload it), zip all files into 1 ZIP and upload the zip to medoafire.com and post a link here.

Thanks, I guess I found the problem,

Check whether you have Intel integrated graphics driver Igdkmd32.sys or Igdkmd64.sys and whether you upgraded the driver

Windows 7 SP1 will not appear in Windows Update if update 2454826 is not installed. Windows Update will not offer you update KB2454826 if you are using one of the following Intel integrated graphics drivers:

Igdkmd32.sys (32-bit), versions 8.15.10.2104 through 8.15.10.2141

Igdkmd64.sys (64-bit), versions 8.15.10.2104 through 8.15.10.2141

These drivers are known to cause problems with certain applications that use D2D (Direct2D). For example, if you use these drivers together with Windows Live Mail under certain circumstances, Windows Live Mail could crash.

Mine is running version 8.15.10.2141, and sony haven't provided a newest version :(

EDIT: It doesn't show on Sony update, but they have uploaded a newest version into their site, going to try it!

Edited by Cloaky

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...