Jump to content

WinNTSetup v5.3.3


Recommended Posts

Problem was introduced with support for relative paths.
I had not thought that PathIsRelativeW API returns true for an empty string.
So now for some Combo boxes, selection is interpreted as the WinNTSetup directory even is there is no selection.

Link to comment
Share on other sites

WinNTSetup 5.1.0

- fixed global disabling of combobox animation
- fixed vertical alignment of edit controls
- fixed now using rounded button in Win11 Darkmode
- fixed vhd-create commandline option only accepts - not /
- fixed combo could add empty strings and accepts them as valid input
- removed subframe from Darkmode Messagebox in Win11
- added format option to ini and GUI (right click on F button)
- added /help command line option
- added option 'VHD creation, FAT32 Part' boot file creation
- added option 'VHD creation, FAT32 Part' select as boot drive
- added option 'VHD creation, FAT32 Part' assign drive letter
- updated BootICE Darkmode

Link to comment
Share on other sites

  • JFX changed the title to WinNTSetup v5.1.0
  • JFX changed the title to WinNTSetup v5.1.2
  • 2 weeks later...

I have a new system that I installed and tested on Q: I did a backup of the system and restored it to T:
I edited the BCD from the restored image to boot from the T: partition, but the system boot isn't running like it should. It takes forever to get to the desktop and that shows up with a black background. I still need to make additional changes in order for the system start correctly.

Another thing that I tried was to capture the Q: partition and then apply with dism, but that doesn't create a BCD and won't boot. I then tried applying the capture with WinNTSetup and the system booted fine from the new partition. I need to know what other commands WinNTSetup uses to make this work so that I can apply the changes to my restored image without making and applying a capture. I would appreciate some pointers. I think it may have to do with the system having invalid mount points. No sure though.


Edited by click-click
Link to comment
Share on other sites

long loading desktop + black screen seems to be letter mount point swap, Windows has tried to update letter in registry resulting in a corrupt system.

Winntsetup update Mounted Device Letter in registry to force c: to restored partition because current mounted device in current system has q:

You can try to restore registry files (system32\config + ntuser. dat ) then fix mounted device manually 


by the way but that's not your problem, new bcd entry winntsetup use command :

bcdboot letterOfRestoredSystem:\windows /s letterOfBootPartition: /f BIOS

If uefi boot part, replace BIOS by UEFI

Link to comment
Share on other sites

Yeah, the problem is you did not change the system mount point, it's still points to the old drive.
WinNTSetup always set HKLM\SYSTEM\MountedDevices, \DosDevices\C: to avoid this trouble.

You could load offline registry and set this value with the binary data from your current system.

Or just use WinNTSetup without selecting a installation source.

Edited by JFX
Link to comment
Share on other sites

I did manage to manually update HKLM\SYSTEM\MountedDevices with the correct value for c: and the system came up fine.
Thanks for mentioning leaving out the installation source. Great stuff. I either forgot :lol: or didn't realize you could use WinNTSetup                           without specifying an image.  :thumbup

Guten Rutch und ein frohes neues Jahr ....

Edited by click-click
Link to comment
Share on other sites

Is there an x86 version of this? I want to run it on my old 32-bit laptop to apply LTSC to a different partition, it has problems booting Windows normally and somehow I got 1903 working on it 3 years ago.

Link to comment
Share on other sites

A friend of mine asked me to do the setup of a new Lenovo E15 Gen 3 Laptop and I wanted to do a backup of the original system
before doing anything. I have a bootable usb recovery flash drive where I installed W10 10 LTSB 32-bit in a vhd with WinNTSetup
and I don't have any problems booting it from My lenovo L460 where I have legacy CSM enabled.

The E15 is pure UEFI and when I select my flash from the F12-boot menu, it ignores the Ultra Flash and won't even start booting it.
I tried turning off secure boot, but that did not help. The partition on the flash is set active. Since I'm not familiar with UEFI,
I need some pointers on what needs to be done to make the flash bootable on the E15. Thanks for any help.

I edited  the G:\EFI\Microsoft\Boot\BCD, but that did not help either ?


Edited by click-click
Link to comment
Share on other sites

  • JFX changed the title to WinNTSetup v5.3.3
  • wimb featured this topic

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...