Jump to content
MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. ×

WinNTSetup v5.0.2


JFX
 Share

Recommended Posts

Abbodi1406, nice to see you around...

Let's not get into the image.exe timings anymore. I think the point is clear: Imagex.exe was almost "forgotten", but as Abbodi1406 found out, it can be useful for direct apply of UUP files, and fast as well, for some people (with old hardware/ disks?) even faster than the mighty WinNTSetup.

If people are concerned with/ interested in this time difference, I'm sure they will try it themselves. That's it.

  • Like 1
  • Upvote 1
Link to comment
Share on other sites


-From Google translate-

From version 3.8.8.* I install Windows from LiveXP or Live7 and at the very end of installation the error message is displayed. She repeats on 2 times everyone. But all the same installation is carried out correctly. Why it can be?

"The application or library *** isn't image of the program for Windows NT. Check purpose of an adjusting disk."

20171122_145625.jpg

20171122_145639.jpg

Edited by Scampy82
Link to comment
Share on other sites

The message is repeated two times because it is related to two files:

bootstx.dll

bootstx.dll.mui

Most probably (for whatever reasons and whatever those files are) they are compiled for an earlier version of the OS.

This would make sense for LiveXP (as most programs are now compiled for MajorVersion 6 and Minor version 6.1 or 6.2 and anyway XP doesn't uses .mui files) but that shouldn't apply to a 7 based PE. :unsure: , unless somehow a later (10) version is in use?

jaclaz

 

 

Link to comment
Share on other sites

8 hours ago, jaclaz said:

The message is repeated two times because it is related to two files:

You can be right. But from the same assembly of LiveXP but in the WiNTSetup version 3.7.*.* such mistakes weren't

On 7 based PE I didn't check. But I will surely try

Edited by Scampy82
Link to comment
Share on other sites

1 hour ago, JFX said:

XP support is hard to maintain and so it get's often broken.

I soon will remove it completely.

Tu quoque ... :w00t: :ph34r:

jaclaz

Seriously, as long as an "old" version working with XP remains available that would be just fine :), after all it is not like new, strange ways were added (for XP) in the last several releases,

Link to comment
Share on other sites

  • 4 weeks later...

JFX, as you're the biggest imagex (and wimgapi) experts I know, I wonder if you could shed any light on this:

- I downloaded the new 17063 preview UUP files yesterday, installing them with WinNTSetup worked just fine (that's unconverted UUP files, so .esd and .cab, 33 files).

To repeat my imagex speed comparison test, I also tried to apply using imagex:

Q:\WinNTSetup\Tools\x86\DISM\imagex.exe /apply g:\Professional_nl-nl.esd 3 c: /ref g:\*.*

This worked fine with the previous preview, so I already included in some test batches. With the latest preview however, I get this error:

[   8% ] Applying progress: 10:46 mins remaining
[ RETRY ] Restoring c:\Windows\InfusedApps\Frameworks\Microsoft.NET.Native.Frame
work.1.6_1.6.24903.0_x86__8wekyb3d8bbwe\AppxMetadata\CodeIntegrity.cat again (Er
ror = 1784)

[ ERROR ] c:\Windows\InfusedApps\Frameworks\Microsoft.NET.Native.Framework.1.6_1
.6.24903.0_x86__8wekyb3d8bbwe\AppxMetadata\CodeIntegrity.cat (Error = 1784)

Error restoring image.

The supplied user buffer is not valid for the requested operation.

Do you have any idea what's going on here, why would imagex fail where wimgapi works? I

Link to comment
Share on other sites

Thank you for your reply. I'm using the version from the WinNTSetup tools folder (downloaded by WinNTSetup). It is indeed the 16299 version.

I will try to find the 15063 version, can't remember now how to get it :-) (Will try).

So you say 16299 has a bug, which bug is that? I find it strange that the previous previews applied fine, but not this one. Does it sound to be related to the bug you found?

PS: Would the 15063 version have the same UUP file apply capabilities (will test if/when I find it).

Edited by Atari800XL
Link to comment
Share on other sites

Thanks, that did the trick! :thumbup

Still very strange that the error didn't play up for me until now, sorry again for not remembering your errors (but it must have been in the back of my mind, that's why I came straight back to "the master" to ask! <g>) Thanks for the link to the previous versions, will save it!

 

 

Link to comment
Share on other sites

  • 4 weeks later...
  • JFX changed the title to WinNTSetup v5.0.2

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...