Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


JFX

WinNTSetup v3.9.4 / 4.0 RC1

Recommended Posts


On 8/17/2019 at 10:59 AM, wimb said:

Also the program WinNTSetup crashes when a wrong type of wim file like boot.wim is selected.
May be for the unexperienced user it is good to give WARNING - This WIM file is Not Valid as Installation file

Selecting a wrong type of wim file should be refused by the program.

Now boot.wim can be selected as installation file and then pressing Setup results in program crash.

Share this post


Link to post
Share on other sites

Windows Defender false detection WinNTSetup_x86.exe ->[RSRCEmb] Trojan:Win32/Zpevdo.B   (Beta 2 & Beta 3 of version 4 )

Edited by Sonic

Share this post


Link to post
Share on other sites

On my system , cpu is intel Core i5-9600k ( 6 cores without hyperthreading ) WinNTSetup use x3 active cores, is normal ?

Share this post


Link to post
Share on other sites

Version 4 uses half of your CPUs physical cores, which seems the be the best trade off.
Using all cores would make the system unusable and it's unlikely that the destination drive is fast enough to actually write all the data in time.

@wimb
I can't really spot the cause, it never happens with debugger on, so I hope Beta 4 now fixes this bug.

 

Share this post


Link to post
Share on other sites

Hi, Sergei.

same place, Tools\Win10Builds.ini.
You can edit the ini file to your liking.

Share this post


Link to post
Share on other sites

Wrong type of wim file like boot.wim gives now when pressing Setup - Warning Windows Source invalid
So the crash is gone and this solution is OK.

There is another problem present in 4.0 Beta3 and Beta4
In case wimlib is used and Mode Wimboot Selected then After pressing Setup the program crashes.
Using WimGAPI (all cases) Or wimlib with Mode Wimboot Unchecked Or other Mode are working OK.

In version 4.0 Beta1 and Beta2 this problem did not yet occur.
 

Edited by wimb

Share this post


Link to post
Share on other sites

Thanks, reuploaded Beta4 with Italian Translation and a crash fix.

  • Like 1

Share this post


Link to post
Share on other sites

Thanks, Crash Fix of WinNTSetup4 Beta 4 is working OK  :thumbup

Share this post


Link to post
Share on other sites

ok for cpu , I was thinking about wrong hyper threading detection ...

I've just tried the restore system of a Microsoft Surface 3 (Win10 v1511) 4 files with format *.swm ; directly downloader from Microsoft.
WinNTSetup seems apply first swm then error -> Error Applying System image failed! 0x6: Descripteur non valide 
even with wimlib.dll

If i apply with dism or WinNTSetup3.9.4 , there isn't error.

Edited by Sonic

Share this post


Link to post
Share on other sites

Hmm, this error is properly caused by the multi core decompression used in beta 4.
You can disable it in the ini with. 

[Options]
UseMultiCore=0

Can you send me the links for these *swm?

Share this post


Link to post
Share on other sites

it's working fine disabling multicore

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...