Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


JFX

WinNTSetup v3.9.4 / 4.0 Beta 2

Recommended Posts

I noticed that when you create a VHD with WinNTSetup, it does a full format which takes forever using a USB flash drive. Is it also possible to do a quick format when using the VHD create option?

 

Edited by click-click

Share this post


Link to post
Share on other sites

 

@JFX Do you use diskpart from WinNTSetup when creating a VHD with the instant creation option?

When I run diskpart create vdisk file="d:\Win2Go ltsb.vhd" maximum=16384

it takes longer than the  instant creation option via WinNTSetup although both VHDs seem to have the

same properties and size. What commands do you use with the instant creation option?

Thanks for any infos...

 

 

Edited by click-click

Share this post


Link to post
Share on other sites

I create the VHD manually and diskpart only to create the partition in this case.

If you curious search for vhdtool and vhdxtool.

 

Share this post


Link to post
Share on other sites

Thanks, I did stumble upon vhdtool and this is what I ended up doing to clone the WinNTSetup VHD creation
because I need a different volume label than what WinNTSetup sets. Are these the correct commands to use?

Also, do you know where I can find the vhdtool that includes the /repair option. I haven't been able to find it yet.
 

vhdtool /create <filename> <size> /quiet
select vdisk
attach vdisk
automount disable
attributes disk clear readonly
create partition primary
online volume
attributes volume clear readonly
Active
format
assign
Edited by click-click

Share this post


Link to post
Share on other sites

Oh boy, I did not realize some of this stuff could be done from the command line. I never thought of using F1 from the GUI. :rolleyes:

Thanks for the link and the command line pointer. That is better and easier for me.

Share this post


Link to post
Share on other sites

I have a weird error. I am still running 3.8.9 and decided to upgrade to the 3.9.2. I have been starting 3.8.9 from a cmd file for months no problem. I deleted the 3.8.9 files out of the folder and copied in the 3.9.2 and didn't change nothing else and the 3.9.2 will not start from the same cmd line that has worked for months. This is the cmd line that I am using but this has me puzzled. I can double click on the 3.9.2.exe and the program runs fine.

 

WinNTSetup_x64.exe NT6 /Runafter:%LaddsUSB%\WINSETUP\%Folder%\Copy.cmd /cfg:"%LaddsUSB%\WINSETUP\%Folder%\%INI%" /setup

Never mind, figured it out. I didn't have libwim-15.dll copied into the new 3.9.2 tools folder as I have that set in my ini.

Edited by laddanator

Share this post


Link to post
Share on other sites
On 10/2/2018 at 10:50 PM, JFX said:

Hi mnogo999,

the "Turn off USB Device after safe remove" tweak is only using the 
DisableOnSoftRemove REG_DWORD you mentioned.

JFX, thanks!

Share this post


Link to post
Share on other sites

@JFX what command are you using to update the boot record with bootsect and bcdboot when ALL is selected? Are these the commands?

 

bootsect /nt60 C: /force
bcdboot C:\windows /s C: /f UEFI

 

Share this post


Link to post
Share on other sites

It are 2 separate combo boxes, when you set ALL you mean this command.

bcdboot C:\windows /s C: /f ALL

 

Share this post


Link to post
Share on other sites

При установке из образа, сделанного с Windows 10 1809 пишет, что образ повреждён. Можно поправить?

When installing from an image made with Windows 10 1809 program writes that the image is damaged. Could you fix it?

Screenshot_16.png

Edited by Lara Ban

Share this post


Link to post
Share on other sites

It does not have the needed xml information and not even my fix for that seems to be working for this image.

How did you made this WIM file :huh: 

Share this post


Link to post
Share on other sites

I made image by Gimagex 2.1.1 and 2.2.0, the result is the same. And this image successfully opened in DISM.

Edited by Lara Ban

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...