Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Brabant

Install 2000 from USB CD to Sata HD

Recommended Posts

[HardwareIdsDatabase]
PCI\VEN_1106&DEV_4149 = "viapdsk", "VIA ATA/ATAPI Host Controller"

Yes that line came free with storage.ini. It doesn't do anything.

(I do have PCI\VEN_1106&DEV_0571 (ata controller) in the registry. But that has installed correctly from IDE cd, without adding any files or ini entries.)

Other way is to use your source without any 3rd party mass storage drivers integrated and put BTS mass storage drivers, eventually with the modified NTDETECT.COM. I'd try that first.

I read your post and thought that trying Mass Storage would be best. Install fails with a corrupted ahcix86.sys. There seems to be one in AM2 and one in AM3. The one that ends up in i386 can be copied and expanded manually.

Edited by Brabant

Share this post


Link to post
Share on other sites

Oh look! What a coincidence, I had noticed the line: ms_1_exc_disableIfOS="w2k" for PCI\VEN_1106&DEV_0571. So it wasn't a surprise that should install (and has installed) without extra files.

I don't like to add 10000 files just for the few that are (possibly) useful. So I'm gonna try editing the ini in the Mass Storage 7z. Maybe delete unused directories as well.

If that doesn't work I'll have to add ms_1_exc_disableIfOS="w2k" lines.

Edit: I just found the nightlies (since they're mentioned in one thread you linked to)

http://driverpacks.sytes.net/driverpacks/Nightlies/NT5/

Edited by Brabant

Share this post


Link to post
Share on other sites

Removing ms_1_exc_disableIfOS="w2k" from [V] gives a corrupted viamraid.sys. I guess I need to remove stuff from the HardwareIdsDatabase and/or other sections. Or maybe make the mass storage zip only contain the Via dirs. Do you have any suggestions?

Share this post


Link to post
Share on other sites

Maybe remove all other sections from the ini file and dirs from the archive except VIA stuff?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...