Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 

Recommended Posts

@midiboy First start WPI (this will create all missing files) - after that you can copy it to a network-share (now you can run WPI from network share without write-permissions).

Do you guys want me to include "empty" default files for config.js, ueroptions.js,and networkoptions.js so this issue does on happen? You would still copy your previous version files over them. At least with the defaults already there,it could be run right out the box with no need for writing files.

Hi guys,

thanks, that worked. Yeah, maybe it would be a good idea to have empty files there by default. It´s no problem if people know to start WPI first but sometimes we might forget :-)

Bye,

Alex

Share this post


Link to post
Share on other sites

I think it's better to NOT include empty config-files.

Without these empty config-files I can download a new archive and extract it over my current WPI-installation and all it's fine.

With these empty config-files download the archive and have to extract it manually if I don't want to override my config-files.

In my opinion there is no need to change the current behavior.

But I some people don't like this it would be better to initialize the config internaly with default-values and after that try to load the config files - if they exist override the default-values.

Al

Share this post


Link to post
Share on other sites

@Midiboy and everyone:

Do you guys want me to include "empty" default files for config.js, ueroptions.js,and networkoptions.js so this issue does on happen? You would still copy your previous version files over them. At least with the defaults already there,it could be run right out the box with no need for writing files.

If this is a big enough problem to warrant any action I would agree with AlBundy33's suggestion of having default values either in the code or in separate configs (ie. useroptions_defaults.js) and load those values only if the standard configs haven't been written yet. As this would help prevent users accidentally or not knowingly overwrite their configs.

Edited by xure

Share this post


Link to post
Share on other sites

Good points. There are built in defaults, obviously, that will/could be used. It may just be easier to not save a default file if doesn't exist. They don't have to be there, it's just nice to see something there.

Share this post


Link to post
Share on other sites

I have added this bug once before it have been there since v7. Tho it has not been fixed?.

Everytime i start up wpi from the exe or hta, and i go to "options" This message appears.

Im running windows 7 64 Danish, and Danish keyboard layout tho im using wpi in english as i want it.

This appears in modified and clean version of wpi's

Share this post


Link to post
Share on other sites

I have added this bug once before it have been there since v7. Tho it has not been fixed?.

Everytime i start up wpi from the exe or hta, and i go to "options" This message appears.

Im running windows 7 64 Danish, and Danish keyboard layout tho im using wpi in english as i want it.

This appears in modified and clean version of wpi's

I too have noticed this message, since it started appearing in 8.0.0 (for me). In my case it is for the Swedish language rather than Danish. I was going to report it after I had updated the translation file as well but since you mentioned it I might as well confirm it.

The reason for the error is that WPI checks for different locale letters than what the files are named. For Swedish this means that WPI looks for 'sv' but the translation file is named 'se' and for danish the file is named 'dk' and I would guess that it is searching for 'da' (not tested). To solve this rename the file accordingly, you also need to change the 'lang' variable in the first row of the file.

Edited by xure

Share this post


Link to post
Share on other sites

I don't know about that, xure. I would assume a line is missing from the lang file. Since translators tend to take my comment lines out, I can't do an easy side-by-side comparison. It drives me nuts some times.

ISO 639-2 has Swedish as se, Danish as da. (http://www.loc.gov/standards/iso639-2/php/code_list.php)

ISO 639-1 has Swedish as sv, Danish as da. (http://www.science.co.il/language/Codes.asp?s=code2)

WHich is correct?

My codes match what is picked from the combobox, so not a bad filename issue.

Share this post


Link to post
Share on other sites

I have added this bug once before it have been there since v7. Tho it has not been fixed?.

Everytime i start up wpi from the exe or hta, and i go to "options" This message appears.

Im running windows 7 64 Danish, and Danish keyboard layout tho im using wpi in english as i want it.

This appears in modified and clean version of wpi's

I too have noticed this message, since it started appearing in 8.0.0 (for me). In my case it is for the Swedish language rather than Danish. I was going to report it after I had updated the translation file as well but since you mentioned it I might as well confirm it.

The reason for the error is that WPI checks for different locale letters than what the files are named. For Swedish this means that WPI looks for 'sv' but the translation file is named 'se' and for danish the file is named 'dk' and I would guess that it is searching for 'da' (not tested). To solve this rename the file accordingly, you also need to change the 'lang' variable in the first row of the file.

Thanks it worked!! Great finally!, were getting tired of it :S

I don't know about that, xure. I would assume a line is missing from the lang file. Since translators tend to take my comment lines out, I can't do an easy side-by-side comparison. It drives me nuts some times.

ISO 639-2 has Swedish as se, Danish as da. (http://www.loc.gov/standards/iso639-2/php/code_list.php)

ISO 639-1 has Swedish as sv, Danish as da. (http://www.science.co.il/language/Codes.asp?s=code2)

WHich is correct?

My codes match what is picked from the combobox, so not a bad filename issue.

I can confirm that it has to be da instead of da and also need to edit it in the file to da.

I have edited the file and renamed it nothing else.

Share this post


Link to post
Share on other sites

Okay i dont know what happend, now it says its not a language file when im trying to select danish, just to test :S. But the message when pressing options does not appear anymore.

Share this post


Link to post
Share on other sites

I don't know about that, xure. I would assume a line is missing from the lang file. Since translators tend to take my comment lines out, I can't do an easy side-by-side comparison. It drives me nuts some times.

ISO 639-2 has Swedish as se, Danish as da. (http://www.loc.gov/standards/iso639-2/php/code_list.php)

ISO 639-1 has Swedish as sv, Danish as da. (http://www.science.co.il/language/Codes.asp?s=code2)

WHich is correct?

My codes match what is picked from the combobox, so not a bad filename issue.

Okay i dont know what happend, now it says its not a language file when im trying to select danish, just to test :S. But the message when pressing options does not appear anymore.

Yeah... I didn't really check the code or test extensively since I was not going to report this yet. However after some minor testing it seems the error message comes from WPI detecting my system uses Swedish and recognizes it using ISO 639-1 (sv). So adding a file with those values will make the error go away (as it then knows there is a language file available). However when selecting and loading a language ISO 3166-1 (se) is used. At least that is how it seems to work, but I'm sure mritter could tell us if I got it wrong.

I do believe that this is the likely issue since just duplicating the same file using both ISO standards removes the error as well as makes the translation be selectable as normal. Therefore I don't believe there is a case of missing lines or something similar.

btw mritter: have you tried any graphical diff utilities for comparing files like WinMerge for Windows or Meld for linux? I would highly recommend both of them.

EDIT: Man, I got confused there for a while 639-2 is the 3 letter language code, 3166-1 is the country code (se)

Edited by xure

Share this post


Link to post
Share on other sites

hi.

1@;I can't see the percentages% in the installation bar

2@;Sound does not work.

3@;And if i choice Dependent of:i can make 1 program thats work oke with that.

But if I choice 2 program's then selecten program's doesend work no more.

Example;officesmall/officebig <------------>Choice;officeupdate1/office update2/officeupdate3

If I do; Officesmall -----------> Choice;officeupdate1/office update2/officeupdate3 it works wel!!

But I do this;officesmall/officebig --------> Choice;officeupdate1/office update2/officeupdate3

I could then click on what I want but it respond no more.. Choice;officeupdate1/office update2/officeupdate3 FAIL!!!!

sorry for bad english..bye

OS;XpProSp3 and wpi 8.0.1

Edited by Whatsup

Share this post


Link to post
Share on other sites

@Whatsup:

1) go into your selected theme folder and edit: wpi_theme.js. At the end of the file is this line:

ShowPercentValue=false;

2)Fixed.

3) It works for me. I do hope you are using the combobox to pick the entries and not removing the commas between entries.

Share this post


Link to post
Share on other sites

@Whatsup:

1) go into your selected theme folder and edit: wpi_theme.js. At the end of the file is this line:

ShowPercentValue=false;

2)Fixed.

3) It works for me. I do hope you are using the combobox to pick the entries and not removing the commas between entries.

Hé thanks for the response.

1@Thx

2@thx again

3@;I am looking at.

But can't do it today.

whether it works or not.

you hear it as soon as possible.

Thx a lot..bye

Share this post


Link to post
Share on other sites

I am receiving this script error as seen in the screen capture and a few more saying the same thing. The WPI scripts having this error are windowoptions.js,configwizard.js, and useroptions.js. I am running XP Pro (SP3) x86. Any ideas as how to fix this or is it even a big problem? Thanks

post-293645-127497003375_thumb.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×