Jump to content

Windows XP SVCPACK.INF : Several failure


 Share

Recommended Posts

Hi,

SVCPACK.INF still failed to install silently .NET 1.1, .NET 3.5 SP1, IE8, Compatibility View list update and Windows Update Agent

I don't know if Update for root certificates and Browser choice update are installed, QFECHECK don't find them.

Please, help !

This is my SVCPACK.INF

[Version]
Signature="$WINDOWS NT$"
MajorVersion=5
MinorVersion=1
BuildNumber=2600

[SetupData]
CatalogSubDir="\I386\svcpack"

[ProductCatalogsToInstall]
basecsp.cat
KB898461.cat
KB943729.cat
KB952011.cat
KB952013.cat
KB955704.cat
KB971513.cat
KB976002.cat
KB980302.cat

[SetupHotfixesToRun]
Q282784.exe -q -n -z
REG DELETE HKLM\Software\Microsoft\PCHealth\ErrorReporting\DW /f
REG ADD HKLM\SYSTEM\Setup /v SystemSetupInProgress /t REG_DWORD /d 0 /f
dotnetfx.exe /Q /C:"install.exe /Q"
KB867460.exe /Q
REG ADD HKLM\SYSTEM\Setup /v SystemSetupInProgress /t REG_DWORD /d 1 /f
KB898461.exe /q /n /z
KB909520.exe /q /n /z
KB925850.exe /Q:A /R:N
KB931125.exe /Q:A /R:N
START /WAIT msiexec /qb /update KB953297.msp
KB943729.exe /q /n /z
KB944036.exe /quiet /norestart /update-no /no-default
KB949104.exe /wuforce /quiet /norestart
REG ADD HKLM\SYSTEM\Setup /v SystemSetupInProgress /t REG_DWORD /d 0 /f
KB951847.exe /qb /norestart
REG ADD HKLM\SYSTEM\Setup /v SystemSetupInProgress /t REG_DWORD /d 1 /f
REG ADD HKLM\Software\Microsoft\PCHealth\ErrorReporting\DW /f
KB952011.exe /q /n /z
KB952013.exe /q /n /z
KB955704.exe /q /n /z
KB971513.exe /q /n /z
KB976002.exe /q /n /z
KB979202.exe /q
KB980302.exe /q /n /z
qchain.exe

[CatalogHeader]

Q282784.exe : QFECHECK - installed

dotnetfx.exe : .NET 1.1 - Fail to run silent mode. User mode is display.

KB867460.exe : .NET 1.1 SP1 - Not installed

KB898461.exe : installed

KB909520.exe : installed

KB925850.exe : WMP 11 - installed

KB931125.exe : Update for root certificates - ???

KB953297.msp : .NET 1.1 SP1 Update - Not installed

KB943729.exe : Group Policy Preference Client Side Extensions for Windows XP - installed

KB944036.exe : IE8 - installed but failure Error in: C:\WINDOWS\SYSTEM32\iedkcs32.dll Entry Missing: BrandIEActiveSetup

KB949104.exe : Windows Update Agent - Not installed

KB951847.exe : .NET 3.5 SP1 - Not installed

KB952011.exe : Windows Feature Pack for Storage 1.0, IMAPIv2.0 - installed

KB952013.exe : Windows Feature Pack for Storage 1.0, ICCD - installed

KB955704.exe : exFAT - installed

KB971513.exe : Windows Automation API - installed

KB976002.exe : Browser choice update - ???

KB979202.exe : Silverlight 4.0 - installed

KB980302.exe : Compatibility View list update - Not installed

Edited by Se7enIs6
Link to comment
Share on other sites


Hi,

I'm installing the IE8 and WMP11 at the beginning of my "SVCPACK.INF" and it's working very fine for me:

[Version] 
Signature="$Windows NT$"
MajorVersion=5
MinorVersion=1
BuildNumber=2600

[SetupData]
CatalogSubDir="\i386\SVCPACK"

[ProductCatalogsToInstall]

[SetupHotfixesToRun]
"WMP11.exe /Q:A /R:N /c:""SETUP_WM.EXE /Q /R:N /NoPID /DisallowSystemRestore /P: #e"""
"IE8.exe /quiet /update-no /no-default /norestart"
"KB890830.exe /Q /O /N /Z"
"KB898461.exe /Q /O /N /Z"
"KB923789.exe /Q:A /R:N"
"KB929399.exe /Q /O /N /Z"
"KB936782.exe /Q /O /N /Z"
"KB938464.exe /Q /O /N /Z"
"KB939683.exe /Q /O /N /Z"
"KB941569.exe /Q /O /N /Z"
"KB946648.exe /Q /O /N /Z"
"KB950760.exe /Q /O /N /Z"
"KB950762.exe /Q /O /N /Z"
"KB950974.exe /Q /O /N /Z"
"KB951066.exe /Q /O /N /Z"
"KB951376.exe /Q /O /N /Z"
"KB951748.exe /Q /O /N /Z"
"KB951978.exe /Q /O /N /Z"
"KB952004.exe /Q /O /N /Z"
"KB952069.exe /Q /O /N /Z"
"KB952287.exe /Q /O /N /Z"
"KB952954.exe /Q /O /N /Z"
"KB954154.exe /Q /O /N /Z"
"KB954155.exe /Q /O /N /Z"
"KB954459.exe /Q /O /N /Z"
"KB954600.exe /Q /O /N /Z"
"KB955069.exe /Q /O /N /Z"
"KB955759.exe /Q /O /N /Z"
"KB955839.exe /Q /O /N /Z"
"KB956572.exe /Q /O /N /Z"
"KB956744.exe /Q /O /N /Z"
"KB956802.exe /Q /O /N /Z"
"KB956803.exe /Q /O /N /Z"
"KB956844.exe /Q /O /N /Z"
"KB957097.exe /Q /O /N /Z"
"KB958644.exe /Q /O /N /Z"
"KB958687.exe /Q /O /N /Z"
"KB958869.exe /Q /O /N /Z"
"KB959426.exe /Q /O /N /Z"
"KB959772.exe /Q /O /N /Z"
"KB960225.exe /Q /O /N /Z"
"KB960803.exe /Q /O /N /Z"
"KB960859.exe /Q /O /N /Z"
"KB961371.exe /Q /O /N /Z"
"KB961373.exe /Q /O /N /Z"
"KB961501.exe /Q /O /N /Z"
"KB967715.exe /Q /O /N /Z"
"KB968389.exe /Q /O /N /Z"
"KB968537.exe /Q /O /N /Z"
"KB968816.exe /Q /O /N /Z"
"KB969059.exe /Q /O /N /Z"
"KB969897.exe /Q /O /N /Z"
"KB969898.exe /Q /O /N /Z"
"KB969947.exe /Q /O /N /Z"
"KB970238.exe /Q /O /N /Z"
"KB970430.exe /Q /O /N /Z"
"KB970653.exe /Q /O /N /Z"
"KB971468.exe /Q /O /N /Z"
"KB971486.exe /Q /O /N /Z"
"KB971557.exe /Q /O /N /Z"
"KB971633.exe /Q /O /N /Z"
"KB971657.exe /Q /O /N /Z"
"KB971737.exe /Q /O /N /Z"
"KB971961.exe /Q /O /N /Z"
"KB972270.exe /Q /O /N /Z"
"KB973346.exe /Q /O /N /Z"
"KB973354.exe /Q /O /N /Z"
"KB973507.exe /Q /O /N /Z"
"KB973525.exe /Q /O /N /Z"
"KB973540.exe /Q /O /N /Z"
"KB973687.exe /Q /O /N /Z"
"KB973815.exe /Q /O /N /Z"
"KB973869.exe /Q /O /N /Z"
"KB973904.exe /Q /O /N /Z"
"KB974112.exe /Q /O /N /Z"
"KB974318.exe /Q /O /N /Z"
"KB974392.exe /Q /O /N /Z"
"KB974417.exe /Q:A /R:N"
"KB974455.exe /Q /O /N /Z"
"KB974571.exe /Q /O /N /Z"
"KB975025.exe /Q /O /N /Z"
"KB975467.exe /Q /O /N /Z"
"KB975560.exe /Q /O /N /Z"
"KB975561.exe /Q /O /N /Z"
"KB975713.exe /Q /O /N /Z"
"KB976662.exe /Q /O /N /Z"
"KB977165.exe /Q /O /N /Z"
"KB977816.exe /Q /O /N /Z"
"KB977914.exe /Q /O /N /Z"
"KB978037.exe /Q /O /N /Z"
"KB978207.exe /Q /O /N /Z"
"KB978251.exe /Q /O /N /Z"
"KB978262.exe /Q /O /N /Z"
"KB978338.exe /Q /O /N /Z"
"KB978601.exe /Q /O /N /Z"
"KB979306.exe /Q /O /N /Z"
"KB979309.exe /Q /O /N /Z"
"KB979683.exe /Q /O /N /Z"
"KB980182.exe /Q /O /N /Z"
"KB980232.exe /Q /O /N /Z"
"KB981332.exe /Q /O /N /Z"
"qchain.exe"

Link to comment
Share on other sites

IE8 and .NET 3.5 SP1 installs still fail in CMDLINES.TXT but Windows Update Agent and .NET 1.1 installs work.

Maybe I should try to install them first like you did.

Edited by Se7enIs6
Link to comment
Share on other sites

Note:

I'm installing IE8 etc. in the "SVCPACK.INF" not in "CMDLINES.TXT" :yes:

Just post here when you've tested it.

Edited by HØLLØW
Link to comment
Share on other sites

  • 2 weeks later...

Hey Hollow not to hijack this thread but,,

I 've been trying like mad to get my hotfixes installed on Windows XP Pro SP1 through "svcpack.inf" and i can't figure it out. I noticed your using quotes around all the hotfixes in you "svcpack.inf" file. I wasn't using quotes and i've haven't seen any reference to it anywhere. Are quotes supposed to be used for installing through "svcpack.inf". Or do you know if it matters? I've been working on this unattended disk for months now.....

Thanks

Chris

EDITED: I'm going to give it a try right now anyways ... I'll Check back,..

Edited by chrisoborski
Link to comment
Share on other sites

I tried install first IE8 in SVCPACK.INF but it still failed.

I'll try to install IE8 and .NET 3.5 while the GuiRunonce with Windows Search, WGA Notification and Windows Defender.

Link to comment
Share on other sites

Worked!!!!

Hey chrisoborski,

just used quotes now and it worked?

In the past, I also used no quotes in my "SVCPACK.INF", but there was a reference at Microsoft or somewhere with the quotes. ;)

Link to comment
Share on other sites

Worked!!!!

Hey chrisoborski,

just used quotes now and it worked?

In the past, I also used no quotes in my "SVCPACK.INF", but there was a reference at Microsoft or somewhere with the quotes. ;)

Yes!! It worked

I've been trying to get hotfixes/updates to install for at least two months maybe longer. I added quotes like your "svcpack.inf" and i also added two spaces at the end of the "svcpack.inf" file. Somewhere within the past few days i remember reading that a space at the end of the file was needed but i cant remember where i saw that so i added both quotes and two spaces and viola it installed. I'm Completely amazed!!

Thanks that's just what i needed!!

Chris

Link to comment
Share on other sites

Worked!!!!

Hey chrisoborski,

just used quotes now and it worked?

In the past, I also used no quotes in my "SVCPACK.INF", but there was a reference at Microsoft or somewhere with the quotes. ;)

Yes!! It worked

I've been trying to get hotfixes/updates to install for at least two months maybe longer. I added quotes like your "svcpack.inf" and i also added two spaces at the end of the "svcpack.inf" file. Somewhere within the past few days i remember reading that a space at the end of the file was needed but i cant remember where i saw that so i added both quotes and two spaces and viola it installed. I'm Completely amazed!!

Thanks that's just what i needed!!

Chris

That is so bizzarre. I don't have quotes around anything except the path to the SVCPACK directory and "$Windows NT$", but my SVCPACK.INF worked fine. However, in WINNT.SIF, I had to quote the URL for Home_Page. That's another file I've seen quotes and no quotes. (Even in the "ref.chm" help, the use of quotes is not consistent!) Maybe quote requirements are very particular to the exact version of some tool or dependency of a tool...like how compilers can affect a program even though there was no error in syntax based on the language standards. Useful to know!

Link to comment
Share on other sites

IE8 and .NET 3.5 SP1 installs still fail in CMDLINES.TXT but Windows Update Agent and .NET 1.1 installs work.

Maybe I should try to install them first like you did.

If neither that nor the GuiRunOnce works, maybe try what was suggested here:

I'm going to try the "net stop" as well (I had a permissions error with .NET 2.0). If that doesn't work, maybe it's the order of something else happening in the system. I also wonder, can the "slipstream" method be used for something like this? Or is that only for service packs?

Did you get your .NET 3.5 to install yet?

Link to comment
Share on other sites

That is so bizzarre. I don't have quotes around anything except the path to the SVCPACK directory and "$Windows NT$", but my SVCPACK.INF worked fine. However, in WINNT.SIF, I had to quote the URL for Home_Page. That's another file I've seen quotes and no quotes. (Even in the "ref.chm" help, the use of quotes is not consistent!) Maybe quote requirements are very particular to the exact version of some tool or dependency of a tool...like how compilers can affect a program even though there was no error in syntax based on the language standards. Useful to know!

Well its like when you export a registry setting if you open it up in notepad you'll notice there's always two spaces after the last entry. I've never had a problem when i didn't add two spaces at the end but since i noticed that i always add two spaces at the end of my reg files just in case. Like for example if i was to silently install a bunch of tweaks during an unattended install i'd like to be 100% about them installing or not.. I don't want any errors.

That's just what i do but from now on i'm adding a space and using quotes for "svcpack.inf" and any others that i suspect might be affected... I'll be very carefull in the future...

(Somehow my quotes got messed up/couldn't fix it. That was a reply to JustShootIt's Message)

.

Edited by chrisoborski
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...