Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
lansing

Slave drive disappeared after a windows optional update

Recommended Posts

Recently my Windows was unable to detect my slave drive, and the most recent event I can recall was installing of an optional update for Windows call "ITE IT8211 ATA/ATAPI Controller". My slave drive is working fine on another computer, and bios is able to detect it on boot up, but only it didn't shows up in Windows. And I couldn't find the way to uninstall that update, what can I do?

Share this post


Link to post
Share on other sites

Go in device manager, find the said "ITE IT8211 ATA/ATAPI Controller", double click on it, pick the "Driver" tab, and make use of the "Roll Back Driver" button.

Share this post


Link to post
Share on other sites

It works! I'm so relief now, haha. Thanks for the help CoffeeFiend.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...