Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


bensam56

RT Seven Lite - RC build 1.7.0 and Beta build 2.6.0

Recommended Posts

clpdj

Hey man... It seems that all Volume (and probably OEM) editions of W7 get messed up when processed by vLite (and probably by any other program alike). At least that's my personal experience with W7 Pro VL and W7 Enterprise VL and vLite. Any Retail version seems to be working out just fine. But I just might be wrong. Correct me someone if I am... Hope that helps...

AFAIK, Ultimate works with vLite. But I bought an OEM Home Premium edition of W7, and Vlite only messed it up. IMHO, vLite is obsolete, with RT7 largely stable and more feature rich than vLite.

Edited by Bilar Crais

Share this post


Link to post
Share on other sites

Removing Indexing Service, without breaking Startmenu search

Can it be added to the program to be able to remove the Indexing service but keep the start menu search feature ??

It was possible with some of the ealier methods eg the guide by Liquid0624

In RT lite under services removal...

If you select "windows search" for removal it removes the SearchEngine-Client-Package which is the start menu search.

The indexing service is a package called Indexing-Service-Package which would be noce to be able to remove, but keeping the above feature intact.

Possible ???

Share this post


Link to post
Share on other sites

I'm sorry... But WTF is this? I launch this app on a just installed MSDN W7Pro x64 Eng (WAIK W7 installed too) and all I get is the error. Tried several times, reinstalling host W7...

And why do you specify the .Net Framework 3.5 as a pre-requisite for W7 if it's a part of any W7 already?!!! At the same time it looks like some other required files that aren't there by default are not mentioned. Look into this please.

So, once again, to clear things up: I just installed my W7 Pro x64, installed WAIK for W7, installed RT Seven Lite. I start it.

1) I get a "WAIK installation" window, suggesting me to DL and install the WAIK, which is already installed. If I press "OK" it's exiting. If I close this window I get

2) the error:

See the end of this message for details on invoking 
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.NullReferenceException: Object reference not set to an instance of an object.
at RTWin7Lite.RT7LiteHome.RT7LiteHome_FormClosing(Object sender, FormClosingEventArgs e) in D:\Ben\4-8-2010\Final_state\RTWin7Lite\RTWin7Lite\RT7LiteHome.vb:line 517
at System.Windows.Forms.Form.WmClose(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)
CodeBase: file:///E:/Windows/Microsoft.NET/Framework64/v2.0.50727/mscorlib.dll
----------------------------------------
RTWin7Lite
Assembly Version: 1.3.0.0
Win32 Version: 1.3.0.0
CodeBase: file:///E:/Program%20Files/RT%207%20Lite/RTWin7Lite.exe
----------------------------------------
Microsoft.VisualBasic
Assembly Version: 8.0.0.0
Win32 Version: 8.0.50727.4927 (NetFXspW7.050727-4900)
CodeBase: file:///E:/Windows/assembly/GAC_MSIL/Microsoft.VisualBasic/8.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll
----------------------------------------
System
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)
CodeBase: file:///E:/Windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Windows.Forms
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)
CodeBase: file:///E:/Windows/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System.Drawing
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)
CodeBase: file:///E:/Windows/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System.Runtime.Remoting
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)
CodeBase: file:///E:/Windows/assembly/GAC_MSIL/System.Runtime.Remoting/2.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll
----------------------------------------
RTWin7Lite.resources
Assembly Version: 1.3.0.0
Win32 Version: 1.3.0.0
CodeBase: file:///E:/Program%20Files/RT%207%20Lite/en-US/RTWin7Lite.resources.DLL
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
<system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

3) and after pressing "Continue", the next one:

Requiered files are missing. Please reinstall the application.

Could anyone tell me how do I pray so this app starts up?

Edited by POMAH-PRESS

Share this post


Link to post
Share on other sites

I'm sorry... But WTF is this? I lunch this app on a just installed MSDN W7Pro x64 Eng (WAIK W7 installed too) and all I get is the error. Tried several times, reinstalling host W7...

Could anyone tell me how do I pray so this app starts up?

Tell me: Are you trying to use it on a Windows installation that has already been modified by some other person or program; a "Lite" version of Windows 7? Those error messages indicate that you are missing .NET version 2.0. Unless there is an issue with the specific language you are using, I'd doubt this is the fault of RT7 Lite.

Share this post


Link to post
Share on other sites

1) If you're talking about the host OS - it's MSDN W7 Pro, where everything is in place. I also tried it on a just installed one, the only modification to it was the WAIK, so it couldn't be messed up. And I never use Windows modified by anybody...

2) If you're talking about the guest, the one that I'm trying to modify - it's irrelevant at all, because I get the error the moment I start the app.

3) If I'm not mistaken, .Net Framework v2.0 - 3.5 is integrated into any W7, so I don't see how that could happen. I also don't understand why it is said to have .Net 3.5 while this app only works on NT6 which comes with it out of the box. Since it's original MSDN W7 image I'm using, it should be there, right?

4) The language question remains. Well, the host OS language is EN. The date, currency... format is set to Russian however, and the location is set to Ukraine. Could that make a difference?

Could you please tell me more about the potential language related issues. And what language exactly is in question here? Like host OS UI language or guest language, or what? Cause I'm at lost here...

Share this post


Link to post
Share on other sites

1) If you're talking about the host OS - it's MSDN W7 Pro, where everything is in place. I also tried it on a just installed one, the only modification to it was the WAIK, so it couldn't be messed up. And I never use Windows modified by anybody...

2) If you're talking about the guest, the one that I'm trying to modify - it's irrelevant at all, because I get the error the moment I start the app.

3) If I'm not mistaken, .Net Framework v2.0 - 3.5 is integrated into any W7, so I don't see how that could happen. I also don't understand why it is said to have .Net 3.5 while this app only works on NT6 which comes with it out of the box. Since it's original MSDN W7 image I'm using, it should be there, right?

4) The language question remains. Well, the host OS language is EN. The date, currency... format is set to Russian however, and the location is set to Ukraine. Could that make a difference?

Could you please tell me more about the potential language related issues. And what language exactly is in question here? Like host OS UI language or guest language, or what? Cause I'm at lost here...

Are you using the x64 version of RT Se7en Lite.

Share this post


Link to post
Share on other sites
Are you using the x64 version of RT Se7en Lite.

Yes... Why? Is there a difference? Should I use x86 one? I'm on Winx64.

Update: Tried x86 version 1.4.0 on W7 x86, same story, but I figured out a way to lunch the app by first pressing "quit" in an error window, and then pressing "Continue" in a second identical window. However, when I'm trying to do something I get the same error repeatedly... So no-go ( ...

Edited by POMAH-PRESS

Share this post


Link to post
Share on other sites

This program only works if you installed Win7 on the C:\ drive - and from what you posted above about error messages, if I read things correctly, you installed Win7 on the E:\ drive.

The fact RT 7 Lite mandates the user to adhere to their requirements, specifically - install Win7 to the C:\ drive, prevents many users from adopting the program. This issue has been mentioned to those responsible for the program and their position is: Tough!!! It's your problem - not ours.

Share this post


Link to post
Share on other sites

Hahaha)))... What a nice progie))))... Good luck to you, Dev's... With that kind of attitude and... "quality")))...

ChiefZeke: Thnx for clearing this up...

P.S. : vLite and DISM rule!)

P.P.S. : Nuhi is da BEST!)))

Share this post


Link to post
Share on other sites

Hahaha)))... What a nice progie))))... Good luck to you, Dev's... With that kind of attitude and... "quality")))...

ChiefZeke: Thnx for clearing this up...

P.S. : vLite and DISM rule!)

P.P.S. : Nuhi is da BEST!)))

boy there is a name from the past!! Nuhi has not been around for what? 3-4 years now. vlite was for vista not 7 and is not fully compatable with 7. give bensam his due, he is doing this for free just as nuhi did.

Share this post


Link to post
Share on other sites

Well, what Nuhi did several years before for Vista fully suits my needs today with my W7... And it is far more stable for me then this tool specifically designed for W7... vLite is a quality product, proven with time.

Share this post


Link to post
Share on other sites

Hahaha)))... What a nice progie))))... Good luck to you, Dev's... With that kind of attitude and... "quality")))...

ChiefZeke: Thnx for clearing this up...

P.S. : vLite and DISM rule!)

P.P.S. : Nuhi is da BEST!)))

Spam/troll??

Why all the "))))"? beacuse your 12 or what?

boy there is a name from the past!! Nuhi has not been around for what? 3-4 years now. vlite was for vista not 7 and is not fully compatable with 7. give bensam his due, he is doing this for free just as nuhi did.

So unfortunate Nuhi isnt here:(. I wish he would continue developing his great tools.

Share this post


Link to post
Share on other sites

Well, what Nuhi did several years before for Vista fully suits my needs today with my W7... And it is far more stable for me then this tool specifically designed for W7... vLite is a quality product, proven with time.

Yes beacuse its older and alot more feedback has been given..

7Lite is completely new, its not a stable release yet, only a beta... Why dont you wait 4-5 years and then say 7Lite isnt stable for Win7 as vLite is for vista..

Share this post


Link to post
Share on other sites

Hey everyone)... Cool down, LOL)... I'm just saying I'll stick to vLite, for now... And then, well... We'll see)...

And yes, having Nuhi back here would be really fantastic...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...