Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


x-Shadow-x

[Tool] Nero 9 Repacker - Alpha

Recommended Posts

This is just alpha, but I need some testers. It should work on all versions of Nero 9.

This will make an installer for Nero 9 rite in front of your eyes (Nero + Express, nothing else as of rite now).

Please, if you like it, I will continue making it for every other Nero app (and a GUI).

The instructions are in the zip, if you like it post here, if you have problems, also post here.

Mediafire

2Shared

Megaupload

Rapidshare (Traffic Share)

Uploading.com

Edited by x-Shadow-x

Share this post


Link to post
Share on other sites

OK, first try went pretty well, with a few queries and explanations required.

1. (and most serious) I received a lot of errors because nothing was found in TEMP, hence nothing extracted. Then I realized that your first batch "1. Extract CAB, Build Folders" contained folder name "NERO1005442", while in my temp the folder name was "NERO1004930". Having changed that title in the batch file, it started doing exactly what you say.

2. I noticed two different batches: "4. Make 7z" and "5. Compile". They both produced an appropriate file of approximately the same size (less than 18MB, which is really cool). I suppose they are both there for a reason, like creating a .7z archive, and then an SFX from that archive?

3. Thank you for adding silent switches (if I may add, a bit uncommon, which is a good idea IMHO)

Thank you

Share this post


Link to post
Share on other sites

Ah, I will have to fix that, i was worried about if the version would change the temp folder name, and it does. I will fix that.

Yes, one creates the 7z and the other creates the SFX.

Thanks for the info, and you are welcome. :thumbup

Fixed and reuploaded.

Edited by x-Shadow-x

Share this post


Link to post
Share on other sites

Well, I would further suggest you add the *.7z file to the cleanup list since the .exe is the final product, and it would probably be a good idea if you uploaded the tool to at least one more mirror. Due to many server requests, I couldn't download the new files for about an hour this morning.

Keep up the good work.

Share this post


Link to post
Share on other sites

I have two problems.

Downloaded "Nero-9.4.26.0_Trial.exe". I have valid serial and clean Windows.

Run the Installer (to extract), when finished, I closed the Installer.

I looked Temp folder, there is a folder named "NERO1005442".

"1. Extract CAB, Build Folders.bat"

I got error in consol.

"The file name, directory name or volume label syntax is incorrect, 0 files copied."

(setup.exe, ipclog.exe, unit_app_30)

So I manually copied files and folder.

"2. Serial Generator.bat"

Nero Installer showed, entered serial, It began to install, I got Installiation error (can't resume), skipped that, looked registry, no Nero entry.

"3. Extract Serial.bat"

So I got error, because there isn't a registry entry.

"4. Make 7z.bat"

"5. Compile.bat"

I got "Nero.exe".

Installed "Nero.exe", run from start menu, but not worked.

Maybe because I have no serial registry entry.

Can you add a "Serial.reg" (no serial, It could have a serial like XXXXX-XXXXX-XXXXX-XXXXX-XXXX), we can edit and fill our serial.

Edited by menes

Share this post


Link to post
Share on other sites

I had the same thing with the registry entry, but later it was there. Maybe it's simply a matter of restarting the PC.

Share this post


Link to post
Share on other sites

The serial generator is the most finicky part of it. I have an Idea for something else, going to try it.

There will also be an update later today.

Post programs you would like to see Repacked.

I don't know what programs people want to be Repacked.

Share this post


Link to post
Share on other sites

I was determined to create lite version. To get "Serial.reg", I should have set up the software. When I tried to setup full Nero, I got warning, which says I must install "Nero Product Patcher, ImagXPres, Microsoft CRT 2005 KB973544" (What are these things? I think we only need .NET 3.0 and Microsoft Visual C++ 2005). After setup this things, setup completed. Copied my language files to "Build" folder. Then I tried "3. Extract Serial.bat", but It gave error again. I looked bat file and registry, I found that both registry keys are wrong. First key is wrong address, second key is not exist. I manually got backup of "Serial.reg" to "Build" folder. Run "4. Make 7z.bat" and "5. Compile.bat". Uninstalled full Nero and cleaned registry and temp folders. Restarted. Tried to install lite "Nero.exe". And happy ending, It worked.

Edited by menes

Share this post


Link to post
Share on other sites

Sorry for the wrong address, I'm on x64 and trying to remember for x86. :wacko:

Would you mind sharing where you found your key in the registry?

Edited by x-Shadow-x

Share this post


Link to post
Share on other sites

HKLM/Software/Nero/Shared/Nero9/

But please take this relatively, as I'm out of town and using another PC. Maybe someone can confirm.

BTW, menes, I installed Nero9 without .NET 3.0, so I don't think it is a requirement. I only have .NET 2.0 SP2.

Share this post


Link to post
Share on other sites

HKLM/Software/Nero/Shared/Nero9/

Thats what I thought, maybe I just had it wrong. Big update, might be out tomorrow.

Share this post


Link to post
Share on other sites

I already had all .NETs. According to Nero (when downloading);

"This Software requires the Microsoft .NET Framework 3.0 to run on Windows XP. Please download and install from here."

Share this post


Link to post
Share on other sites

I hate to say this, but I had the same problem as menes in post #6, namely the first batch file finished, but did not copy setup(x).exe and ipclog.exe into N.Files/Serial.Getter. I copied them manually and got another error, something about files not matching or invalid product. This means I had more success with the first version (which I deleted).

Cheers

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...